Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Carlos Mosqueda 157 posts 246 karma points
    Jan 24, 2019 @ 19:04
    Carlos Mosqueda
    0

    Umbraco 7 and www and non-www configured on host throwing errors in the admin console.

    Umbraco 7 and www and non-www configured on host throwing errors in the admin console.

    When we put in our "Cultures and Hostnames" both our www and our non-www domains.

    www.domain.com domain.com

    When we do this, in the admin we get an error that looks like this: enter image description here

    If we remove the domain.com and keep the www.domain.com from the Umbraco domain settings, the error goes away. It seems like Umbraco can't tell between the two domains. Because it is throwing that error, we can't see our page URLs in the admin panel under the "Links"

    enter image description here

    If we remove the domain.com and keep the www.domain.com it we can see the links.

  • MuirisOG 360 posts 1218 karma points
    Feb 04, 2019 @ 13:41
    MuirisOG
    0

    In fact, you should probably only keep one of them anyway, and in IIS, set up a http redirect to the other canonical URL.

    You can for example, have an empty site in IIS, whose only function would be as a http redirect from e.g. domain.com to www.domain.com.

    Search engines and SEO in general like this approach.

    https://support.google.com/webmasters/answer/139066?hl=en

    Muiris

Please Sign in or register to post replies

Write your reply to:

Draft