Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Sjoerd Stottelaar 15 posts 141 karma points
    Feb 08, 2019 @ 15:49
    Sjoerd Stottelaar
    0

    Missing Culture Bug in Back-Office

    Hi There,

    I'm experiencing a bug in the back-office that happens when I want to sort nodes in the content tree and when viewing a list view in the back-office. The error message is giving me this:

     Error mapping types.
    
     Mapping types:
     IContent -> ContentItemBasic`1
     Umbraco.Core.Models.IContent -> Umbraco.Web.Models.ContentEditing.ContentItemBasic`1[[Umbraco.Web.Models.ContentEditing.ContentPropertyBasic, Umbraco.Web, Version=8.0.0.0, Culture=neutral, PublicKeyToken=null]]
    
     Type Map configuration:
     IContent -> ContentItemBasic`1
     Umbraco.Core.Models.IContent -> Umbraco.Web.Models.ContentEditing.ContentItemBasic`1[[Umbraco.Web.Models.ContentEditing.ContentPropertyBasic, Umbraco.Web, Version=8.0.0.0, Culture=neutral, PublicKeyToken=null]]
    
     Property:
     UpdateDate
    

    And

    System.InvalidOperationException: Missing culture in mapping options.
    

    I've researched a little bit and found a Github issue from a while back. I currently use version 8.0.0-alpha.58.2084 and it's still happening. Does anyone know a workaround or a way to fix this issue?

    Much appreciated!

  • Sjoerd Stottelaar 15 posts 141 karma points
    Feb 11, 2019 @ 11:01
    Sjoerd Stottelaar
    100

    After some debugging, I found that the solution is to add a second language. In my case, the default language was set to en-US and I've added "Allow varying by culture" to all my property editors. Once I've added a second language in the back-office the bug with sorting was fixed.

    This still remains a bug in the current build (8.0.0-alpha.58.2084), so I hope this will be fixed in an upcoming release.

Please Sign in or register to post replies

Write your reply to:

Draft