Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Søren Tidmand 116 posts 331 karma points
    Mar 05, 2019 @ 15:07
    Søren Tidmand
    0

    Hi,

    I've got an issue that has been reported a long time ago but still is messing things up abit. When working with the DocTypeGridEditor I randomly get a ton of errors like

    enter image description here

    I found out that it might have something to do with an issue with a trimStart function introduced in Chrome 66, but since I'm working with the 7.13.2 version of Umbraco I would expect that it had been solved. So the following two links doesn't help me further:

    https://issues.umbraco.org/issue/U4-11253

    https://github.com/umco/umbraco-doc-type-grid-editor/issues/97

    Apparently the issue isn't connected directly to the DTGE, although I've only encountered problems when using that great plugin and I'd be sorry to stop using it.

    Of course a hard reload of Chrome helps, but it will turn up again and is disturbing for the end user (customer).

    So my question is does anybody know of any fixes for this issue?

    Thanks, Søren

  • Søren Kottal 430 posts 2622 karma points MVP c-trib
    Mar 05, 2019 @ 19:40
    Søren Kottal
    0

    Hi Søren :)

    Have you tried bumping the version number in /config/ClientDependency.config?

  • Jesper Ordrup 975 posts 1411 karma points MVP
    Mar 05, 2019 @ 22:38
    Jesper Ordrup
    0

    Hi Søren K,

    We definitely have tried that. Its really sticky :-)

    Bumping CD version

    Restarting app

    Clearing browser cache

    Even trying to load the damn site using another url.

    Problem persists.

  • Jesper Ordrup 975 posts 1411 karma points MVP
    Mar 06, 2019 @ 05:53
    Jesper Ordrup
    100

    Update

    The problem looks like being a third part javascript library (messenger.js from small.chat) as it redefines the trimStart method.

    When this widget is loaded the trimStart is no longer working.

    Note, this problem has nothing to do with Umbraco or dtge - both are still awesome.

    I've reported this to small.chat

Please Sign in or register to post replies

Write your reply to:

Draft