Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Rotem Orbach 99 posts 532 karma points
    Mar 20, 2019 @ 12:05
    Rotem Orbach
    0

    Cannot publish after upgrade

    Hi All, I've upgraded Umbraco from version 7.4.3 to 7.13.2 From some reason, every time I try to publish a page, I get the following error:

    POST http://www.jtpcopy.com/umbraco/RestServices/BulkPublish/PublishDocument 417 (Expectation Failed)
    

    enter image description here

    any idea what this might be?

  • Alex Skrypnyk 5371 posts 19862 karma points MVP 3x admin c-trib
    Mar 20, 2019 @ 12:12
    Alex Skrypnyk
    0

    Hi Rotem

    Did you clean browser cache and change ClientDependency version? It might be the wrong js part.

    Here are the steps to clear the ClientDependency cache:

    • Delete files in /AppData/TEMP/ClientDependency (might be in /data or /AppData/ClientDependency depending on your install)

    • Open /config/clientDependency.config and increase the version attribute by

    • Touch your web.config

    Hope this helps,

    Thanks,

    Alex

  • Rotem Orbach 99 posts 532 karma points
    Mar 20, 2019 @ 12:27
    Rotem Orbach
    0

    Hi Alex, Thanks, but unfortunately it does not work.

  • Nik 1144 posts 4732 karma points MVP 2x c-trib
    Mar 20, 2019 @ 12:55
    Nik
    0

    Hi Rotem,

    When you did the upgrade did you follow the version specific upgrade steps as well?

    As you were going from version 7.4 to version 7.13, there are a few different version specific steps that need to be checked. ( https://our.umbraco.com/documentation/Getting-Started/Setup/Upgrading/version-specific )

    Also, was this upgrade performed via NuGet?

    Thanks

    Nik

  • Rotem Orbach 99 posts 532 karma points
    Mar 20, 2019 @ 12:59
    Rotem Orbach
    0

    Hi Nik. Yes, I followed all the steps and upgraded via Nuget. I might add that this upgrade works perfectly fine in Dev and in staging environment. One hint that might be related: I've upgraded in production environment, but to a dummy website, without Https (just a local iis site).

    Can it be related?

    thanks

  • Nik 1144 posts 4732 karma points MVP 2x c-trib
    Mar 20, 2019 @ 13:03
    Nik
    0

    It's possible, if your web config is saying this in app settings:

    <add key="umbracoUseSSL" value="true" />

    Then you could be getting that issue, but I'm not certain. Not seen a 417 error before.

  • Rotem Orbach 99 posts 532 karma points
    Mar 20, 2019 @ 13:05
    Rotem Orbach
    0

    Hi Nik, Unfortunately it does not.

    <add key="umbracoUseSSL" value="false" />
    

    This error is an anigma

  • Alex Skrypnyk 5371 posts 19862 karma points MVP 3x admin c-trib
    Mar 20, 2019 @ 13:06
    Alex Skrypnyk
    0

    Rotem, did you merge all needed config files successfully?

  • Rotem Orbach 99 posts 532 karma points
    Mar 20, 2019 @ 13:14
    Rotem Orbach
    0

    Hi Alex, Not sure actually. Trees.config and Dashboard.config are two separate files, so i'm not sure what you meant by "merge", but as I was saying, the same version of code is working flawlessly on stage and dev. I can only suspect a missing file or web.config issue..

  • Rotem Orbach 99 posts 532 karma points
    Mar 20, 2019 @ 13:21
    Rotem Orbach
    0

    one more thing that might assist. I sometimes get the following error when I select a page for the first time:

    LegacyTreeJs?umb__rnd=8551290a06a0099f6bfc739febb53527:12 Uncaught TypeError: Cannot read property 'treeEventHandler' of undefined
        at LegacyTreeJs?umb__rnd=8551290a06a0099f6bfc739febb53527:12
    (anonymous) @ LegacyTreeJs?umb__rnd=8551290a06a0099f6bfc739febb53527:12
    setTimeout (async)
    (anonymous) @ LegacyTreeJs?umb__rnd=8551290a06a0099f6bfc739febb53527:12
    DependencyHandler.axd,qs=L3VtYnJhY29fY2xpZW50L3VpL2pxdWVyeS5qczsvdW1icmFjb19jbGllbnQvdWkvanF1ZXJ5dWkuanM7L3VtYnJhY28vbGliL2pxdWVyeS1taWdyYXRlL2pxdWVyeS1taWdyYXRlLm1pbi5qczs,at=Javascript,acdv=1600000000.pagespeed.jm.eleBWttKTP.js:1 JQMIGRATE: Migrate is installed, version 1.4.0
    
  • Alex Skrypnyk 5371 posts 19862 karma points MVP 3x admin c-trib
    Mar 20, 2019 @ 13:34
    Alex Skrypnyk
    0

    Trees.config and Dashboard.config should be merged or just try to use ones from the latest version.

  • Rotem Orbach 99 posts 532 karma points
    Mar 20, 2019 @ 13:53
    Rotem Orbach
    0

    Hi Alex, I've downloaded UmbracoCms.7.13.2.zip and took a look in tree.config and dashboard.config. It's two separate files ,and the content is identical to what I currently have, so that is not the issue. Furthermore, trees.config and dashboard config are responsible on the left hand tree, and on the image one sees when clicking on one of the branches, so it has nothing to do with the problem at hand :)

  • Alex Skrypnyk 5371 posts 19862 karma points MVP 3x admin c-trib
    Mar 20, 2019 @ 14:03
    Alex Skrypnyk
    0

    Why did you upgrade to 7.13.2? 7.14 is the latest one

  • Rotem Orbach 99 posts 532 karma points
    Mar 20, 2019 @ 14:05
    Rotem Orbach
    0

    I upgraded my dev and stage 2 months ago, so now I'm trying to do the same on production. Didn't have time for that up until now :)

  • Rotem Orbach 99 posts 532 karma points
    Mar 24, 2019 @ 08:11
    Rotem Orbach
    100

    Ok, I solved the issue. A quick explanation: When One tries to publish, a POST request is being sent by the handler to Umbraco's server (RestServices). The server expects a specific HTTP Header to be sent along with that request. x-umb-xsrf-token (xsrf is Angular's version of csrf - Croos Site Resource Forgery). This token is compiled from a random GUID and the session ID (it meant to prevent someone calling this service from afar and publish in your behalf, so this token identifies you as the user). Anyway, to make a long story short, this token was undefined, and that's why I got this 417 (Expectation failed).

    The resolution was quite simple: It appeared that my web.config's compilation tag had debug set to "true" (A huge mistake by itself). Setting it to "false" solved the issue.

    Now I get the token when I'm trying to publish: enter image description here

Please Sign in or register to post replies

Write your reply to:

Draft