Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Nancy A. 44 posts 175 karma points
    May 01, 2019 @ 13:45
    Nancy A.
    0

    Umbraco 8 - looking in Visual Studio, where are the files I created in Solution Explorer?

    Ok, I feel like an idiot. I'm building a website w/ Umbraco 8; I've downloaded the files for Umbraco to an empty project and created a layout file and a homepage file and their corresponding editor files. The layout I've created shows up in the browser. However, when I look at VS, I don't see any of the files that I've created in the Solution Explorer nor can I access the database that was created locally.

    I CAN see these files in the file explorer but they're not showing up in VS.

    They were easier to locate in Umbraco 7.

  • bdsoko 4 posts 93 karma points
    May 01, 2019 @ 14:21
    bdsoko
    0

    Hi Nancy,

    I found that templates created in Umbraco's back-office don't automatically get included in Visual Studio's project file. In VS, you'll need to show hidden files and include them. As for getting access to the SQL CE database, I use the "SQLite/SQL Server Compact Toolbox" VS extension. Seems to work pretty well for my needs. You can find the extension here: https://marketplace.visualstudio.com/items?itemName=ErikEJ.SQLServerCompactSQLiteToolbox

  • Frans de Jong 499 posts 1708 karma points c-trib
    May 01, 2019 @ 14:22
    Frans de Jong
    0

    You need to reload the folder where the files are located in visual studio.

    richtclick the folder and refresh

  • Nancy A. 44 posts 175 karma points
    May 01, 2019 @ 14:42
    Nancy A.
    0

    Tried that, and still wasn't seeing the files. But what did work was clicking on the 'Solutions and Folders' button above the Solution Explorer panel, it looks like it's switching between two different folder types, one being the solution (not showing the Umbraco folder), the other the folder that contains all the files (where I found the Umbraco folder). I can run the files in the browser for the former but I don't have that option for the latter. Any particular reason why it's set up this way?

  • Bryna 66 posts 228 karma points
    May 01, 2019 @ 16:04
    Bryna
    0

    Make sure to show hidden files. That will cause a ghosted folder to show up and you can right click and say include in project.

  • Søren Gregersen 316 posts 1269 karma points MVP c-trib
    May 01, 2019 @ 16:37
    Søren Gregersen
    0

    VS only shows files in a project.

    Do you have a screenshot of what you are working with?

Please Sign in or register to post replies

Write your reply to:

Draft