Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Paul McCarthy 25 posts 125 karma points
    May 09, 2019 @ 17:22
    Paul McCarthy
    0

    Examine Index content set not updating

    I have added a nodeTypeAlias to a content set (Article Content Set) in the ExamineIndex.config file. When I build locally it appears in the Examine Management panel in the back office. However, when I publish to the web app the index does not update. (My new node type is not added to the list).

    Have tried: Publishing whole app Restarting web app Republishing site Rebuilding index Creating a page using that doctype

    Nothing works. Any ideas?

  • Matt Barlow 131 posts 532 karma points
    May 09, 2019 @ 22:37
    Matt Barlow
    100

    Have you verified that the ExamineIndex.config file on your published instance contains the additional nodeTypeAlias?

    Perhaps there is something wrong with your deployment process, and the file isn't being updated.

    Also double checked that the nodeTypeAlias of the content on your published instance is exactly the same as what's in the ExamineIndex.config?

  • Paul McCarthy 25 posts 125 karma points
    May 10, 2019 @ 14:23
    Paul McCarthy
    0

    Going to mark as solution as you led me in the right direction. An error in a config .xslt file was pointing the target environment at the wrong Examine.Settings.config file. Once I fixed that it all worked.

    Thanks for your help!

  • Paul McCarthy 25 posts 125 karma points
    May 10, 2019 @ 07:19
    Paul McCarthy
    0

    Hi Matt Thanks for your suggestions. Yes, I can see the change made when I inspect the ExamineIndex.config file in Azure and the node type is definitely the same. Indeed when I build locally it’s against the database for this instance (it’s a dev instance).

Please Sign in or register to post replies

Write your reply to:

Draft