Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Gibran Shah 37 posts 178 karma points
    May 13, 2019 @ 02:47
    Gibran Shah
    0

    The type or namespace name 'Personnel' does not exist in the namespace 'Umbraco.Web.PublishedContentModels'

    Hello,

    I just created a new page call Personnel and I'm getting the following error:

    enter image description here

    It consists of a document type called Personnel, a template called Personnel, and a content page called Personnel.

    The top of the template looks like this:

    @inherits Umbraco.Web.Mvc.UmbracoTemplatePage

    IOW, everything looks right but I still get the error above.

    The only thing I can think of is that when I first created the page, I misspelled it as "Personelle". When I do a search for "Personelle" in Visual Studio, it comes up with these four lines in umbraco.config:

    <!ELEMENT personelle ANY>
    <!ATTLIST personelle id ID #REQUIRED>
    ...
    <personelle id="1306" key="a3ff374f-c358-4daf-9016-e759aeb4be47" parentID="1106" level="2" creatorID="0" sortOrder="21" createDate="2019-03-03T18:40:19" updateDate="2019-05-08T20:21:15" nodeName="Personnel" urlName="personnel" path="-1,1106,1306" isDoc="" nodeType="1425" creatorName="Mitch Wardrop" writerName="Gibran Shah" writerID="1" template="1429" nodeTypeAlias="personelle" isPublished="true">
    ...
    </personelle>
    

    I tried correcting these but that just messed everything up.

    Can anyone tell what's wrong?

Please Sign in or register to post replies

Write your reply to:

Draft