Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • liran 59 posts 140 karma points
    Jun 16, 2019 @ 10:42
    liran
    0

    change umbraco admin url

    hi, i need to change /UMBRACO/ url for the Backoffice. i need to do this for security reasons. i have changed in the web.config the "umbracoReservedPaths" and "umbracoPath" but then i hade a problem with "/umbraco/surface/..." links.

    is there a way to change /UMBRACO/ without the rest of the path demaged?

  • Søren Gregersen 436 posts 1876 karma points MVP 2x c-trib
    Jun 16, 2019 @ 13:34
    Søren Gregersen
    0

    Hi,

    Have you read the documentation on this: https://our.umbraco.com/documentation/Reference/Security/Security-hardening/

    It also covers the controllers

  • liran 59 posts 140 karma points
    Jun 17, 2019 @ 06:35
    liran
    0

    i read this, this is not working very well, when i added the rule

    <rule name="Allowed IPs" stopProcessing="true">
    <match url="^(?:app_plugins|config|umbraco|umbraco_client)(?:/|$)" />
    <conditions>
        <add input="{REMOTE_ADDR}" negate="false" pattern="213.3.10.8|88.4.43.108”>
    </conditions>
    <action type=”AbortRequest” />
    

    it blocked the entire website.

  • liran 59 posts 140 karma points
    Jul 28, 2020 @ 11:25
    liran
    0

    i found the solution:

                    <rule name="BlockUmbracoManagment" enabled="true" stopProcessing="true">
                    <match url="^(?:umbraco)(?:/|$)" />
                    <action type="AbortRequest" />
                    <conditions>
                        <add input="{REMOTE_ADDR}" matchType="Pattern" pattern="127.0.0.1|2.52.*.*|5.28.128.*|5.29.*.*|5.102.*.*|5.144.*.*|31.44.*.*|31.154.*.*|31.168.*.*|31.210.*.*|37.19.*.*|37.19.*.*|37.46.*.*|37.142.*.*|46.*.*.*|62.*.*.*|77.*.*.*|79.*.*.*|80.*.*.*|81.5.*.*|81.218.*.*|82.*.*.*|83.*.*.*|84.*.*.*|85.*.*.*|87.*.*.*|91.*.*.*|92.61.*.*|92.240.*.*|93.*.*.*|94.159.*.*|94.188.*.*|94.230.*.*|95.*.*.*|109.186.*.*|109.226.*.*|109.253.*.*|128.139.*.*|132.*.*.*|138.134.*.*|141.226.*.*|147.233.*.*|147.234.*.*|147.235.*.*|147.236.*.*|147.237.*.*|148.76.*.*|149.76.*.*|164.138.*.*|176.12.*.*|176.13.*.*|176.*.*.*|188.120.*.*|192.114.*.*|192.115.*.*|192.116.*.*|192.117.*.*|192.118.*.*|194.29.*.*|194.90.*.*|209.206.*.*|212.*.*.*|213.*.*.*|217.*.*.*|199.203.234.*|109.64.60.117|89.139.214.*|109.64.16.237|109.65.72.*" ignoreCase="true" negate="true" />
                        <add input="{URL}" pattern="/umbraco/surface" negate="true" />
                    </conditions>
                </rule>
    
  • Rihab 104 posts 388 karma points
    Aug 12, 2020 @ 10:35
    Rihab
    0

    Hi liran. where did you add these configurations?

  • liran 59 posts 140 karma points
    Apr 26, 2021 @ 12:31
    liran
    0

    in web.config file (URL Rewrite)

Please Sign in or register to post replies

Write your reply to:

Draft