Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Connie DeCinko 95 posts 247 karma points
    Jun 25, 2019 @ 19:00
    Connie DeCinko
    0

    AutoMapper version conflict?

    Trying to get Azure Active Directory setup and configured correctly. One sample uses UseWindowsAzureActiveDirectoryBearerAuthentication but when I try and add the necessary reference I get this error:

    Attempting to resolve dependencies for package 
    'Microsoft.Owin.Security.ActiveDirectory.4.0.1' with DependencyBehavior 
    'Lowest'
    Unable to find a version of 'AutoMapper' that is compatible with 
    'UmbracoCms.Core 7.13.2 constraint: AutoMapper (>= 3.3.1 && < 4.0.0)'.
    

    I have AutoMapper 3.3.1 installed.

  • Thomas Rydeen Skyldahl 47 posts 226 karma points
    Jun 25, 2019 @ 21:25
    Thomas Rydeen Skyldahl
    0

    I think the output is wrong, as 'Microsoft.Owin.Security.ActiveDirectory.4.0.1' doesn't have a dependency on 'AutoMapper'

    I tried installing the packages in reverse order on a new WebApplication

    Where I installed the packages in the following order

    1. 'Microsoft.Owin.Security.ActiveDirectory.4.0.1'
    2. 'UmbracoCms' version 7.13.2

    Here is the error message in that case:

    Unable to resolve dependencies. 'Microsoft.Owin.Security.OAuth 4.0.1' is not compatible with 'UmbracoCms.Core 7.13.2 constraint: Microsoft.Owin.Security.OAuth (>= 3.1.0 && < 4.0.0)'.

    So it seems to be a compatibility issue between the Microsoft.Owin.Security.OAuth used by Umbraco and the one you are trying to install.

Please Sign in or register to post replies

Write your reply to:

Draft