Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Dan Evans 605 posts 957 karma points
    Jul 24, 2019 @ 08:36
    Dan Evans
    0

    The default behaviour for this in Umbraco is set to "on/true" - is there a way to turn this off? I know it only creates a pointer but it's confusing to users.

  • Erik-Jan Westendorp 29 posts 281 karma points MVP c-trib
    Jul 26, 2019 @ 11:55
    Erik-Jan Westendorp
    0

    Hi Dan,

    There is no config setting or something to change this default behavior. In Umbraco.Editors.CopyController the "relate to original" option will be set to true by default. If you really want to change it you can do it here.

    angular.module("umbraco").controller("Umbraco.Editors.Content.CopyController",
    function ($scope, userService, eventsService, contentResource, navigationService, appState, treeService, localizationService, notificationsService) {
    
        var searchText = "Search...";
        localizationService.localize("general_search").then(function (value) {
            searchText = value + "...";
        });
    
        $scope.relateToOriginal = true;
        $scope.recursive = true;
        $scope.dialogTreeApi = {};
    
        etc.....
    

    You can find it here:

    https://github.com/umbraco/Umbraco-CMS/blob/v8/dev/src/Umbraco.Web.UI.Client/src/views/content/content.copy.controller.js

  • Splinx 47 posts 182 karma points
    Feb 18, 2020 @ 14:56
    Splinx
    0

    Hi Dan,

    Did you ever find a solution to this that did not involved editing the standard Umbraco install and recompiling?

    I agree with you that this setting SHOULD NOT be checked by default because I would wager that 99% of people copying do not see this checkbox let alone even understand the ramifications of checking it.

    Cheers,

    Splinx

Please Sign in or register to post replies

Write your reply to:

Draft