Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Rasmus Olofsson 4 posts 85 karma points
    1 week ago
    Rasmus Olofsson
    0

    [V8] Prevent page from being createable in the document tree

    Hi,

    I have created a document type as a template that I only use as a composition for other pages to inherit. I do not want this template page to be createable in the document/page tree.

    Does anyone know if it is possible to prevent it from appearing in the list of document type templates when trying to create a new page?

    Kind regards

  • Rhys Hamilton 135 posts 888 karma points
    1 week ago
    Rhys Hamilton
    2

    If you access your Composition Document Type and navigate to its Templates tab. You should be able to remove the template from here to prevent it being selected.

    Alternatively, you could simple delete the template if you never intend to use it by removing it from the Templates folder in Settings.

  • Rasmus Olofsson 4 posts 85 karma points
    1 week ago
    Rasmus Olofsson
    0

    Thanks your the reply.

    I have accessed my composition document type and removed the template from there. I have also deleted the template from the Templates folder in settings. But the page still shows up as createable in the list, and I can create the page. Visiting the page however creates an error message saying a template does not exist for it.

    enter image description here

  • Rhys Hamilton 135 posts 888 karma points
    1 week ago
    Rhys Hamilton
    100

    Ah, I see what you mean now!

    By default, Umbraco will display all document types as under Content (at least according to this issue).

    To prevent this, if you access your Document Type(s) and navigate to the Permissions tab, you should see an option to "Allow at Root".

    Check this for the document types you wish to show and the rest should no longer appear.

  • Rasmus Olofsson 4 posts 85 karma points
    1 week ago
    Rasmus Olofsson
    1

    Thanks, it works!

Please Sign in or register to post replies

Write your reply to:

Draft