Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Dan 3 posts 73 karma points
    Aug 16, 2019 @ 01:40
    Dan
    0

    Umbraco removes html spacing

    We do a lot of custom HTML editing of pages using the source code editor on a page.

    After clicking OK in the code editor, Umbraco seems to remove all forms of spacing in the html, which makes it a pain in the ass to make small incremental changes to pages.

    Is there a master setting somewhere, to stop umbraco doing this automatically?

    I can't think of another CMS that does this.

  • Shaishav Karnani from digitallymedia.com 330 posts 1562 karma points
    Aug 16, 2019 @ 06:00
    Shaishav Karnani from digitallymedia.com
    0

    You can try these settings to allow all elements and stop umbraco to make changes.

    In TinyMCE.config, you can change validElements to below:-

    In umbracosettings.config, you can add TidyEditorContent

  • Dan 3 posts 73 karma points
    6 days ago
    Dan
    0

    Thank you Shaishav.

    Will this stop Umbraco from stripping out <style></style> from the code too?

Please Sign in or register to post replies

Write your reply to:

Draft