Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Babak Momen 2 posts 72 karma points
    Sep 08, 2019 @ 18:17
    Babak Momen
    0

    Does uSync work with Umbraco version 7.15.1?

    I've tried to use uSync to transfer content between my live and debug site but I am having trouble getting the content to actually appear in the backoffice. I am using Umbraco 7.15.1 with uSync Backoffice 4.0.14 and uSync Content 4.17.

    The files seem to export okay, however the import does not seem to add the content and site structure (without giving any errors). I have noticed 7.15.X is untested on the package page so this could very well be the reason why it doesn't work. Could someone please confirm and guide me in the right direction if I am doing something wrong? Thanks.

  • David Sheiles 60 posts 283 karma points
    Sep 20, 2019 @ 01:05
    David Sheiles
    0

    I've had the same issue occur with the latest uSync. Downgrading uSync seemed to solve it for me.

    I have posted a an issue, so please add any additional that you might want to add - https://github.com/KevinJump/uSync/issues/236

  • Kevin Jump 1625 posts 10317 karma points MVP 3x c-trib
    Sep 20, 2019 @ 08:46
    Kevin Jump
    0

    Hi,

    I have run a couple of tests, and upgrades and it seems to be working for me :(

    there is an issue in the final summary line isn't being reported for content, which is inconvenient. but i suspect this probibly a result of how Content is checked and imported.

    Unlike other settings/items, content isn't imported if the file is diffrent, it is imported if the content is newer, this means the content handlers check the updated date in the usync file and that of the content and if the import only happens if the file updated date is newer than that of the content

    this is configurable in the uSyncCore.config file

    <!-- content Match used by core: 
         Newer: we use the date, so only newer content is updated (this is the historical default)
         Mismatch : updates happen if the content is diffrent (so irespective of update dates)
    -->
    <ContentMatch>Newer</ContentMatch>
    

    What the default behavior means is if you try and import content by either just changing the file or changing the content on the target - then it wont import because the file date wont be greater than that of the content on the box. Its a slight pain but as you can see its a historical behavior which we have had for a while and can't flip by default without potentially messing a lot of people up. (in v8 mismatch is how it works all the time)

    If its still not working after this, then if you can up the logging (as per the uSync Issue) and we can see if we can track any other issues down.

    In the meantime we will fix the logging, because that's annoying!

  • Babak Momen 2 posts 72 karma points
    Sep 29, 2019 @ 18:43
    Babak Momen
    0

    Hi Kevin, thanks for the response. Unfortunately I am still experiencing issues - the content still won't appear! I will send you a log file including the Jumoo debug as well as the completed usync report.

Please Sign in or register to post replies

Write your reply to:

Draft