Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Sven 4 posts 94 karma points
    Sep 17, 2019 @ 12:50
    Sven
    0

    Multi-Site in V8 results in "random" content (first requested site wins)

    Maybe I simply didn't get it, but I am a bit confused about the random behavior of umbraco in my multi-site configuration:

    • I have configured two root nodes ("home" and "app")
    • Both have different "Hostnames" configured: "home.mydomain.com" and "app.mydomain.com".
    • I configured two CNAME entries in my DNS (one for each domain) to point to my Azure App Service hosting the umbraco application.

    My expectation would be that I can use one domain name for one root node and the other domain name for the other root node.

    Unfortunately, the first one wins:

    • when I clear all cached and open "http://home.mydomain.com", I get the content of "home" in both "http://home.mydomain.com" and "http://app.mydomain.com"
    • when clearing the cache and opening "http://app.mydomain.com", I get the content of "app" for both urls.

    I hope it's just a little checkbox I currently don't find. I already tried adding "" to my umbracoSettings.config, but that setting has been removed. Also tried urlProviderMode="Absolute" without success.

  • Sven 4 posts 94 karma points
    Sep 19, 2019 @ 12:37
    Sven
    100

    Found it: https://our.umbraco.com/documentation/getting-started/setup/server-setup/azure-web-apps#umbraco-xml-cache-file-and-other-temp-files

    So, basicalle an RTFM-problem, but I would strongly recommend to use EnvironmentTemp by default. The default should be the most secure and the most compatible.

Please Sign in or register to post replies

Write your reply to:

Draft