Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Jake 2 posts 72 karma points
    Oct 16, 2019 @ 19:16

    Umbraco 8 Azure deployment bootfail

    I am trying to deploy my Umbraco website to an Azure app service. The solution works and builds locally fine, but when I deploy there is a boot fail(error pasted below). The fail seems to be pointing to Our.Umbraco.FileSystemProviders.Azure. I tried installing the nuget package UmbracoFileSystemProviders.Azure but that didnt fix anything after filling out the FileSystemProviders.config. I uninstalled the nuget package and it worked locally again, but I still can not get to work on the deployed Azure site.

    I pasted my packages.config section showing my Umbraco versions and then also the boot fail output. Any help would be greatly appreciated!

    • "Umbraco.ModelsBuilder" version="8.1.0"
    • "Umbraco.ModelsBuilder.Ui" version="8.1.0"
    • "Umbraco.SqlServerCE" version=""
    • "UmbracoCms" version="8.2.0" "UmbracoCms.Core" version="8.2.0"
    • "UmbracoCms.Web" version="8.2.0"

    Server Error in '/' Application. Boot failed: Umbraco cannot run. See Umbraco's log file for more details.

    -> Umbraco.Core.Exceptions.BootFailedException: Boot failed.

    -> System.Reflection.ReflectionTypeLoadException: Could not load all types from "Our.Umbraco.FileSystemProviders.Azure, Version=, Culture=neutral, PublicKeyToken=null" due to LoaderExceptions, skipping: . System.TypeLoadException on Our.Umbraco.FileSystemProviders.Azure.AzureBlobFileSystem: Method 'GetSize' in type 'Our.Umbraco.FileSystemProviders.Azure.AzureBlobFileSystem' from assembly 'Our.Umbraco.FileSystemProviders.Azure, Version=, Culture=neutral, PublicKeyToken=null' does not have an implementation. . System.TypeLoadException on Our.Umbraco.FileSystemProviders.Azure.AzureFileSystem: Method 'GetSize' in type 'Our.Umbraco.FileSystemProviders.Azure.AzureFileSystem' from assembly 'Our.Umbraco.FileSystemProviders.Azure, Version=, Culture=neutral, PublicKeyToken=null' does not have an implementation. . System.TypeLoadException on Umbraco.Core.ApplicationEventHandler: Could not load type 'Umbraco.Core.ApplicationEventHandler' from assembly 'Umbraco.Core, Version=, Culture=neutral, PublicKeyToken=null'.

    at Umbraco.Core.Composing.TypeFinder.GetTypesWithFormattedException(Assembly a) in d:\a\1\s\src\Umbraco.Core\Composing\TypeFinder.cs:line 569 at Umbraco.Core.Composing.TypeFinder.GetClassesWithBaseType(Type baseType, IEnumerable1 assemblies, Boolean onlyConcreteClasses, Func2 additionalFilter) in d:\a\1\s\src\Umbraco.Core\Composing\TypeFinder.cs:line 504 at Umbraco.Core.Composing.TypeFinder.FindClassesOfType[T](IEnumerable1 assemblies, Boolean onlyConcreteClasses) in d:\a\1\s\src\Umbraco.Core\Composing\TypeFinder.cs:line 346 at Umbraco.Core.Composing.TypeLoader.<>c__DisplayClass50_01.

  • Sjors Pals 617 posts 270 karma points
    Oct 31, 2019 @ 14:32
    Sjors Pals

    Same problem here, it did work with an Umbraco Package, but since I want to rely on Nuget that's not an option.

  • Chris Evans 137 posts 353 karma points c-trib
    Nov 01, 2019 @ 03:37
    Chris Evans

    Umbraco 8 has a new package for handling the Azure media:

    The one you're installing is for Umbraco 7 so it won't work with v8.

    You can find more details about how to configure the v8 package here:

Please Sign in or register to post replies

Write your reply to: