Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Noor 5 posts 75 karma points
    Oct 17, 2019 @ 13:15
    Noor
    0

    Umbraco cloud deployment issue

    Hello

    We are tried all options to fix this but......

    Error while extracting Umbraco data This environment encountered an error while trying to extract Umbraco data, during a previous deployment

    The environment contains a deploy-failure marker file, which indicates that extraction of Umbraco data, faulted on a previous deployment. To move forward, ensure that all templates, document types etc. are properly saved, and that you dont have duplicated .courier files in the data folder.

    You can find more help by checking the offical troubleshooting documentation or by contacting support

    Error Message Could not get master template with id c53fe114-dbaa-469d-ad69-5e43bf26f76f.

    enter image description here

  • Magnus Eriksson 122 posts 362 karma points
    Oct 17, 2019 @ 13:25
    Magnus Eriksson
    0

    Have you tried contacting Umbraco Cloud support?

    Regards, Magnus

  • Noor 5 posts 75 karma points
    Oct 17, 2019 @ 13:29
    Noor
    0

    Yes I am talking to them but still they couldn't a solution.

  • Paul Sterling 716 posts 1512 karma points MVP 6x admin c-trib
    Oct 17, 2019 @ 17:06
    Paul Sterling
    0

    Hi Noor -

    When I've seen this before it has been due to a template being created in more than one environment with the same alias. I.e., a template with the alias master may have been created in both your local and dev environments but, since each item is assigned a unique ID there is a mis-match when Deploy is looking for the template using the ID. The confusing part is that the actual template file (in ~/views/master.cshtml) can be identical in all environments but the ID is different, so Deploy can't find it. The error you provided is consistent with this:

    Could not get master template with id c53fe114-dbaa-469d-ad69-5e43bf26f76f.

    To confirm is this is the case for you, try a schema deployment. Make a small change to a file and commit to git (not the template file in question though), then do a schema deploy using git push. If you see a schema mis-match message you know you're on the right track and can follow the docs here to help get things straightened out:

    https://our.umbraco.com/documentation/Umbraco-Cloud/Troubleshooting/Deployments/Schema-Mismatches/

    If that's not it, perhaps you can post back here the contents of the detailed error message?

    -Paul

Please Sign in or register to post replies

Write your reply to:

Draft