Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • prinneh 2 posts 22 karma points
    Apr 21, 2015 @ 23:00
    prinneh
    0

    Upgrading Umbraco 4.7.1 to 4.7.2 and beyond - Complete newbie

    Hi everyone, first off I’d like to admit that I’m very much out of my depth here, but I am trying to upgrade an umbraco website from version 4.7.1 to 4.7.2, following the directions given here: http://www.blix.co/blog/2014/6/5/follow-the-path-upgrading-umbraco-from-v4-to-v7.aspx , and ultimately hoping to upgrade all the way from 4.7.1 to version 7.

    But something is going wrong: After upgrading (moving the config, install, umbraco, umbraco-client and the bin folders from the 4.7.2 cms to our ftp) and the install running without a hitch, the images on the front page disappear and a few product images also disappear, but the real trouble happens in the backend/back-office. Logging into umbraco, I can see all the groups of products etc that I’ve added, but I can’t edit them due to a “Server Error in '/' Application.”-error in the, I think it’s called, node. Let me show you what I mean via a screenshot:

    https://dl.dropboxusercontent.com/u/2915803/ysod-umbraco.png

    As you can see, clicking to edit the “Products” folder in this instance (but the same error applies to all added individual products and the “Home” folder) gives me this error. Never having worked with neither umbraco nor asp or even .net before, I’ve tried googling around for a result. I’ve matched the different files in the new “config” folder and the old, the most striking difference being in the Dashboard.config file, where the old reads:

      <section id="courier">

        <areas>

          <area>courier</area>

        </areas>

        <tab caption="Umbraco Courier">

          <control>/umbraco/plugins/courier/dashboard/CourierDashboard.ascx</control>

        </tab>

      </section>

    and the 4.7.2 version reading:

      <section alias="uGoLiveDashboardSection">

        <areas>

          <area>developer</area>

        </areas>

        <tab caption="uGoLive Checklist">

          <control>/umbraco/plugins/uGoLive/Dashboard.ascx</control>

        </tab>

      </section>

    I’ve tried changing these around, but it didn’t help. From more googling, I thought it might be a problem with uComponents, and I tried the work around supplied here: https://our.umbraco.org/projects/backoffice-extensions/ucomponents/questionssuggestions/33021-Upgrading-to-Umbraco-48-breaks-support-for-uComponents?p=0 , but that didn’t help either.

    Luckily, the site isn’t live yet and I keep a backup which I can restore whenever I fail. I’ve been trying to get this working for more than a week now. I did not design, code or write this website, I am merely doing data entry as a favour on behalf of a family member. After adding countless products to the site and editing the CSS on request, starting over with a completely new install is not a viable option, but we need some of the new functionality added to umbraco over the last few years and, honestly, running a version that’s not even on the “historical releases” part of the umbraco page feels neither responsible nor safe. For example, installing a package from the umbraco repository will completely break the site (result in a YSOD until the offending .dll’s are deleted).

    Alternatively, if there is a way to migrate the css/design and the added products (text, image and layout) to a completely new install, I’d also be up for that - I’m at the end of my tether, so any ideas you might have would be welcome.

  • Dennis Aaen 4448 posts 17912 karma points admin hq c-trib
    Apr 21, 2015 @ 23:34
    Dennis Aaen
    0

    Hi prinneh and welcome to our :-)

    If you have the chance to rollback from a backup and start the upgrading process all over again, then I think it would be a good idea. When you have done the rollback, then try to have a look at the documentation about upgrading an Umbraco installation and try to follow the general guide https://our.umbraco.org/documentation/installation/upgrading/general, and there is also some version specific guides https://our.umbraco.org/documentation/installation/upgrading/version-specific.

    Perhaps you also can benefit from Lee Kelleher´s upgrading path http://code.leekelleher.com/umbraco/archive, I have use it few times, it I haven´t had any problems upgrading my installations.

    Maybe you also need to re-write some of you code if you are plans to upgrade to Umbraco 7. Lots´s has happen to the API in Umbraco 4 to 6 and again to Umbraco 7.

    Umbraco 7 uses JSON, to store the values from the property editors, and it runs MVC as default, so you will typical use Razor instead of XSLT, to get data from the backend. You can see here how to get data from the different property editors in Umbraco 7. https://our.umbraco.org/documentation/using-umbraco/backoffice-overview/property-editors/Built-in-Property-Editors-v7/

    In Umbraco 7 we are working with two implementations of Razor, one is called dynamic Razor and the orther one is called stronly typed Razor. If you are goning to learn Razor, and the differences bewteen dynamic Razor and strongly typed, then I think I would be an good idea for you to take a look at the Razor cheatsheets (PDF files) https://our.umbraco.org/projects/developer-tools/umbraco-v6-mvc-razor-cheatsheets. I know it says for Umbraco 6, but you can use it for Umbraco as well.

    Hope this help you on the right way.

    /Dennis

  • prinneh 2 posts 22 karma points
    Apr 22, 2015 @ 00:37
    prinneh
    0

    Thank you, Dennis!

    I used Lee Kelleher's upgrading path and Umbraco version downloads extensively, it was the only place I could find the code for Umbraco 4.7.2, so I was very glad to see it mentioned here. Every time I tried a different fix, I did so from a fresh restore, making sure my different ad-hoc and unknowledgable solutions didn't do any damage to the upgrading process.

    Besides the blix link and guide I posted above, I did look at and try to follow the umbraco general guidelines as well as the version specific guidelines, but both approaches proved unfruitful. I should have made this more clear in my first post, I apologise about that. I should also underline that, while the topic says "Upgrading Umbraco 4.7.1 to 4.7.2 and beyond", I have yet to make a working update from 4.7.1 to 4.7.2, which is why this is making me so frustrated :)

    Looking at the screenshot of the backoffice error I posted above, would you have a guess as to where my error originated? I'll keep trying, but I sometimes feel like I'm looking for a needle in a haystack :) I haven't tried the "Module Load Order" fix yet as suggested by the general guidelines (because I thought it was a version 7 fix?) in combination with a merged Dashboard.config file, do you think that would help?

Please Sign in or register to post replies

Write your reply to:

Draft