Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Simon 81 posts 184 karma points
    Jul 23, 2015 @ 12:13
    Simon
    0

    Problem with S3 bucket names

    Hi,

    There seems to be a problem with handling of S3 bucket names which include dots.

    e..g you have a bucket named cdn.example.com because you want to set up a CNAME against it then AST S3 seems to have an issue with this. Clicking on Save in the Media section just causes it to hang - no error message is generated. If the bucket name is a single word with no dots it works fine.

    Any ideas?

    Cheers

    Simon

  • Ali Sheikh Taheri 470 posts 1647 karma points c-trib
    Jul 26, 2015 @ 17:47
    Ali Sheikh Taheri
    0

    Hi Simon,

    To be honest with you I have never tried having a bucket name with dots.

    I will have a look at it as soon as I get any chance and will keep you posted.

    Thanks

    Ali

  • Ali Sheikh Taheri 470 posts 1647 karma points c-trib
    Sep 06, 2015 @ 10:59
    Ali Sheikh Taheri
    0

    Hi Simon,

    I had a look into this issue and apparently in version 1 of Amazon SDK, you have to specify the end point , so for now I have hard coded it and release a new dll that can be downloaded here. (please remove .txt extension at the end of this file and to just have ast.s3.dll, and drop it in to the bin folder) here is the link to this issue on stackoverflow

    Because I haven't tested that with all the scenarios that's why I haven't released a new version of this package yet.

    Please feel free to download the dll and let me know if you have any questions.

    Cheers

    Ali

  • Pervez Choudhury 2 posts 22 karma points
    Sep 07, 2015 @ 09:37
    Pervez Choudhury
    0

    I tried out the patched DLL and it worked for me. We were using a Bucket with dots in the name and the old version would just error for us. The dll you link to just works.

  • Simon 81 posts 184 karma points
    Sep 07, 2015 @ 09:55
    Simon
    0

    Hi Ali,

    Many thanks for taking the time to take a look - I'll try out the new DLL and let you know but it looks promising from the comment by Prevez.

    Cheers Simon

  • Ali Sheikh Taheri 470 posts 1647 karma points c-trib
    Sep 29, 2015 @ 10:06
    Ali Sheikh Taheri
    0

    Hi Simon,

    Did you get a chance to look at the new dll ? does it work if so please mark this issue as resolved and I will try to make a new release in the coming week.

    Thanks

    Ali

  • Simon 81 posts 184 karma points
    Oct 02, 2015 @ 08:57
    Simon
    0

    Hi Ali,

    Apologies but didn't get a chance to test it until yesterday - but yes, it does appear to work.

    Many thanks Simon

Please Sign in or register to post replies

Write your reply to:

Draft