Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Elias 25 posts 108 karma points
    Dec 21, 2013 @ 00:17
    Elias
    0

    Category picker fails, when users has no access to settings section

    Hi, I just get noticed that when a user has no access to Setting sections, he can’t use the category picker on any content, error below:

    Exception:

    There is any work around to allow editor users (access only to the content section) use this category picker?

    Best,

    Elias

    • umb 6.1.5
  • James Patterson 53 posts 192 karma points
    Dec 22, 2013 @ 14:10
    James Patterson
    0

    Hi Elias,

    Sorry, there is no work around for this currently.

    This is unfortunatly the expected behavior if the user does not have access to the Settings section. If you use the Media Picker data type in a document type it will fail too if the user does not have access to the Media section. Of course there are more cases where a user would not have access to the Settings section!

    I've had similar problems flagged up before so I think it might be good to move the category tree to its own section in Umbraco. If this was done, would this be a suitable solution for you?

    Cheers,
    James 

  • Elias 25 posts 108 karma points
    Dec 22, 2013 @ 17:21
    Elias
    0

    Hi James, moving the category tree to a different section it’s easy to do or custom coding is needed to keep the component working?

    Regards,

    Elias

  • Scott Leslie 24 posts 139 karma points
    Jan 31, 2014 @ 03:11
    Scott Leslie
    0

    Hi,

    We would be interested in getting the category tree moved away from the settings section. Are there plans to allow this?

    Regards


    Scott 

  • James Patterson 53 posts 192 karma points
    Feb 26, 2014 @ 21:11
    James Patterson
    100

    Hi Scott and Elias,

    Appologies for the delay in getting back to you.

    I have released a new version of the package, 2.5.1, now with a new Categories section. I'd really appreciate it if you could test it out.

    You can download it from here; http://our.umbraco.org/FileDownload?id=10513

    Once you install it, refresh the browser and the user you're using should automatically have access to the Categories section - it will appear with the other sections at the bottom. Also, if you already have an older version of the Categorisation package installed it should work too, all your categories you've created will now just appear within the Categories section.

    I'd back-up your system first if you're concerned, but I have tested it on new 6.1.5 installations and ones with an existing Categorisation package installed.

    I'd appreciate any feedback.

    Thanks,
    James 

  • Scott Leslie 24 posts 139 karma points
    Feb 26, 2014 @ 21:45
    Scott Leslie
    0

    Running 6.1.6 (already had 2.5.0.0 installed). Installed local package 2.5.1.0.
    Installation ran smoothly. Logged out of admin and logged back in now have categories section in backoffice.

    using a test "editor" account gave access to content, media and categories sections.

    Works like a charm.

    Many Thanks! 

  • James Patterson 53 posts 192 karma points
    Feb 27, 2014 @ 16:36
    James Patterson
    0

    Excellent news. Thanks for getting back to me.

  • Elias 25 posts 108 karma points
    Feb 28, 2014 @ 19:46
    Elias
    0

    Hi James, I'm sorry but wen i see that the user needed permission over settings sections, and there was no easy way to modify that, changed the package to a radio button list.

    Thank you anyway for your consideration!

    Regards,

    Elias

Please Sign in or register to post replies

Write your reply to:

Draft