Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Matt Brown 62 posts 174 karma points
    Mar 09, 2017 @ 23:10
    Matt Brown
    0

    In Developer I don't see any "Grid Editors" at all...

    After installing LeBlender and restarting I get no Grid Editors in the Developer section at all. Nothing. Do In need to turn them on somewhere?

    Using 7.4.3

    Update 3/10/17 - Still no Grid Editors on Developer tab. Multiple re-installs and restarts of the Umbraco app in the IIS Control Panel.

    This extension is really exactly what I need. Does anyone have any advice?

  • Dave Woestenborghs 3213 posts 10799 karma points MVP 4x admin c-trib
    Mar 11, 2017 @ 07:40
    Dave Woestenborghs
    0

    Hi Matt,

    Did you try to clear update you client dependency cache ?

    This usually helps. If not, can you check your browser console for any errors.

    Dave

  • Matt Brown 62 posts 174 karma points
    Mar 14, 2017 @ 17:23
    Matt Brown
    0

    Thanks very much for your response. I just deleted my client dependency cache folder, stopped the entire server in the IIS control panel, restarted it and then restarted my browser and reloaded the page with an Empty Cache and Hard Reload.

    I still only see 6 options in the developer panel

    enter image description here

    There are some errors in the console, but 5 are related to EventCalendar which I am not using any longer and 1 is an avitar which I think is not linked either.

    I really appreciate the help. Any other things you can suggest to check?

    I am correct that I should see grid editors here?

  • Matt Brown 62 posts 174 karma points
    Mar 16, 2017 @ 19:53
    Matt Brown
    0

    OK more info. The package installer simply didn't install a single file. Not one thing.

    So... I opened the manifest.xml and moved all the files to the right places in our installation of Umbraco so now all the files in the download are in the right places.

    However it still does not work.

    Our installation of Umbraco is not at the root of our server. We need to share server space with other umbraco installations and other app servers. This is from our IT department and won't be changing.

    In our case Umbraco is at /xxxxInclusion/

    All the js files and the project.manifest all referred to the root so I changed all of them to go from our root.

    ~/App_Plugins/LeBlender/Backoffice/GridEditorManager/edit.js
    

    becomes

    ~/xxxxInclusion/App_Plugins/LeBlender/Backoffice/GridEditorManager/edit.js
    

    Now the Grid Editors appear and I get the choices the documentation says should be there but they all error when I click on them.

    Request error: The URL returned a 404 (not found): /umbraco/backoffice/LeBlenderApi/PropertyGridEditor/GetAll

    In the debugger console, Angular.min.js?cdv=(some big number) throws: http://localhost/umbraco/backoffice/LeBlenderApi/PropertyGridEditor/GetAll 404 (Not Found)

    Note that this is not going to be a location that will work in our configuration. Also this is not a location that was listed in the manifest.xml for me to create. I believe it is coming from the dll which is there in the /xxxxInclusion/bin.

    I believe there are paths in the dll that are hard coded to start with /umbraco. If this is the case, can I change those paths in the cs files and recompile?

    Does anyone have a brief description of how to do this?

  • Patrick Scott 70 posts 109 karma points c-trib
    Mar 19, 2017 @ 10:16
    Patrick Scott
    1

    Hi, I can't help you on the other thread with a tutorial on using the media picker control, but I think I can help with leBlender.

    Doing a search on the project in GitHub - https://github.com/Lecoati/LeBlender/search?utf8=%E2%9C%93&q=leblenderapi

    comes up with the file https://github.com/Lecoati/LeBlender/blob/09fb8f87bbe9a714b40cc37a0fae816a24b019f4/Src/Lecoati.LeBlender.Ui/App_Plugins/LeBlender/common/services/requesthelper.service.js

    which has the API calls in. Have you edited this file yet? It is in the folder App_Plugins\LeBlender\common\services in your install.

    I haven't tested it but changing the paths in here should sort out your API errors in the back office.

    I can't see any where in the c# source code where the umbraco paths are hard coded, let me know how you get on.

  • Matt Brown 62 posts 174 karma points
    Mar 20, 2017 @ 17:46
    Matt Brown
    0

    Thanks Patrick. I appreciate that.

    I spent all day on Friday changing paths and I am now quite close I think. However there are paths in the source in a few places that I also changed.

    AssemblyInfo.cs
    UmbracoEvents.cs
    PropertyGridEditorController.cs
    LeBlenderController.cs
    HelperController.cs
    

    and as you noted:

    leblenderproperties.controller.js
    requesthelper.service.js
    edit.js
    

    The problem is that everything is set to "/AppPlugins" (and the like) and we need it to be "/xxxxInclusion/AppPlugins". I am getting more confident that this is the solution.

    This is the first time I have compiled code in VS so it's pretty interesting to chase this down. I appreciate your help and it makes me feel as though I am going in the right direction

  • Patrick Scott 70 posts 109 karma points c-trib
    Mar 21, 2017 @ 16:09
    Patrick Scott
    1

    May be a silly question, but earlier you said you changed some paths to "~/xxxxInclusion/App_Plugins/...." to get it to work.

    the ~ is interpreted in dot net as the root of the application, so "~/App_Plugins/...." would be correct for the project.manifest file and any c# code.

    I am wondering if you have setup IIS correctly. When you created the xxxxInclusion folder, you did convert it into a virtual application?

    i.e. in IIS you right click on the xxxxInclusion folder and select "Convert to Application".

  • Matt Brown 62 posts 174 karma points
    Mar 21, 2017 @ 18:39
    Matt Brown
    0

    OK thank you again. Good questions.

    Yes. I did set it as an application and set the right file permissions and chose ASP.NET 4.0 connection pool as specified in one of the articles I read here. The overall install was working correctly and in fact we are serving several sites that are set up this way.

    I think IIS is set up correctly but I don't have the hubris to insist that it is, so anything you think of checking I am game to do.

    OK I did not know the tilde before I changed them. I now have everything going from root with normal root relative pathing.

    I am in the process of reinstalling Umbraco (this is my localhost test server and I can blow it away as often as I want.) I am installing at the root at this time and Umbraco is up and running correctly. I am going to test LeBlender on this configuration to evaluate it before I add my data back in and then worry about getting it in the right place.

    I think that I can glean enough knowledge from LeBlender that I may be able to "reinvent the wheel" if I need to if I again cannot get it set right on our config.

    I appreciate you following up. I will post with what I find in a few days.

  • Nandoh 32 posts 104 karma points
    May 03, 2017 @ 13:32
    Nandoh
    0

    Hi Matt,

    Did you come to a conclusion on this subject? Because I've installed the LeBlender using Nuget and it doesn't show up in the Developers section. Moreover, I can tell that installing it using Nuget didn't change the tree.config file, but I did change it manually to include the GridEditorManager but with no success.

    Also, when adding a new DataType using the property editor "LeBlender Editor" in the browser's console I have a javascript error

    "Cannot read property 'config' of undefined at new

     // Inir render with the value of frontView
        // render have to be always = /App_Plugins/LeBlender/editors/leblendereditor/views/Base.cshtml
        $scope.model.parentValue.render = $scope.model.parentValue.config.frontView ? $scope.model.parentValue.config.frontView : "";
    

    And I can't add any property because when I click in the "Add property" button it "triggers" the save and nothing more happen.

    PS: I'm using Umbraco 7.5 :)

    Thanks

  • Matt Brown 62 posts 174 karma points
    May 03, 2017 @ 16:05
    Matt Brown
    0

    No. I have not got it to work. I have been on other side tracks just now. I will try again in a new install of 7.6. Sorry not to be of help.

  • Nandoh 32 posts 104 karma points
    May 03, 2017 @ 16:09
    Nandoh
    0

    No problem Matt, thanks for your reply :)

    I've just read other threads with people complaining about similar problems, but no answer was given.

    I don't even know if it's worth to create another thread with my problem.

    PS: between my post and your reply, I've installed the umbraco package through the backoffice, but still no luck with this :(

Please Sign in or register to post replies

Write your reply to:

Draft