Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • MisterG 19 posts 31 karma points
    May 28, 2014 @ 16:03
    MisterG
    0

    Scritpt not loading on second request

    Hi,

    I've installed the plugin and it works well the first time when you edit an item.

    But when you want to edit another one, I only have a blank textbox. I don't have any JS error, it's like umbraco is not loading the JS anymore.

    This is my version of Umbraco : Umbraco version 7.1.3 assembly: 1.0.5250.13487

    I'm using the latest version of the plugin : Spectrum_Color_Picker_0.0.2.zip

    Thanks for your help,

    Greg

  • Robert Foster 416 posts 1572 karma points MVP admin c-trib
    Jun 06, 2014 @ 12:40
    Robert Foster
    0

    Hey Greg,

    Firstly, sorry for not responding earlier - got buried underan avalanch of email this week.  I've noticed the same problem, am investigating and will have an update soon.

    - Rob.

  • Robert Foster 416 posts 1572 karma points MVP admin c-trib
    Jun 06, 2014 @ 13:12
    Robert Foster
    0

    Ok, uploaded a new version addressing this issue.  If you do notice anything else let me know.

    Rob.

  • MisterG 19 posts 31 karma points
    Jun 10, 2014 @ 10:59
    MisterG
    0

    Hi Rob,

    Thank you very much, it works perfectly now!

    Greg

  • MisterG 19 posts 31 karma points
    Jun 10, 2014 @ 16:26
    MisterG
    0

    Hmm I spoke too quickly.

    The control is rendered correctly but without any value. It shows only a cross.

  • Robert Foster 416 posts 1572 karma points MVP admin c-trib
    Jun 10, 2014 @ 20:04
    Robert Foster
    0

    Hi Greg,

    The cross indicates that there is no value in the field - are you able to select a color, change it, and then does the color get rendered correctly when you refresh?

  • MisterG 19 posts 31 karma points
    Jun 16, 2014 @ 16:36
    MisterG
    0

    This is what I have when I go back to the item having de property.

    The property is set, the control is loaded but not with the value.

  • Robert Foster 416 posts 1572 karma points MVP admin c-trib
    Jun 17, 2014 @ 05:48
    Robert Foster
    0

    hm.  This is working in the sites I'm using it in...

    I'm wondering whether this is to do with the existing page content - if you create a new page with the color picker on it and then set a color, save and refresh, does it work as expected, or as you are currently seeing it?

  • MisterG 19 posts 31 karma points
    Jun 19, 2014 @ 15:35
    MisterG
    0

    Nope, we have created new content and the problem still persists. We've also tested on other browser, same issue.

    Thanks for your help,

    Greg

  • Robert Foster 416 posts 1572 karma points MVP admin c-trib
    Jun 23, 2014 @ 19:48
    Robert Foster
    0

    Hi Greg,

    I just now created a brand new site and installed the Spectrum Color Picker to verify it works - which it is.  This was using the package from this site just to make sure.

    A few suggestions to help you debug it:

    1. Try creating a fresh site and download the package afresh from Our.
    2. On a "broken" installation, open up your browser's developer tools and make sure there are no javascript errors showing up in the console, but also in the Network trace.
    3. If you're still having problems, are you able to send me a copy of your database and a sample project that isn't working?  If I can get my hands on a broken installation then I may be able to shed some light on the problem.

    Thanks,

    Rob.

     

  • Robert Foster 416 posts 1572 karma points MVP admin c-trib
    Jun 29, 2014 @ 14:06
    Robert Foster
    0

    Hi Greg,

    Have just uploaded a new version which should hopefully fix this, if you can find time to test it out and let me know how it goes that'd be great - I've tested it locally, and haven't been able to get it to fail.

    Thanks,

    Rob.

  • MisterG 19 posts 31 karma points
    Jun 30, 2014 @ 14:15
    MisterG
    0

    Hi Rob,

    It seems to be good, thanks!

    Greg

Please Sign in or register to post replies

Write your reply to:

Draft