Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • John 7 posts 97 karma points
    1 week ago
    John
    0

    Merchello 2.7.0 No Data

    This was originally posted in the wrong channel. My apologies.

    I have installed a fresh install of Umbraco, Merchello, and FastTrack.

    Everything was done as it was supposed to... no Nuget packages. Just downloads, and careful version matching.

    There are no errors in the log or js console.

    But, no content shows up anywhere on the site. I have tried everything I can think of. The closest I have gotten is looking ftCategory in debug in VS19. It looks like there is nothing coming back for Model.Products, though it clearly does in the backoffice. I started digging into the Property Editors for Product Listing ... but then its started getting pretty hairy.

    Ultimately, something seems strange: no content and no errors...

    Umbraco 7.14.0 - from Nuget Merchello 2.7.0 - from site and local package install. FastTrack 2.7.0 - from site and local package install. VS2019 .NET 4.7.2 IISExpress

    Anybody have any ideas on what I can try?

    UPDATE: Just tried again with 7.13.2 -- Same behavior.

    UPDATE: And now have tried 17.2.0 just to confirm. Same behavior every time.

    UPDATE

    Read in the 2.7.0 Release notes:

    You MUST install Merchello 2.7.0 before you install this package. If you install this package first, it will fail.

    Once installed, if you cannot see the products on the home page locally (Or on server), then check file permissions for the website folder. I've seen this a few times and it always ended up being a permissions issue. (On windows locally, try giving IUSR modify permissions and see if that works).

    I gave "Everyone" full access to rule out perm issues. And ensure the permission set was propogated down recursively through the directory.

    Still the same.

Please Sign in or register to post replies

Write your reply to:

Draft