Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Søren Mastrup 110 posts 495 karma points c-trib
    Aug 17, 2016 @ 10:20
    Søren Mastrup
    0

    Could not find the surface controller

    I just did a fresh install on my test site. I am running 7.4.3.
    I am getting this error when I am logged in and trying to access a post or posting something new: http://prntscr.com/c6sil8

  • Søren Mastrup 110 posts 495 karma points c-trib
    Aug 17, 2016 @ 10:30
    Søren Mastrup
    102

    Just had a look in the SimpilyForumsController.cs

    In line 15:

    public class SimpilyForumsController : SurfaceController
    

    I've changed it to this:

    public class SimpilyForumsController : Umbraco.Web.Mvc.SurfaceController
    

    That works!

  • Alex Skrypnyk 5365 posts 19803 karma points MVP 3x admin c-trib
    Aug 17, 2016 @ 10:56
    Alex Skrypnyk
    1

    Hi Søren,

    Great that you found solution!!!

    Best,

    Alex

  • James 13 posts 84 karma points
    Dec 15, 2016 @ 23:12
    James
    0

    Sorry to revive a dead thread, but I ran into this same problem recently (only after turning "debug" off in web.config).

    Any idea why the fully qualified class name works, but just referencing Umbraco.Web.Mvc at the top of the file and using the naked class name doesn't?

    [edit] Updating that even with fully qualified class names it still randomly can't find surface controllers on cache clears, so it isn't solved.

  • Paul 132 posts 427 karma points
    Jun 05, 2017 @ 09:18
    Paul
    0

    Same issue for me. Refreshing the site cache via a republish all kicks it back into life, but this is far from ideal.

  • Paul 132 posts 427 karma points
    Jun 06, 2017 @ 07:52
    Paul
    0

    Changing line 49 in RenderPostEditor.cshtml to the following resolved this for us (at present!):

    using (Html.BeginUmbracoForm("PostReply", "SimpilyForums", new { @class = "form-horizontal forum-reply-form" })) 
    
Please Sign in or register to post replies

Write your reply to:

Draft