Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Chris Clancy 51 posts 118 karma points
    Jul 22, 2018 @ 06:27
    Chris Clancy
    0

    CMS import including references in CSPROJ

    Hi,

    I have used CMSImport in the past and am installing on a new site (with Umb 7.8) but running into a few problems. I can get everything running fine locally but I have noticed that when installing CMSimport via Nuget, I get a full list of Umbraco includes added to my CSProj - the entire Umbraco folder. Now I don't include Umbraco in my repo (like many people) so this is a problem.

    If I remove these references then I see some strange behaviour in the backoffice once I have pushed to our DEV environment on Azure, like styles and icons are missing. The backoffice homepage appears to have some styles missing on the /umbraco/#/content page but they eventually seem to come back but the CMSImport icons are missing in the developer section. Also, CMSImport doesn't work on DEV, showing a 'cannot find Wizard.aspx' error, so some things have not installed correctly when building. We have the Pro licence and I checked a previous site which I know works but that has the Umbraco folder included, which I definitely do not want.

  • Richard Soeteman 3829 posts 11860 karma points MVP
    Jul 22, 2018 @ 09:30
    Richard Soeteman
    0

    Hi Chris,

    When back from Holiday in August I will make sure there will be a cmsimport.core Nuget package that only includes binaries.

    Best,

    Richard

  • Chris Clancy 51 posts 118 karma points
    Jul 22, 2018 @ 16:52
    Chris Clancy
    0

    Hi Richard,

    Thanks for the reply. I could import from my local version or temporarily include the Umbraco folders for the import then remove again. Will find a way around it. Enjoy your holidays.

    Chris

Please Sign in or register to post replies

Write your reply to:

Draft