Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Brian Rush 25 posts 95 karma points
    Aug 29, 2017 @ 18:37
    Brian Rush

    Interesting Package. Question about Azure Search 3.0

    This looks very interesting. Thanks for creating this. Trying to have Examine on Azure seems very tricky.

    I installed latest version but I have Microsoft.Azure.Search

    I can verify my connection to the Search endpointenter image description here

    But when I try to build the index I get a 500 response

    enter image description here

    The exception is as follows

    at Moriyama.AzureSearch.Umbraco.Application.AzureSearchIndexClient.DropCreateIndex() at lambdamethod(Closure , Object , Object[] ) at System.Web.Http.Controllers.ReflectedHttpActionDescriptor.ActionExecutor.<>cDisplayClass10.9(Object instance, Object[] methodParameters) at System.Web.Http.Controllers.ReflectedHttpActionDescriptor.ExecuteAsync(HttpControllerContext controllerContext, IDictionary`2 arguments, CancellationToken cancellationToken)--- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw() at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at System.Web.Http.Controllers.ApiControllerActionInvoker._1.MoveNext()

    Any thoughts here. I really am having a tough time with Examine on Azure and would rather use this approach. I think this would scale better.


    BTW I am version 7.6.5 for Umbraco

    I also tried creating index through Azure then doing a rebuild but I get this

    Method not found: 'Microsoft.Azure.Search.SearchIndexClient Microsoft.Azure.Search.IIndexesOperations.GetClient(System.String)'.

    What version of Microsoft Search did you originally code this with?

  • Jay 410 posts 636 karma points
    May 14, 2018 @ 15:30

    Having similar issues, Reindex content doesn't work with errors. Any idea?

    From debugging through, when the Reindex content has been clicked, it's trying to read a content.json file which seems to not exist.

    There's a bits on the AzureSearchServiceClient.cs (line 88) > ReIndexContent(string sessionId) which seems to create this Json file, but the method are not called anywhere at all. Confused....

    enter image description here

    Can anyone point me to the right direction on this?


  • Murtaza 2 posts 72 karma points
    Jul 17, 2019 @ 01:55

    Hi @Brian Rush

    Did you ever find the solution for this problem? I am having the exactly same problem and its been now couple of days cant figure out whats the cause of this issue?

    Your help would be greatly appreciated.

    Cheers Ali

  • Murtaza 2 posts 72 karma points
    Aug 08, 2019 @ 04:21

    For me I had to manually create the index flie on azure and then the problem got solved.

Please Sign in or register to post replies

Write your reply to: