Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Anthony 26 posts 145 karma points
    Jun 02, 2018 @ 11:13

    Articulate Post Images Not Shown in Umbraco BackOffice Media Section

    When I create a new blog post and upload an image for it under the images tab, the images are uploaded to /media/1234/image.jpg as expected and shown on the post's page just fine, but when I browse to the media section in the back-office they're not there.

    Is this usual? should they be there? is it because they're not of "UmbracoFile" property alias? can this be changed as I like tinkering with images in the media section.

    Not sure is this is my set-up or something which happens with all versions of Articulate, I'm on Umbraco 7.10.3; Articulate 3.0.1;with a customised theme.

    Thoughts and comments would be welcome.

  • Jan Skovgaard 11280 posts 23678 karma points MVP 10x admin c-trib
    Jun 02, 2018 @ 11:25
    Jan Skovgaard

    Hi Anthony

    This is the way it works since the "Post image" property is based on the "Image Cropper" datatype and it does not create the image in the media folder as opposed to the "Media Picker", which does.

    Not sure why it is like that though and not 100% if you can "just" switch the datatype to use the "Media picker" with a "image only" restriction setup. I better let Shannon (Package creator) answer that :)

    But it's the default behavior so nothing wrong on your part.


  • Anthony 26 posts 145 karma points
    Jun 02, 2018 @ 11:56

    Thanks Jan. Much appreciate.

    I think I've switched the Upload Image to an Image Cropper in a previous project and that's allowed me to view images in the image section(backoffice)

    Settings Media Type in Back office

    But the property alias has always been UmbracoFile. I see the Articulate Post Document Type has the property alias set to postImage (which is how it's referenced in my custom theme too).

    Settings Articulate Post Type in Back Office

    I suspect if I rename the property alias to UmbracFile it'll appear in the Media section. I may give it a try and check the Umbraco source later.

    I'll post back any findings. Thanks again.

  • Nicholas Westby 2054 posts 7100 karma points c-trib
    Jun 02, 2018 @ 16:25
    Nicholas Westby

    I suspect if I rename the property alias to UmbracFile it'll appear in the Media section.

    I do not think that is correct. The name of a content property in the content section will have no effect on where an image in the media section will be placed.

    I think your best bet would be to change the "Post Image" property to a media picker (as Jan hinted at), then ensure the "Image" media type has the "umbracoFile" property set to an image cropper (as you say you have done in the past).

    That change will likely necessitate a change of the code that is fetching the images, which may mean changes to Articulate will become necessary.

  • Anthony 26 posts 145 karma points
    Jun 03, 2018 @ 16:36

    Thanks Nicholas.


    I quickly added a new ImageCropper property to the Articulate Post's Document Type (Image Tab) with the property alias of UmbracoFile and it doesn't seem have an effect, but using a Media Picker uploads to the Media section in the back office.

    I guess it's supposed to and you and Jan both knew already :)

    I suppose I need to rethink my question. Perhaps in hindsight I should have been asking why files uploaded with ImageCropper property type aren't shown in the Media Section (back-office)?

    Feels like I'm missing something as it seems like common sense that images uploaded ImageCropper should be visible in the media section...

  • Anthony 26 posts 145 karma points
    Jun 04, 2018 @ 10:38

    Okay. Coming back to this this morning, as with most things, it's been thought about and discussed before:

    It looks like a feature request is outstanding. Obviously I've upvoted :)

    Thanks again for the input.

Please Sign in or register to post replies

Write your reply to: