Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Rico 3 posts 23 karma points
    Nov 29, 2017 @ 07:52
    Rico
    0

    Internal links not working or targeting self in version 7.6 / 7.7

    Greetings! Firstly, thanks for your great starter kit. Really good for getting up and running quickly, nice work! I've only just started using the starter kit and when I set internal links they don't got to the other content pages. The top menu works correctly but the link buttons just return to the top of the home page. I've looked in the database and it does not look like the data for the internal links is being added? Any help would be appriciated. Thanks!

  • Alex Skrypnyk 6120 posts 23747 karma points MVP 7x admin c-trib
    Dec 27, 2017 @ 12:08
    Alex Skrypnyk
    0

    Hi Rico

    Welcome to our forum

    Can you show me how did you render buttons? How are they looking in the backend?

    Thanks,

    Alex

  • Rico 3 posts 23 karma points
    Dec 28, 2017 @ 11:41
    Rico
    0

    Hey Alex,

    This is on the default button from the template. It's when I published the Link Buttons in the Homepage Assets? The button renders when published but the re is no target.

    Many thanks.

    Rico

  • Andrew Bright 84 posts 244 karma points
    Sep 18, 2018 @ 10:08
    Andrew Bright
    0

    I had this issue also and tried to fix with RJP multi Url picker but had no luck. essentially whats happening is the DLinkButton class is being used to obtain a link item which has no idea what a content picker or RJP Url are so I had to update the external link with the required internal link to get round this.

Please Sign in or register to post replies

Write your reply to:

Draft