Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Søren Reinke 158 posts 206 karma points c-trib
    Nov 02, 2012 @ 18:35
    Søren Reinke
    0

    Installing the .air app fails

    I am trying your package on my development setup.

    I am running 4.9.1 from VS2012, so the site is running on IIS Express.

    When i click 'desktop media uploader' tab on the media section, i see the flash animation, which shows 'Install now'.
    I click it, and it tells me it need Adobe Air (which is actually installed already), when i click 'Yes' i just get an 'a download error occurred'.

    I have installed tried to install the air app via '/umbraco/plugins/theoutfield/desktopmediauploader/desktopmediauploader.air'

    The install goes well, but the flash animation still wants to install it.

    I have tried to add the mimetype to IIS Express via:

    C:\Program Files (x86)\IIS Express>appcmd set config /section:staticContent /+[fileExtension='air',mimeType='application/vnd.adobe.air-application-installer-package+zip']

    I have tried to restart the IIS Express without any luck.

    Any clues?

  • Jan Skovgaard 11241 posts 23387 karma points MVP 6x admin c-trib
    Nov 02, 2012 @ 18:45
    Jan Skovgaard
    1

    Hi Søren

    I'm experiencing the same thing with 4.1.0 RC using webmatrix - And since DMU has been a part of the Umbraco core for a while I think this should be reported on the issue tracker rather in this forum. (Of course if Matt has some pointers on how to solve the issue that would be great).

    Let me know if you file a bug report and I will vote it up as well.

    /Jan

     

  • Søren Reinke 158 posts 206 karma points c-trib
    Nov 02, 2012 @ 19:04
    Søren Reinke
    0

    Hi Jan, eller 'Hej Jan' as we would say in danish :-)

    I must admit I had no clue it was in the core :)
    How to access it from the backend? Can't find it. I install the package.

    If it help, i'll gladly submit the above post as a a bug report.

     

  • Jan Skovgaard 11241 posts 23387 karma points MVP 6x admin c-trib
    Nov 02, 2012 @ 19:09
    Jan Skovgaard
    0

    When you go to "Media" you can choose the "Get started" tab and then it's found under the second headline called "Desktop Media Uploader" (Maybe that's also the dashboard being added when doing a manual install - but as mentioned it's included in core but you still need to install air in order to make it work).

    Hope this helps :)

    /Jan

  • Søren Reinke 158 posts 206 karma points c-trib
    Nov 02, 2012 @ 19:19
    Søren Reinke
    1

    LOL i need to clean my glasses or actually read the 'Get Started' info :-)
    Have never noticed it.

    That 'installer' fails as well, so I have created bug report as you suggested.

    http://issues.umbraco.org/issue/U4-1129

  • Jan Skovgaard 11241 posts 23387 karma points MVP 6x admin c-trib
    Nov 02, 2012 @ 21:52
    Jan Skovgaard
    0

    Hi Søren

    Seems like I was way to quick on the trigger there. According to Tom's comment on the bug report this may because of a Chrome bug: http://our.umbraco.org/projects/website-utilities/desktop-media-uploader/bugs,-feedback-and-suggestions/33814-Install-Now-via-Badge-fails-download-error-occurred

    Let's try and see if the steps he describes fixes the issue :)

    /Jan

  • Søren Reinke 158 posts 206 karma points c-trib
    Nov 02, 2012 @ 21:54
    Søren Reinke
    0

    It does fix it :)

  • Søren Reinke 158 posts 206 karma points c-trib
    Nov 03, 2012 @ 10:43
    Søren Reinke
    1

    Godmorning Jan :-)

    Do you know if there is anyway to get the 'Desktop Media Uploader' to remember multiple sites? So I can set it up for more than one site, and just select the site i want to upload to?

    If that feature is missing, would http://issues.umbraco.org/issues/U4 be the correct place to suggest that change?
    I have no experience myself in coding .air applications, so someone else would have a lot easier a job :) 

  • Jan Skovgaard 11241 posts 23387 karma points MVP 6x admin c-trib
    Nov 03, 2012 @ 12:25
    Jan Skovgaard
    0

    Morning Søren

    I don't think that feature is currently supported - But it would indeed be a usefull one!

    Since DMU is core now I think it would make sense to add a feature request on the issue tracker. Sebastiaan will put us straight if it's not! :)

    /Jan

  • Søren Reinke 158 posts 206 karma points c-trib
    Nov 03, 2012 @ 18:24
    Søren Reinke
    0

    Jan i created this issue:

    http://issues.umbraco.org/issue/U4-1133

    Hope it's done correctly, feel free to vote for it :) 

  • Jan Skovgaard 11241 posts 23387 karma points MVP 6x admin c-trib
    Nov 03, 2012 @ 18:37
    Jan Skovgaard
    0

    Voted - Sebastiaan will let us know if it's been misplaced I'm sure :)

    /Jan

Please Sign in or register to post replies

Write your reply to:

Draft