Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Matt Barlow 103 posts 258 karma points
    Apr 14, 2018 @ 19:54
    Matt Barlow
    0

    Upload files not being attached when choosing the Send Email with Template (Razor) workflow

    I am using the following versions: Umbraco 7.10.2 Umbraco Forms 7.0.1 Perplex Forms 1.8.3

    I did a clean install of all three, and am using the Perplex File Upload to select files, on a simple form.

    Then I create a workflow item - selecting to attach uploaded files - Send Email with Template (Razor). enter image description here

    enter image description here

    The email sends but the attachment isn't added, when I switch to using the native File Upload then it works.

    I have the smtp server on my local machine so I can see it's not being attached.

    Any ideas how I can fix this?

    Thanks in advance.

  • Daniël Knippers 68 posts 439 karma points MVP c-trib
    Apr 16, 2018 @ 07:01
    Daniël Knippers
    1

    Hi Matt,

    This is a built-in Umbraco workflow, it might only work with Umbraco's File Upload. Unfortunately, Umbraco Forms is not open source so I cannot look at their source. As far as I can tell there is no way for us to specify whether our Field Type (like File Upload / Image Upload) generates attachments so it can be picked up by the workflow. The workflow might just match on field type alias and/or unique field type id and is not checking for our field types.

    Perhaps you can ask Umbraco if their workflow works with custom field types.

    -- Daniël

  • Matt Barlow 103 posts 258 karma points
    Apr 16, 2018 @ 18:37
    Matt Barlow
    0

    Hey Daniel,

    Thanks for the quick response. Makes sense, it does work when using the non-html workflow as well, so hopefully this wouldn't be a big change to Umbraco Forms if they could implement it.

    Thanks,

    -M

Please Sign in or register to post replies

Write your reply to:

Draft