Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Andrew Tregonning 19 posts 41 karma points
    Feb 01, 2014 @ 03:22
    Andrew Tregonning
    0

    Unable to login to back office after deploying Umbraco 7 to server

    Hi

    As this issue is specific to Umbraco 7, I'm reposting from the Installing Umbraco forum.

    I've got a number of Umbraco sites successfully deployed at my shared hosting provider, ranging from version 4.5.2 to 6.1.4, but when I deploy a 7.0.2 umbraco site there, I can't login to the back office.

    I initially encountered the problem with a site I'd developed on my local machine, then deployed to my hosting provider. I've since tried uploading a fresh copy of umbraco 7.0.2 to the server, successfully run through the installation there, but when I try to login for the first time I get the same error:

    As you can see, the javascript error "The user object is invalid, the remainingAuthSeconds is required" shows up in the console and there's a red bar that looks like it should have an error message in the UI, but no message.

    This appears to be a client-side problem, so I've tried a number of different browsers (IE/FF/Chrome) with the same result. I wondered if it could be time zone-related as my hosting company is in another country, but when I try changing my local timezone to match the server, it hasn't helped.

    The umbraco logs show no problems either. These are the entries when I attempt to login:

    2014-01-28 14:26:45,350 [27] INFO  umbraco.BusinessLogic.Log - [Thread 26] Redirected log call (please use Umbraco.Core.Logging.LogHelper instead of umbraco.BusinessLogic.Log) | Type: Login | User: 0 | NodeId: -1 | Comment: User XXXXXX has logged in
    2014-01-28 14:26:45,365 [27] INFO  Umbraco.Web.Security.WebSecurity - [Thread 16] User Id: 0 logged in

    Which, to me, looks like the server has successfully handled my login request.

    I'm not sure where to go from here. Can anyone suggest further troubleshooting steps I can try?

    Cheers,
    Andrew

  • Andrew Tregonning 19 posts 41 karma points
    Feb 09, 2014 @ 05:56
    Andrew Tregonning
    0

    Hi

    I've just tried release 7.0.3, and have the same experience. Anyone have any suggestions?

    Cheers,
    Andrew

  • Sebastiaan Janssen 4578 posts 12764 karma points MVP admin hq
    Feb 09, 2014 @ 15:10
    Sebastiaan Janssen
    0

    Did you follow the suggestions in the release notes?

    Google Chrome has notoriously aggressive caching, so if something doesn't seem to work well in the backoffice, make sure to clear cache and cookies thoroughly (for other browsers as well).

    One way to nudge the cache in Chrome is to open the developer tools (F12) and go to the settings (the cog icon). There will be a checkbox that says "Disable cache (while DevTools is open)". Once this checkbox is on you can refresh the page and the cache should be invalidated. To force it even more, the "reload" button next to your address bar now has extra options when you right-click it. It should have "Normal reload", "Hard reload" and "Empty cache and hard reload" now. The last option is the most thorough and you might want to try that.

    We're working on making this experience better and seamless, but for now make sure to follow these steps for v7 upgrades.

  • Andrew Tregonning 19 posts 41 karma points
    Feb 09, 2014 @ 19:09
    Andrew Tregonning
    0

    Thanks for your reply. I've tried that with no success.

    I don't think it is caching though, as I've tried multple different browsers, and had the same experience after deploying a completely fresh instance of Umbraco 7.

    Cheers,
    Andrew

  • Sebastiaan Janssen 4578 posts 12764 karma points MVP admin hq
    Feb 09, 2014 @ 21:19
    Sebastiaan Janssen
    0

    Does it work locally? v7 needs ASP.NET 4.5, is that installed on the server?

  • Roy Decaestecker 5 posts 25 karma points
    Mar 18, 2014 @ 11:33
    Roy Decaestecker
    0

    Dear Sebastiaan,

    Is there a solution for this issue. I use v 7.0.4 and have the same problem.
    Does an upgrade to 7.1 solve this problem.

    with regards?

     

     

     

  • Sebastiaan Janssen 4578 posts 12764 karma points MVP admin hq
    Mar 18, 2014 @ 11:42
    Sebastiaan Janssen
    0

    @Roy Eh? The solution is to clear your cache.

    If the issue persists, make sure to look in your log file App_Data\Logs\ and see what is really going on. My guess: a misconfigured connection string or unability to connect to your database.

  • Roy Decaestecker 5 posts 25 karma points
    Mar 18, 2014 @ 13:19
    Roy Decaestecker
    0

    Thanks for your quick reply.

    I've managed to log in after hitting F5.
    Still I get the error The user object is invalid, the remainingAuthSeconds is required. in the developers console of chrome.

    The second issue I have: - no icons are visible, nor can I hit any link in the menu. Except for help or logout menu.
     Any ideas?
    I've uploaded my whole project folder to my hosting provider.
    Everything runs fine on my local IIS.
     

  • Sebastiaan Janssen 4578 posts 12764 karma points MVP admin hq
    Mar 18, 2014 @ 13:21
    Sebastiaan Janssen
    0

    You must be getting some JS errors, what are they?

  • Roy Decaestecker 5 posts 25 karma points
    Mar 18, 2014 @ 14:00
    Roy Decaestecker
    0

     

     After hitting F5 :
    Please find below a screenshot of my browser console

    I also uploaded the project to another hosting partner and it seems to work fine there.
    It does not work on "mijnhostingpartner.nl" (combell.com no issues)
    What could be the issue, user rights? web application directory? ...

  • Sebastiaan Janssen 4578 posts 12764 karma points MVP admin hq
    Mar 18, 2014 @ 14:17
    Sebastiaan Janssen
    1

    @Roy The server needs to support ASP.NET 4.5 and it should support full trust (medium trust won't work).

    The error doesn't say much, try setting compilation debug="true" (in your web.config) in order to get a better idea of what might be going on.

  • Roy Decaestecker 5 posts 25 karma points
    Mar 18, 2014 @ 15:25
    Roy Decaestecker
    0

    Thanks Sebastiaan,

    I pass your advise to my provider.

     

    with regards

  • Andrew Tregonning 19 posts 41 karma points
    Mar 18, 2014 @ 21:50
    Andrew Tregonning
    0

    I was never able to solve this problem.

    My hosting provider had .NET 4.5 installed, running in Full Trust. The same project worked locally fine, and worked at a different hosting provider fine.

    In the end, I gave up and decided to host my Umbraco 7 sites at the new hosting provider. Not an ideal solution though, with my Umbraco 4.x and 6.x sites at one hosting provider and my two Umbraco 7 sites at the new one.

    Sebastiaan's suggestion of turning debug on sounds worthwhile - not something I'd tried on the server.

    @Roy, if you have any luck, please repost here, as I'd ideally like to shift back to a single hosting provider!

    Cheers,
    Andrew

  • Sebastiaan Janssen 4578 posts 12764 karma points MVP admin hq
    Mar 18, 2014 @ 22:04
    Sebastiaan Janssen
    0

    I'm very curious to know if something comes out of this, maybe the hosting providers are missing something else that we require which we forgot to mention.. :)

  • Ulrich Wagner Gade Ebsen 79 posts 171 karma points
    Apr 04, 2014 @ 11:37
    Ulrich Wagner Gade Ebsen
    0

    Hi 

    I have had a lot of trouble with this also (7.0.2 and 7.1) ... spend somehours trouble shooting, and I think I found the issue! If Helicon Ape (http://www.helicontech.com/ape/) is installed at server/IIS, something makes umbraco 7 break... I tried installing / uninstalling three times just make sure...!

     

    Ulrich Ebsen

  • Andrew Tregonning 19 posts 41 karma points
    Apr 04, 2014 @ 11:42
    Andrew Tregonning
    0

    Hi

    Yes - that sounds like a likely culprit!

    The hosting company that I couldn't get Umbraco 7 to work with does indeed have that product on their servers.

    Cheers,
    Andrew

  • John Palmer 57 posts 141 karma points
    Apr 08, 2014 @ 07:36
    John Palmer
    0

    Hi Andrew,

    Does your hosting provider support the latest .net 4.5 and Full trust permission? I also use Umbraco v7 on shared hosting (asphostportal.com) and it is working fine without any problem. So, you may check it with your hosting provider

  • Andrew Tregonning 19 posts 41 karma points
    Nov 15, 2014 @ 03:04
    Andrew Tregonning
    0

    More information about this Helicon Ape conflict has been brought to light in this thread. Apparently Helicon Ape installs a cutdown version of Newtonsoft.Json into the GAC.

  • Hiranmai 7 posts 27 karma points
    Jun 30, 2015 @ 06:59
    Hiranmai
    0

    Hi ,

    I have problem with umbraco7.2.4 when i hosted appliction in server i cant able to login in umbraco .Can you please help any one regarding this issue.Please find screen shot regarding this....

    enter image description here

    After Logged into Umbraco i got empty page like and when i have clicked on Inspect elements it show Please look into attached screen shot. enter image description here

    Any one suggest regarding on this issue

  • Hiranmai 7 posts 27 karma points
    Jul 03, 2015 @ 06:38
    Hiranmai
    0

    Hai,

    I am unable to login umbraco in Server.can any one help regarding on this issue.Please find screen shot regarding this

    enter image description here

  • Ian Greentree 3 posts 23 karma points
    Jul 15, 2015 @ 23:02
    Ian Greentree
    0

    I had the same problem as Hiranmai. It took me ages to work out what was wrong but finally got to the bottom of it... My IIS site physical path wasn't pointing to the folder containing the application root (were the main web.config sits) instead it was pointing at the parent folder. I change this and hey presto... I could log in.

  • Ryios 122 posts 262 karma points
    Jul 16, 2015 @ 02:39
    Ryios
    0

    I had a similar issue on Winhost hosting. I had to put in a ticket to have them reset the ACL permissions on my site's directory. When I FTP'd out the files the site folders didn't pick up the folder permissions to allow the application pool process to write to them, this caused login to fail (likely logging code or something).

  • Ryios 122 posts 262 karma points
    Jul 16, 2015 @ 02:39
    Ryios
    0

    Eventually I setup MSDeploy to deploy via MSDeploy from visual studio instead of using FTP. MSDeploy correctly sets the ACL's on the outgoing files.

  • Ryios 122 posts 262 karma points
    Jul 16, 2015 @ 02:40
    Ryios
    0

    ACL = Access Control List

  • Adam Anthony 8 posts 79 karma points
    Dec 31, 2015 @ 14:42
    Adam Anthony
    0

    Im still having this issue in 7.3.3.

    I get intermittent file sharing violations on App_Data/Umbraco.sdf, and hard refreshing and/or clearing cookies sonetimes fixes it. Other times it does nothing. Other times it causes a different error: "a connection string is defined bu umbraco annot connect". Either way, this is not a satisfactory user experience! Im not even changing anything in the backoffice, just browsing the front end and this can suddenly just happen.

    Anyone have any ideas?

Please Sign in or register to post replies

Write your reply to:

Draft