Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • MuirisOG 373 posts 1271 karma points
    Feb 28, 2019 @ 15:02
    MuirisOG
    3

    Installing v8.0.0

    Not a question, more like a solution.

    Version 8 runs on .NET Framework 4.7.2, which I now know is clearly shown in the requirements.

    If you get the error below, it's because you created a project in VS2017 targetting the wrong framework.

    Server Error in '/' Application.
    --------------------------------------------------------------------------------
    Parser Error 
    Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately. 
    
    Parser Error Message: Could not load type 'Umbraco.Web.UmbracoApplication'.
    
    Source Error: 
    
    Line 1:  <%@ Application Inherits="Umbraco.Web.UmbracoApplication" Language="C#" %>
    
    Source File:  /global.asax    Line:  1 
    

    Targetting the right framework also sorted out the issue below:

    Could not load file or assembly 'Microsoft.CodeDom.Providers.DotNetCompilerPlatform,Version=2.0.1.0, Culture=neutral,PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The located assembly's manifest definition does not match the assembly's reference
    

    Now that the site has loaded, it's time to give version 8 a trial run.

    Wish me luck ...

  • James Menendez 4 posts 75 karma points
    Mar 04, 2019 @ 15:33
    James Menendez
    1

    You're a lifesaver!

    Thank you so much. I would have spent hours of time pulling my hair out if you hadn't posted this.

    Thanks!!! :)

  • MuirisOG 373 posts 1271 karma points
    Aug 13, 2019 @ 08:09
    MuirisOG
    0

    Many thanks for Marcin Zajkowski for this

    https://our.umbraco.com/forum/umbraco-8/98211-login-fails-when-trying-to-upgrade#comment-310202,

    ... he's also a life-saver.

    I also spotted that this line uses Umbraco.Web and not Umbraco, as in

    <add name="UmbracoMembershipProvider" type="Umbraco.Web.Security.Providers.MembersMembershipProvider, Umbraco.Web" minRequiredNonalphanumericCharacters="0" minRequiredPasswordLength="10" useLegacyEncoding="true" enablePasswordRetrieval="false" enablePasswordReset="false" requiresQuestionAndAnswer="false" defaultMemberTypeAlias="Member" passwordFormat="Hashed" allowManuallyChangingPassword="false" />
    

    In addition, I changed the line in umbracoSettings.config so that I could log in using my username and not my email address.

    <usernameIsEmail>false</usernameIsEmail>
    

    I had to change the connectionstring in the web.config to fix the timeout problems (I went all-out and added Connection Timeout=3600).

    I'm not sure if this was really an issue, but I also changed the Recovery Mode for the database properties in SQL Server to Simple rather than full, as the log file seemed to grow massively.

    Making sure the database version was set to 7.15.1 in the web.config, I ran the upgrade, which of course, failed.

    The log file showed I was using the (Obsolete) property editors, so I went back to my 7.15.1 site, fixed those, backed up the v7 database, restored it to my new v8 database and tried again.

    This is where I 'fess up. I have only one DocType in my whole set up (don't ask - it was a legacy thing), so it was easy to fix those errors.

    It took ages, so I left it overnight, and when I came back in the morning, Umbraco was still displaying the same page as when I left the night before. I checked the web.config and it was still on 7.15.1. So I checked the log and it said the database was upgraded. I refreshed the Umbraco screen, got the login prompt, and success. The web.config was updated and lo! there was a working backoffice for version 8.

    Next step, recreate our templates.

    And for others trying to upgrade, I recommend looking at these as well:

    https://our.umbraco.com/documentation/Getting-Started/Setup/Upgrading/migrating-to-v8

    https://our.umbraco.com/forum/umbraco-8/98211-login-fails-when-trying-to-upgrade

Please Sign in or register to post replies

Write your reply to:

Draft