Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Mark 15 posts 86 karma points
    Jun 08, 2016 @ 00:36
    Mark
    0

    umbraco forms error: has not been loaded & is required for Umbraco Forms 7

    I already have jquery in the page but the umbraco forms still shows this where the form should be any ideas why?

    jQuery has not been loaded & is required for Umbraco Forms. See Umbraco Forms Documentation

  • Keith Hubbard 174 posts 402 karma points
    Jun 08, 2016 @ 17:44
    Keith Hubbard
    0

    I have the same problem enter image description here

  • Keith Hubbard 174 posts 402 karma points
    Jun 08, 2016 @ 17:52
    Keith Hubbard
    0

    I tried to follow the documentation but no luck

  • Dennis Aaen 4437 posts 17900 karma points admin hq c-trib
    Jun 08, 2016 @ 18:59
    Dennis Aaen
    100

    Hi Keith and Mark,

    Please be sure that you added the below dependency in the top of your site. https://our.umbraco.org/documentation/Add-ons/UmbracoForms/Developer/Prepping-Frontend/

    <script src="http://ajax.aspnetcdn.com/ajax/jQuery/jquery-2.1.1.min.js"></script>
    <script src="http://ajax.aspnetcdn.com/ajax/jquery.validate/1.13.1/jquery.validate.min.js"></script>
    <script src="http://ajax.aspnetcdn.com/ajax/mvc/5.1/jquery.validate.unobtrusive.min.js"></script>
    

    If you want to load them in the bottom of the page you will do some extra try to see this documentation

    https://our.umbraco.org/documentation/Add-ons/UmbracoForms/Developer/Rendering-Scripts/

    If you are more into video see https://umbraco.tv/videos/umbraco-v7/implementor/extending/umbraco-forms/preparing-your-frontend/

    Hope this helps,

    /Dennis

  • Mark 15 posts 86 karma points
    Jun 10, 2016 @ 21:01
    Mark
    0

    this issue only appeared after I clicked the umbraco forms upgrade button in the backend cms.

    I uninstalled the forms package and installed it again and set the forms up again. followed the video on the link above. My JS scripts are at the bottom of the page.

    This fixed it.

    Regarding the purchased umbraco license. I placed the umbracoName.lic inside of the bin folder.

    But the form still did not send me an email, does anybody know how we go about installing the new license in the new version of umbraco forms in the new umbraco 7 (Umbraco version 7.4.3 )?

  • Dennis Aaen 4437 posts 17900 karma points admin hq c-trib
    Jun 12, 2016 @ 09:30
    Dennis Aaen
    0

    Hi Mark,

    The reason why you are seen this issue only appeared after you clicked the umbraco forms upgrade button, is that is a new thing that have been added see issue http://issues.umbraco.org/issue/CON-1040

    Regarding to the license, it´s right that you should place the .lic in your site's /bin/ folder make sure you also recycle the app pool so the license checker will re-validate the license file.

    The recycle of the app pool can simply be done by add a space into the web.config file, and then save the web.config file, then the app pool will recycle.

    Hope this helps,

    /Dennis

  • Chris 92 posts 238 karma points
    Jun 28, 2016 @ 13:15
    Chris
    0

    Hey,

    so I've got the same error message pop up after upgrading UmbracoForms. I had all required dependencies in my <head> so on my frontend everythings works like a charm.

    My problem is that the error message also pops in the backend when I render a form inside the grid editor. Not really a problem from my side, it is just a bit annoying when the content editor always calls me because there is a huge red error message in the backoffice while editing.

    Regards,

    Chris

  • Warren Buckley 2087 posts 4567 karma points MVP 6x admin hq c-trib
    Jun 29, 2016 @ 12:16
    Warren Buckley
    1

    Hello Chris,
    The messages in the backoffice is a bug and is fixed. See the related issue here http://issues.umbraco.org/issue/CON-1109

    Many Thanks,
    Warren :)

  • Lee 35 posts 83 karma points
    Jul 28, 2016 @ 16:34
    Lee
    1

    For me, this was caused by a simple oversight when I synced from local to dev. In the InsertUmbracoForm.cshtml, a parameter needed to be added to set mode = "form"

    Screenshot comparing

  • Bjarne Fyrstenborg 1149 posts 3275 karma points MVP 4x c-trib
    Oct 18, 2016 @ 06:36
    Bjarne Fyrstenborg
    0

    In our projects we are using gulp to bundle the scripts:

    // jQuery library + validation
    vendorPath + "jquery/dist/jquery.js",
    vendorPath + "jquery-validation/dist/jquery.validate.js",
    vendorPath + "jquery-validation-unobtrusive/jquery.validate.unobtrusive.js",
    
    // Umbraco Forms scripts
    "./../ProjectName.Web/App_Plugins/UmbracoForms/Assets/umbracoforms-dependencies.js",
    "./../ProjectName.Web/App_Plugins/UmbracoForms/Assets/umbracoforms.js",
    "./../ProjectName.Web/App_Plugins/UmbracoForms/Assets/umbracoforms-conditions.js",
    

    And then comment out the references in ~/Views/Partials/Forms/Script.cshtml ... just need to be aware, when upgrading Umbraco Forms as it overwrite this file.

    @*<script src="@Url.Content("~/App_Plugins/UmbracoForms/Assets/umbracoforms-dependencies.js")" type="text/javascript"></script>*@
    
    <script type="text/javascript">
        var contourDateFormat = "@Html.ConvertDateFormat()";
    
        //Check for library dependencies
        performDependencyChecks('@Model.FormClientId');
    </script>
    
    
    @*<script src="@Url.Content("~/App_Plugins/UmbracoForms/Assets/umbracoforms.js")" type="text/javascript"></script>
    <script src="@Url.Content("~/App_Plugins/UmbracoForms/Assets/umbracoforms-conditions.js")" type="text/javascript"></script>*@
    

    /Bjarne

  • Magnus Bolling 10 posts 90 karma points
    Aug 23, 2017 @ 12:15
    Magnus Bolling
    0

    Also got this when upgrading to Umbraco Forms 4.4.0. I can confirm that adding mode = "form" in root/Views/MacroPartials/InsertUmbracoForm.cshtml fixes the problem.

    The line should look like this:

    Html.RenderAction("Render", "UmbracoForms", new {formId = g, recordId = recordGuid, mode = "form"});
    
  • Oliver Boardman 19 posts 130 karma points
    May 20, 2019 @ 12:35
    Oliver Boardman
    0

    I also get this problem. I have the required scripts in the of my template. The license file is in the /bin folder, I have changed renderumbracoformscripts.cshtml as posted above but the message won't go away. The form even works after sending some test emails. Any suggestions?

  • Lee 35 posts 83 karma points
    Oct 24, 2019 @ 18:51
    Lee
    0

    Seriously, after all this time, I would think this could get resolved properly.

    enter image description here

    I did the unthinkable task of upgrading Umbraco Forms from 7.1.1 to 7.2.0. No Umbraco upgrade goes unpunished--ever.

    Umbraco is telling me the scripts that clearly exist, do not exist.

  • Lee 35 posts 83 karma points
    Nov 04, 2019 @ 13:44
    Lee
    0

    I had the three scripts in the head when this error starting appearing. That is where the were for the life of the website. Now that I have upgraded from Forms 7.1.1 to 7.2.0, I have had to move them to the bottom of the body to make the error go away.

    The docs state that either location is fine--but, that is simply not the case.

    https://our.umbraco.com/documentation/Add-ons/umbracoforms/developer/Prepping-Frontend/

  • Chantele Crossman 1 post 71 karma points
    Oct 25, 2019 @ 18:11
    Chantele Crossman
    0

    Have you added the snippet to the template you are using to insert the macro (not the macro partial view but your default template page or the specific template you are using on that webpage)? Don't forget to toggle the Exclude Scripts on the Macro. Rendering Forms scripts where you want

    @if (TempData["UmbracoForms"] != null)
        {
            foreach (var form in (List<Guid>)TempData["UmbracoForms"])
            {
                Html.RenderAction("RenderFormScripts", "UmbracoForms", new { formid = form, theme = "default" });
            }
        }
    

    Also, try inserting your form directly in your template just change the FormGuid with one of your GUID:

    @Umbraco.RenderMacro("renderUmbracoForm", new {FormGuid="dfea5397-36cd-4596-8d3c-d210502b67de", FormTheme="bootstrap3-horizontal", ExcludeScripts="1"})
    

    If that works, then you can narrow your issue down to calling your scripts.

Please Sign in or register to post replies

Write your reply to:

Draft