Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Jojo V 61 posts 162 karma points
    Jul 06, 2022 @ 13:37
    Jojo V
    0

    Umbraco Forms upgrade v8 to v10

    Hi,

    I was upgrade my umbraco instance from v8 to v10. This working OK. Now I install Umbraco Forms and it throw this error:

    Umbraco.Cms.Core.Exceptions.BootFailedException: The migration plan does not support migrating from state "7a044d6d-93ff-4534-8f19-ed2daa05451d".
    

    Then I rename database record value in table umbracoKeyValue from record "Umbraco.Core.Upgrader.State+UmbracoForms" to "Umbraco.Core.Upgrader.State+UmbracoFormsOld". After this changed Umbraco started. But umbraco forms in backoffice throw another error:

    Invalid column name 'ViewEntries'. Invalid column name 'EditEntries'.
    

    I think its problem with migrations, maybe.

    My question is simple. How to fix it? :D How to upgrade umbraco forms v8 to v10 without lost data?

    Thanks.

  • Jacob Buus 3 posts 73 karma points
    Aug 01, 2022 @ 19:24
    Jacob Buus
    0

    Any "real" solution to this (sorry @Jojo V :) ) I'm facing the exact same issue upgrading from an Umbraco 8 to 10 site with Forms. Everything runs really smoothly through getting the Umbraco 10 site up and running using the Umbraco 8 database. But all of the sudden the site starts throwing the BootFailedException with the "... plan does not support migrating from state...."

    Very frustrating since this is the only thing holding me back from getting the site up and running :/

  • Rune Grønkjær 1342 posts 3032 karma points
    Aug 26, 2022 @ 08:38
    Rune Grønkjær
    0

    Me too. Anyone found a solution?

  • Jonas 5 posts 75 karma points
    Aug 26, 2022 @ 11:27
    Jonas
    0

    Having the same issue, upgrading from 8.18.4 to 10.1.0

    • I have alot of data in my forms tables in the database ( UFtables )
    • If I dont have the forms packages installed I can run the website and log into umbraco backoffice with umbraco core 10.1.0.
    • I can see all my other content from the datbase like pages/nodes.

    But as soon as i add the latest Umbraco.Forms package I get the same error but with a different state ID: 1d084819-84ba-4ac7-b152-2c3d167d22bc

    Anyone managed to solve this?

  • Sebastiaan Janssen 5009 posts 15264 karma points MVP admin hq
    Aug 26, 2022 @ 13:07
    Sebastiaan Janssen
    0

    7a044d6d is the migration named AddFormsFolderConstraints and 1d084819 is AddFormsDbStorage. Both migrations seem to exist in Forms v9 but not in v10. Maybe you need to do a v9 intermediate step while upgrading? Not sure..

  • Andy Butland 407 posts 2269 karma points MVP 4x hq c-trib
    Aug 26, 2022 @ 13:20
    Andy Butland
    1

    To upgrade to Forms 10 you need to be at least the latest version of Forms 8 or 9 when 10 was released (and to have Forms configured for storing form definitions in the database.

    There's a bit more details about this here.

    Both the migration states mentioned in this thread I can see were introduced in earlier minors of Forms 8. With Forms 10 we've collapsed the migrations (partly just to clean up, partly for issues with SQLite support needing some to be rewritten), so that's why these states aren't being recognised.

    Andy

  • Jonas 5 posts 75 karma points
    Aug 29, 2022 @ 08:49
    Jonas
    0

    Hello Andy!

    The way I understand the documentation is that since I have all my forms data stored in the database already I should be able to upgrade from 8 to 10 with a sucessful migration.

    Does it work for some 8 to 10 upgrades or none at all? Am I just unlucky and there is no way to get past this SQL error and only start from scratch?

    I feel like I have tried everything to get v10 of forms to work with my current db forms data.

  • Andy Butland 407 posts 2269 karma points MVP 4x hq c-trib
    Aug 29, 2022 @ 09:01
    Andy Butland
    0

    You still need to be on at least what was the latest Forms 8 minor with Forms 10 came out, which was 8.12. So if you are attempting to migrate from an earlier version than that, you'll see an error as the migration state of your database won't be one that Forms 10 recognises.

    Andy

  • Jonas 5 posts 75 karma points
    Aug 29, 2022 @ 09:14
    Jonas
    0

    Okay thanks for the clarification!

    My forms packages in the old project were a bit behind in version to do just that then. I will try to upgrade the old project and then attach that database instead.

  • Jonas 5 posts 75 karma points
    Aug 29, 2022 @ 09:51
    Jonas
    0

    It worked! Thanks again Andy

    To anyone else that didnt quite understand the documementation correctly like me, its not enough to just have a 8.xx version that stores forms data in the db.

    You need atleast 8.12 on your forms package

  • Mike Welch 6 posts 74 karma points
    Aug 26, 2022 @ 13:47
    Mike Welch
    0

    I have run into the same issue.

    I'm trying to install Umbraco Forms on my project that was migrated from 7 to 9.5. I didn't attempt to migrate forms until now.

    At this point, I'm not concerned about migrating the forms and data. I would be happy to just have forms installed and working. Is there anyway to remove the old Umbraco Forms data, so I can start clean?

    Thanks,

    Mike

  • Jacob Buus 3 posts 73 karma points
    Aug 26, 2022 @ 13:53
    Jacob Buus
    0

    I actually took the approach to NOT migrate the Forms setup from 8 to 10 - simply because it broke my site. I simply made the Umbraco upgrade from 8 to 10 - and then just uninstalled the Umbraco Forms package. Now everything works (without Forms though).

    Once your Umbraco 10 site is up and running, you shuold be able to start from scratch with Forms. However - before you add Forms again, you might need to go into the database an remove the actual Forms version left over from your Umbraco 8 site. This is what broke my site because Umbraco stated that "...plan does not support migrating from state."

    But if you plan on starting completely from scratch again, then I thinks it's doable.

  • Andy Butland 407 posts 2269 karma points MVP 4x hq c-trib
    Aug 26, 2022 @ 14:31
    Andy Butland
    0

    Hi Mike, yes you should be good to just remove all the Forms tables - they all start with UF.

    And then as Jacob says, remove the details of your previous migration state, which you can do with:

    DELETE FROM umbracoKeyValue
    WHERE [key] = 'Umbraco.Core.Upgrader.State+UmbracoForms'
    

    Andy

  • Heather Floyd 577 posts 883 karma points MVP 4x c-trib
    18 days ago
    Heather Floyd
    1

    I just came across this issue while working on a site upgrade from latest v7 to v10...

    I hadn't done any interim Umbraco Forms version updates (to 8.x or to 9.x), but since moving to v10 for the main CMS have done a lot of schema work, so I really didn't want to go back and start over, or delete existing forms data and entries.

    I figured out that using SQL Management Studio, it's possible to fix the issue.

    1. Run this against the DB:

      ALTER TABLE [dbo].[UFUserSecurity] ADD [ViewEntries] [bit] ;

      ALTER TABLE [dbo].[UFUserSecurity] ADD [EditEntries] [bit] ;

      GO

    2. Open the table [UFUserSecurity] for editing the records.

    3. Set either "true" or "false" on the two new fields for any records present. (Save the data changes.)

    4. Open the table [UFUserSecurity] in "Design" view.

    5. Un-check "Allow Nulls" on the two new fields. Save the changes.

  • Michael Voysey 1 post 71 karma points
    1 week ago
    Michael Voysey
    0

    This worked for me, in umbraco 10 the forms editor now loads

    I modified your SQL so it is possible to do in two steps:

    ALTER TABLE [dbo].[UFUserSecurity] ADD [ViewEntries] [bit] NOT NULL DEFAULT 0;
    ALTER TABLE [dbo].[UFUserSecurity] ADD [EditEntries] [bit] NOT NULL DEFAULT 0;
    GO
    

    If you don't care who views or can edit entries then set the default to 1 otherwise you can start updating the row per user id with the UPDATE

Please Sign in or register to post replies

Write your reply to:

Draft