Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Stief Dirckx 43 posts 76 karma points
    Aug 10, 2017 @ 12:53
    Stief Dirckx

    Backoffice no longer localized after upgrade to 7.6.5

    After upgrading from Umbraco 7.5.12 to 7.6.5 the backoffice is no longer localized. All texts are between square brackets now (see screenshot).

    My web.config hasn't changed and still has:

    <add key="umbracoDefaultUILanguage" value="en" />

    The user that is logged in has it's language set to English (United Kingdom) and in the database it's 'en-GB'.

    All language files in /Umbraco/Config/Lang/ are present.

    But in the log I see this returning several times:

    2017-08-10 14:03:36,090 [P17464/D2/T67] WARN Umbraco.Core.Services.LocalizedTextService - The culture specified nl-BE was not found in any configured sources for this service

    But I have no idea why it's trying to use 'nl-BE' as the backoffice language. My site is partly in Dutch but I don't see what this has got to do with the backoffice.

    What could be the reason for the backoffice trying to use nl-BE as the backoffice language?


  • Manjunatha Govindappa 20 posts 119 karma points
    Aug 11, 2017 @ 04:10
    Manjunatha Govindappa

    check language set for your umbraco user

  • Stief Dirckx 43 posts 76 karma points
    Aug 11, 2017 @ 18:13
    Stief Dirckx

    @Manjunatha Thanks for the tip, but like I said in my initial post the Umbraco user was set to English (United Kingdom) and the database record has the proper value 'en-GB'.

    I also tried changing the language for the user to Danish and that showed me something strange. Some parts of the backoffice are translated to Danish but others are not (see screenshot). While the log file still shows the same error that the LocalizedTextService tries to find translations for 'nl-BE'.

    enter image description here

  • Ismael 71 posts 354 karma points
    Nov 10, 2017 @ 00:37


    Weirdly, this has just happened to me, did you ever find the issue?

    In my case, my local environment is fine, however my test environment (which is on another machine) is not - the source/files are the same, but my test database was replicated from production.
    I wondering if its a machine specific issue (a setting somewhere), however I'm still trying to figure out how to test that theory.


  • Stief Dirckx 43 posts 76 karma points
    Nov 10, 2017 @ 09:27
    Stief Dirckx

    @Ismael Unfortunately not. I tried upgrading several times but each time with the same 'faulty' result. So now my site is still on 7.5.x.

    I even asked Sebastiaan from HQ but I was the only one reporting this so he didn't think it was an Umbraco bug.

    Keep me posted if you find anything...

  • Stief Dirckx 43 posts 76 karma points
    Nov 28, 2017 @ 09:34
    Stief Dirckx

    A couple of days ago I tried upgrading my website again from Umbraco version 7.5.12 to 7.6.12 and now everything went perfectly. No more localization problems anymore.

    The only difference since my first attempt was to clean my local working copy before starting the upgrade. I ran git clean -fdx which removed the app_data, umbraco and umbraco_client folders.

    Afterwards I also could upgrade to version 7.7.6 without any problem.

  • Aleksander 45 posts 205 karma points
    Jun 26, 2018 @ 09:42

    I have this exact error after upgrading to 7.10.4.

    The log sais
    2018-06-26 11:33:01,001 [P34908/D2/T7] WARN Umbraco.Core.Services.LocalizedTextService - The culture specified en-DK was not found in any configured sources for this service

    I checked DB and web.config, and everything is being correctly set to en-US, or da-DK accordingly. I have no idea of where it's getting en-DK though? Anyone that can shed some light?



    This fixed it for me:

  • Chris Kim 48 posts 254 karma points c-trib
    Jan 15, 2019 @ 23:15
    Chris Kim

    We had the same issue when changing the httpRuntime targetFramework to 4.7 in the web.config.

    It is related to this issue: and has been fixed in 7.13.

Please Sign in or register to post replies

Write your reply to: