Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Carl 65 posts 87 karma points MVP
    Jul 27, 2010 @ 21:19
    Carl
    0

    Umbraco Admin interface not showing stylesheets

    Hi All

    I've had a weird error start happening - The admin interface (umbraco.aspx) has stopped showing my stylesheets so I can't edit them. When I navigate to the settings section, I can see it allows me to expand it, but when I do, it flickers then shows nothing, when I know I have a css stylesheet in the correct folder. I've reset the folder permissions, I've tried creating a new file (same problem, and this time the file is not actually created)

    Anyone encountered similar issues before?

  • Tom Maton 387 posts 659 karma points
    Jul 27, 2010 @ 22:04
    Tom Maton
    0

    I had something similar before and all I did was do an iisreset (out of desperation as nothing else worked)

  • Carl 65 posts 87 karma points MVP
    Jul 27, 2010 @ 22:19
    Carl
    0

    Tried that already I'm afraid and it didn't work. It's very weird because it's only happening in the settings -> stylesheets section and no others. It's driving me mad

  • Arimas Artadi 4 posts 24 karma points
    Jul 28, 2010 @ 10:17
    Arimas Artadi
    0

    have you checked permissions for folder css? Is network service / iis_iusr has full control for that folder?

  • atze187 160 posts 215 karma points
    Jul 28, 2010 @ 10:49
    atze187
    0

    Have you included the ".css" extension in the name of the new stylesheet? That caused such problems for me...

  • Sascha Wolter 615 posts 1101 karma points
    Jul 28, 2010 @ 13:20
    Sascha Wolter
    0

    Hm, maybe you could move your stylesheets to a temporary location on your hard drive and see what happens? Then try adding a new file 'test.css' to the CSS folder and see if Umbraco picks it up? Then try and add a new style via Umbraco?

    Have you checked file permissions on the folder? Sometimes the system doesn't cascade the permissions properly down.

    Just fumbling in the dark here, never had that problem so far.

  • John C Scott 457 posts 1157 karma points
    Nov 03, 2010 @ 11:54
    John C Scott
    0

    having exactly the same problem with a site right now  - it was working fine for ages, and nothing changed except the user reports that they created a new stylesheet anbd then abandoned the create without saving and then this problem occurred - would be good to get help with how to resolve this

  • John C Scott 457 posts 1157 karma points
    Nov 03, 2010 @ 12:06
    John C Scott
    0

    ahaa - i think i know what happened now in my case

    i went to the create packages page to see the files I could add to see what files are in the application (the customer has control over the hosting of this site, so I only have access to the umbraco application) and when I right-clicked packages and chose "Create" I got a yellow screen of death error:

    "Could not find file 'D:\inetpub\SAM\SAM_CMS_Aug10\css\shadowbox.css'.

    I checked with the user and this is the CSS file they abandoned the creation of, ie they started creating it but did not click save.
    So it seems Umbraco thinks this file should exist but it does not.
    I'm going to try placing an empty css file in there using a package.
    As otherwise I need to talk to the customer about IIS resets or editing the database, which at this early stage may cause them to doubt the product.

     

  • Carl 65 posts 87 karma points MVP
    Nov 03, 2010 @ 12:11
    Carl
    0

    Hi John

    That's a good trick to diagnose this problem, as I wasn't seeing anything in the event logs and no other exceptions when I had it. I can see theres a bug here, will try to investigate further if I have time. Did creating an empty file do the trick?

  • John C Scott 457 posts 1157 karma points
    Nov 03, 2010 @ 12:15
    John C Scott
    0

    yes that worked :)

    though when i got it running again it was clear that the user had entered .css as part of the file name

    so there was a duplicate entry for shadowbox.css and shadowbox once the package was loaded

    i'll go to codeplex and vote up the issue etc. 

  • Kanwar 8 posts 29 karma points
    Jun 17, 2011 @ 09:46
    Kanwar
    0

    Umbraco Admin interface not showing stylesheets

    i am also get same problem.Please help me.

  • Cameron 23 posts 42 karma points
    Aug 20, 2012 @ 02:17
    Cameron
    0

    I just encountered this issue today on umbraco v 4.7.2

    I can confirm there was a css file with .css in its name eg. style.css.css

    Renaming this file and then restarting IIS resolved the issue for me.

    Cheers,

    Cam

  • colin gray 16 posts 56 karma points
    Nov 14, 2013 @ 18:18
    colin gray
    0

    MY FIX

    had this issue with v6.1.3,

    using my hosting control pannel I could see there was a file something.css.css 

    deleted through control pannel tools > fixed it (no IIS restart required)

Please Sign in or register to post replies

Write your reply to:

Draft