Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Sjors Pals 615 posts 268 karma points
    Aug 11, 2010 @ 11:28
    Sjors Pals
    0

    Paragraph Tags and force_p_newlines setting

    In the Richtext editor, i want to disable the automatic conversion of linebreaks to paragraphs. After some googling i found that there is a force_p_newlines setting for TinyMCE, can someone tell me or i do have to configure this in the tinymceconfig.config, and if yes, what setting?

  • dan 29 posts 53 karma points
    Aug 15, 2010 @ 03:59
    dan
    0

     

    Example of TinyMCE configuration

    <html>
    <head>
    <script language="javascript" type="text/javascript" src="../jscripts/tiny_mce/tiny_mce.js"></script>
    <script language="javascript" type="text/javascript">
    tinyMCE.init({
        force_p_newlines: true
    });
    </script>
    

    Try this.. There's a wiki.. http://wiki.moxiecode.com/index.php/TinyMCE:Index

     

    danielcruger.com

     

  • jc 64 posts 100 karma points
    Aug 15, 2010 @ 14:58
    jc
    1

    I think it's actually set in ~/config/tinyMceConfig.config

    <customConfig>
        <config key="force_p_newlines">true</config>
    </customConfig>

    You'll need to restart the app in order for changes to take effect.

     

     

  • Sjors Pals 615 posts 268 karma points
    Aug 15, 2010 @ 16:45
    Sjors Pals
    0

    Thx, this was what i was looking for, had no time to test it yet, since had to fix some other stuff, great thanks for your help.

  • Phillip Ng 148 posts 250 karma points
    Jan 25, 2012 @ 00:06
    Phillip Ng
    0

    Hate to bring up old issues, but I can't find this in the config file. I tried adding it and touched the web.config file, but no luck still. Am I missing something? On version 4.5.2. Thanks!

  • jc 64 posts 100 karma points
    Jan 25, 2012 @ 02:05
    jc
    0

    Phillip,

       It should go all the way at the bottom of ~/config/tinyMceConfig.config

       If you're not seeing it in your version of the file, check out this link and scroll all the way to the bottom for the customConfig section: http://umbraco.codeplex.com/SourceControl/changeset/view/42e0985fede2#config%20templates%2fconfig%2ftinyMceConfig.config

       You should be able to add a new key there. If youi're wanting to disable the forced newlines, make sure to set it to false.

  • Phillip Ng 148 posts 250 karma points
    Feb 04, 2012 @ 06:46
    Phillip Ng
    0

    Ah, after some digging, I found the settings in umbraco_client > tinymce3 > tiny_mce_src.js. Thanks for the response!

Please Sign in or register to post replies

Write your reply to:

Draft