Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Simon steed 371 posts 683 karma points
    Dec 02, 2010 @ 17:27
    Simon steed
    0

    Umbraco CMS is screwed - lost all styling

    Came to setup a site today and got the following

     

    Anyone got any ideas what could be wrong? The only thing the host has done is move from classic to integrated pipeline mode but can't think why it would cause a problem - i've not changed it back as the front end is working fine, it's just the CMS that is goosed?

    Ideas?

    Simon

  • Lee Kelleher 3993 posts 15620 karma points MVP 12x admin c-trib
    Dec 02, 2010 @ 17:51
    Lee Kelleher
    0

    Hi Simon,

    Uh-oh, doesn't look pretty.  My guess would be to do with file permissions for the /App_Data/ClientDependency directory.

    But with you saying that your hosts switched from classic to integrated... you might be missing something in the Web.config, (not sure what that might though).

    Cheers, Lee.

  • Laurence Gillian 597 posts 1216 karma points
    Dec 02, 2010 @ 19:37
    Laurence Gillian
    0

    My first port of call would be opening it up in Firefox running Firebug.

    I'd imagine its a permissions issue, so use the network section to determine what error the server is throwing for those files.

    I don't suppose by any chance your host has upgraded the install for you? I've seen issues when the windows compression tool doesn't extract folders correctly and just misses files out.

  • Simon steed 371 posts 683 karma points
    Dec 03, 2010 @ 13:01
    Simon steed
    0

    Well for now i've got it working but had to revert to classic mode - I suspect the web.config file has been screwed in the changeover (see http://our.umbraco.org/forum/core/general/14106-Client-Dependency-woes-refresh-cache).

    I'll have a look over the weekend, get it working locally in integrated pipeline mode and then upload the config file and try again

    Cheers all

    Si

  • Matt Brailsford 3630 posts 19227 karma points MVP 9x c-trib
    Dec 03, 2010 @ 14:26
    Matt Brailsford
    0

    Hey Simon,

    I had this happen to me the other day, but can't remember what I did to fix it.

    Have you tried deleting the client dependancy folder in the App_Data folder (i think)? It kinda looks like it's just the CSS that's a bit screwed. Maybe try accessing the CSS path directly and see what happens.

    Cheers

    Matt

  • Simon steed 371 posts 683 karma points
    Dec 03, 2010 @ 14:33
    Simon steed
    0

    Cheers Matt,

     

    Yup deleted the client dep folder, same old. Recycled the app pool and nothing. The CSS is being pulled through no probs as there are no errors. Network tab in firebug tells me:

    http://telcoop.local/umbraco/DependencyHandler.axd?s=L3VtYnJhY29fY2xpZW50L3BhbmVsL3N0eWxlLmNzczsvdW1icmFjb19jbGllbnQvc2Nyb2xsaW5nbWVudS9zdHlsZS5jc3M7L3VtYnJhY29fY2xpZW50L3VpL2RlZmF1bHQuY3NzOw%3d%3d&t=Css&cdv=1 404 not found - obviously linked to the client dependancy issue people have told me about but clueless how to sort it.

    Front end is fine and dandy

  • Matt Brailsford 3630 posts 19227 karma points MVP 9x c-trib
    Dec 03, 2010 @ 14:40
    Matt Brailsford
    0

    Coupld of things to check:

    1) Have you got the .axd handler registered in your web.config?

    2) Have you set the .axd extension NOT to check file exists? (in IIS)

    This soooo rings a bell, I just can't remember what I did =)

    Matt

  • Matt Brailsford 3630 posts 19227 karma points MVP 9x c-trib
    Dec 03, 2010 @ 14:42
    Matt Brailsford
    0

    You could also try incrementing the version number in the client dependency config file.

    Matt

  • Rick Mather 42 posts 124 karma points
    Dec 03, 2010 @ 15:03
    Rick Mather
    0

    This has happened to me too, i'm can't remember 100% but I think I resolved it by clearing out /App_Data/TEMP/ClientDependency.

    From what I remember it happened when I set up an initial Umbraco site using Cassini - as soon as I switched to using IIS on a proper domain I got what you're experiencing (as the backend was still trying to access resources on 'localhost').

  • Simon steed 371 posts 683 karma points
    Dec 03, 2010 @ 18:12
    Simon steed
    0

    Incremented the version, no difference

    Tried removing the contents of temp same

    tried recycling app pool after all the above. I've managed to reproduce it locally now in Windows 7 under IIS so can play with a few things to see what works - may try a fresh install into an integrated pool to see how it's setup

  • Daniel Horn 319 posts 344 karma points
    Dec 04, 2010 @ 00:04
    Daniel Horn
    0

    The permissions are all fine?

  • Simon steed 371 posts 683 karma points
    Dec 05, 2010 @ 14:50
    Simon steed
    0

    Incremented the version, no difference

    Tried removing the contents of temp same

    tried recycling app pool after all the above. I've managed to reproduce it locally now in Windows 7 under IIS so can play with a few things to see what works - may try a fresh install into an integrated pool to see how it's setup

    Just installed a new version, set the app pool to v4 integrated and got the same thing. Changed it to v2 integrated and problem is fixed. However the original reason for doing it is for extensionless urls which now no longer work!

    I thought Umbraco 4.5.2 would work in v4 integrated mode - obviously not, anyone got it working yet?

    Si

  • Simon steed 371 posts 683 karma points
    Dec 05, 2010 @ 14:50
    Simon steed
    0

    Duplicate post

  • Rich Green 2246 posts 4008 karma points
    Dec 05, 2010 @ 15:00
    Rich Green
    0

    Hi Simon,

    I've been running all my 4.5.2 sites in .net v4 integrated, both locally and on the live server, no problems here.

    Rich

  • Rich Green 2246 posts 4008 karma points
    Dec 05, 2010 @ 15:05
    Rich Green
    0

    Let me know if there's anything I can check here that'll help you?

    Rich

  • Simon steed 371 posts 683 karma points
    Dec 05, 2010 @ 15:12
    Simon steed
    0

    Thanks Rich - could you send me a copy of your web.config as that seems to be the source of the problems I reckon.

  • Rich Green 2246 posts 4008 karma points
    Dec 05, 2010 @ 15:46
    Rich Green
    0

    Sure, it's just the default 4.5.2 one. Rich

    <?xml version="1.0" encoding="utf-8"?>
    <configuration>
      <configSections >
        <section name="urlrewritingnet" restartOnExternalChanges="true" requirePermission="false" type="UrlRewritingNet.Configuration.UrlRewriteSection, UrlRewritingNet.UrlRewriter" />
        <section name="microsoft.scripting" type="Microsoft.Scripting.Hosting.Configuration.Section, Microsoft.Scripting, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" />
    
        <section name="clientDependency" type="ClientDependency.Core.Config.ClientDependencySection, ClientDependency.Core"/>
        <section name="Examine" type="Examine.Config.ExamineSettings, Examine"/>
        <section name="ExamineLuceneIndexSets" type="UmbracoExamine.Config.ExamineLuceneIndexes, UmbracoExamine"/>
    
      </configSections>
    
      <urlrewritingnet configSource="config\UrlRewriting.config" />
      <microsoft.scripting configSource="config\scripting.config" />
      <clientDependency configSource="config\ClientDependency.config" />
      <Examine configSource="config\ExamineSettings.config" />
      <ExamineLuceneIndexSets configSource="config\ExamineIndex.config" />
    
      <appSettings>
        <add key="umbracoDbDSN" value="server=.\SQLEXPRESS;database=DATABASE;user id=USER;password=PASS" />
        <add key="umbracoConfigurationStatus" value="" />
        <add key="umbracoReservedUrls" value="~/config/splashes/booting.aspx,~/install/default.aspx,~/config/splashes/noNodes.aspx" />
        <add key="umbracoReservedPaths" value="~/umbraco,~/install/" />
        <add key="umbracoContentXML" value="~/App_Data/umbraco.config" />
        <add key="umbracoStorageDirectory" value="~/App_Data" />
        <add key="umbracoPath" value="~/umbraco" />
        <add key="umbracoEnableStat" value="false" />
        <add key="umbracoHideTopLevelNodeFromPath" value="true" />
        <add key="umbracoEditXhtmlMode" value="true" />
        <add key="umbracoUseDirectoryUrls" value="false" />
        <add key="umbracoDebugMode" value="true" />
        <add key="umbracoTimeOutInMinutes" value="20" />
        <add key="umbracoVersionCheckPeriod" value="7" />
        <add key="umbracoDisableXsltExtensions" value="true" />
        <add key="umbracoDefaultUILanguage" value="en" />
        <add key="umbracoProfileUrl" value="profiler" />
        <add key="umbracoUseSSL" value="false" />
        <add key="umbracoUseMediumTrust" value="false" />
    
        <!-- 
            Set this to true to enable storing the xml cache locally to the IIS server even if the app files are stored centrally on a SAN/NAS 
            Alex Norcliffe 2010 02 for 4.1-->
        <add key="umbracoContentXMLUseLocalTemp" value="false"/>
      </appSettings>
      <system.net>
        <mailSettings>
          <smtp>
            <network host="127.0.0.1" userName="username" password="password" />
          </smtp>
        </mailSettings>
      </system.net>
    
      <connectionStrings>
        <remove name="LocalSqlServer" />
        <!--<add name="LocalSqlServer" connectionString="server=.\sqlexpress;database=aspnetdb;user id=DBUSER;password=DBPASSWORD" providerName="System.Data.SqlClient"/>-->
      </connectionStrings>
    
      <system.web>
        <!-- <trust level="Medium" originUrl=".*" />-->
    
        <customErrors mode="RemoteOnly" />
        <trace enabled="true" requestLimit="10" pageOutput="false" traceMode="SortByTime" localOnly="true" />
        <sessionState mode="InProc" stateConnectionString="tcpip=127.0.0.1:42424" sqlConnectionString="data source=127.0.0.1;Trusted_Connection=yes" cookieless="false" timeout="20" />
        <globalization requestEncoding="UTF-8" responseEncoding="UTF-8" />
        <xhtmlConformance mode="Strict" />
    
        <httpRuntime requestValidationMode="2.0" />
    
        <pages enableEventValidation="false">
          <!-- ASPNETAJAX -->
          <controls>
            <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
            <add tagPrefix="umbraco" namespace="umbraco.presentation.templateControls" assembly="umbraco" />
            <add tagPrefix="asp" namespace="System.Web.UI.WebControls" assembly="System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          </controls>
        </pages>
    
        <httpModules>
          <!-- URL REWRTIER -->
          <add name="UrlRewriteModule" type="UrlRewritingNet.Web.UrlRewriteModule, UrlRewritingNet.UrlRewriter" />
          <add name="umbracoRequestModule" type="umbraco.presentation.requestModule" />
          <!-- UMBRACO -->
          <add name="viewstateMoverModule" type="umbraco.presentation.viewstateMoverModule" />
          <add name="umbracoBaseRequestModule" type="umbraco.presentation.umbracobase.requestModule" />
          <!-- ASPNETAJAX -->
          <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <!-- CLIENT DEPENDENCY -->
          <add name="ClientDependencyModule" type="ClientDependency.Core.Module.ClientDependencyModule, ClientDependency.Core"/>
        </httpModules>
    
    
        <httpHandlers>
          <remove verb="*" path="*.asmx" />
          <!-- ASPNETAJAX -->
          <add verb="*" path="*.asmx" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false" />
          <add verb="*" path="*_AppService.axd" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false" />
          <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false" />
    
          <!-- UMBRACO CHANNELS -->
          <add verb="*" path="umbraco/channels.aspx" type="umbraco.presentation.channels.api, umbraco" />
          <add verb="*" path="umbraco/channels/word.aspx" type="umbraco.presentation.channels.wordApi, umbraco" />
          <add verb="*" path="DependencyHandler.axd" type="ClientDependency.Core.CompositeFiles.CompositeDependencyHandler, ClientDependency.Core "/>
          <add verb="GET,HEAD,POST" path="GoogleSpellChecker.ashx" type="umbraco.presentation.umbraco_client.tinymce3.plugins.spellchecker.GoogleSpellChecker,umbraco" />
        </httpHandlers>
    
        <compilation defaultLanguage="c#" debug="false" batch="false" targetFramework="4.0">
          <assemblies>
            <!-- ASP.NET 4.0 Assemblies -->
            <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
            <add assembly="System.Core, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
            <add assembly="System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
            <add assembly="System.Xml.Linq, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
            <add assembly="System.Data.DataSetExtensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
            <add assembly="System.Web.Extensions.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
            <add assembly="System.Web.Abstractions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
          </assemblies>
        </compilation>
    
        <authentication mode="Forms">
          <forms name="yourAuthCookie" loginUrl="login.aspx" protection="All" path="/" />
        </authentication>
    
        <authorization>
          <allow users="?" />
        </authorization>
    
        <!-- Membership Provider -->
        <membership defaultProvider="UmbracoMembershipProvider" userIsOnlineTimeWindow="15">
          <providers>
            <clear />
            <add name="UmbracoMembershipProvider" type="umbraco.providers.members.UmbracoMembershipProvider" enablePasswordRetrieval="false" enablePasswordReset="false" requiresQuestionAndAnswer="false" defaultMemberTypeAlias="Another Type" passwordFormat="Hashed" />
            <add name="UsersMembershipProvider" type="umbraco.providers.UsersMembershipProvider" enablePasswordRetrieval="false" enablePasswordReset="false" requiresQuestionAndAnswer="false" passwordFormat="Hashed" />
          </providers>
        </membership>
    
        <!-- added by NH to support membership providers in access layer -->
        <roleManager enabled="true" defaultProvider="UmbracoRoleProvider">
          <providers>
            <clear />
            <add name="UmbracoRoleProvider" type="umbraco.providers.members.UmbracoRoleProvider" />
          </providers>
        </roleManager>
    
        <!-- Sitemap provider-->
        <siteMap defaultProvider="UmbracoSiteMapProvider" enabled="true">
          <providers>
            <clear />
            <add name="UmbracoSiteMapProvider" type="umbraco.presentation.nodeFactory.UmbracoSiteMapProvider" defaultDescriptionAlias="description" securityTrimmingEnabled="true" />
          </providers>
        </siteMap>
      </system.web>
    
      <!-- ASPNETAJAX -->
      <system.web.extensions>
        <scripting>
          <scriptResourceHandler enableCompression="true" enableCaching="true" />
        </scripting>
      </system.web.extensions>
    
      <system.webServer>
        <validation validateIntegratedModeConfiguration="false" />
        <modules runAllManagedModulesForAllRequests="true">
          <remove name="ScriptModule" />
          <remove name="UrlRewriteModule" />
          <remove name="umbracoRequestModule" />
          <remove name="viewstateMoverModule" />
          <remove name="umbracoBaseRequestModule" />
          <remove name="ClientDependencyModule" />
    
          <add name="UrlRewriteModule" type="UrlRewritingNet.Web.UrlRewriteModule, UrlRewritingNet.UrlRewriter" />
          <add name="umbracoRequestModule" type="umbraco.presentation.requestModule" />
          <add name="viewstateMoverModule" type="umbraco.presentation.viewstateMoverModule" />
          <add name="umbracoBaseRequestModule" type="umbraco.presentation.umbracobase.requestModule" />
          <add name="ScriptModule" preCondition="managedHandler" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add name="ClientDependencyModule" type="ClientDependency.Core.Module.ClientDependencyModule, ClientDependency.Core"/>
        </modules>
    
        <handlers accessPolicy="Read, Write, Script, Execute">
          <remove name="WebServiceHandlerFactory-Integrated" />
          <remove name="ScriptHandlerFactory" />
          <remove name="ScriptHandlerFactoryAppServices" />
          <remove name="ScriptResource" />
          <remove name="Channels" />
          <remove name="Channels_Word" />
          <remove name="ClientDependency" />
          <remove name="SpellChecker" />
    
          <add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add name="ScriptResource" verb="GET,HEAD" path="ScriptResource.axd" preCondition="integratedMode" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add verb="*" name="Channels" preCondition="integratedMode" path="umbraco/channels.aspx" type="umbraco.presentation.channels.api, umbraco" />
          <add verb="*" name="Channels_Word" preCondition="integratedMode" path="umbraco/channels/word.aspx" type="umbraco.presentation.channels.wordApi, umbraco" />
          <add verb="*" name="ClientDependency" preCondition="integratedMode" path="DependencyHandler.axd" type="ClientDependency.Core.CompositeFiles.CompositeDependencyHandler, ClientDependency.Core "/>
          <add verb="GET,HEAD,POST" preCondition="integratedMode" name="SpellChecker" path="GoogleSpellChecker.ashx" type="umbraco.presentation.umbraco_client.tinymce3.plugins.spellchecker.GoogleSpellChecker,umbraco"/>
        </handlers>
      </system.webServer>
    
    
      <system.codedom>
        <compilers>
          <compiler language="c#;cs;csharp" extension=".cs" type="Microsoft.CSharp.CSharpCodeProvider,System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" warningLevel="4">
            <providerOption name="CompilerVersion" value="v4.0" />
            <providerOption name="WarnAsError" value="false" />
          </compiler>
        </compilers>
      </system.codedom>
    
      <runtime>
        <!-- Old asp.net ajax assembly bindings -->
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
          <dependentAssembly>
            <assemblyIdentity name="System.Web.Extensions" publicKeyToken="31bf3856ad364e35" />
            <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="4.0.0.0" />
          </dependentAssembly>
          <dependentAssembly>
            <assemblyIdentity name="System.Web.Extensions.Design" publicKeyToken="31bf3856ad364e35" />
            <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="4.0.0.0" />
          </dependentAssembly>
        </assemblyBinding>
      </runtime>
    
    </configuration>
  • Simon steed 371 posts 683 karma points
    Dec 09, 2010 @ 17:35
    Simon steed
    0

    Still no closer to sorting this one - very frustrating

  • Siw Ørnhaug 130 posts 109 karma points
    Dec 15, 2010 @ 19:43
    Siw Ørnhaug
    0

    Hi Simon, sorted it out now?

    I upgraded a copy of 3.0.6 site first via 4.0.3 and then directly to 4.5.2 .net 3.5 using a backup of the original database. This on a shared host.

    Everything went well, except I had to set config to xml legacy schema and republish the site.

    So I backed up the original site, deleted all files and copied everything from the upgrade site. Pointing to the same (new) database.

    While the front end works smoothly the backend is exactly as your screen capture. I don't get it. It's a complete copy of a site with no errors.

    I guess I have to look into the app pool question, but if the upgrade site and the now halfway ruined original site runs exact same app pool setup - what can I do?? I'm no Umbraco wizard.

     

     

  • Simon steed 371 posts 683 karma points
    Dec 17, 2010 @ 15:02
    Simon steed
    0

    Hi,

    Sorry meant to reply to this earlier in the week and forgot! Nope I ran out of time so left as is for now i.e. a site with the .aspx extension present instead of SEO Friendly url's

    I needed to revert the app pool back to version 2 to get it working, will not have it with version 4 which caused the problems

    Simon

  • Siw Ørnhaug 130 posts 109 karma points
    Dec 17, 2010 @ 16:45
    Siw Ørnhaug
    0

    Suddenly it works! There was a crash on the server and when everything was copied back it looked the same in umbraco until I had set all permissions over again. Don't know what I did differently this time, after all Umbraco pronounced all settings perfect during the upgrade. But somehow something got the right permissions this time.

  • Thomas Kahn 602 posts 506 karma points
    Jan 11, 2013 @ 14:55
    Thomas Kahn
    0

    I'm experiencing this problem as well!

    The problems started after I added some folder paths to umbracoReservedUrls in web.config. This is how it looks in my web.config (the last four entries are my custom folders - the ones that I want to exclude from umbracos URL rewriting):

    <add key="umbracoReservedUrls" value="~/config/splashes/booting.aspx,~/install/default.aspx,~/config/splashes/noNodes.aspx,~/VSEnterpriseHelper.axd,~/citrix/,~/filer/,~/mobisir/,~/pendelnet/" />

    I have tried lots of different ways to add these four folders to the web.config. Initially I added them to the key umbracoReservedPaths, but someone somewhere on the forum said it should be in umbracoReservedUrls.

    Before I did this modification everything was working perfectly. Frontend worked like it should and the backend had its stylesheet and so on. After this modification the frontend still works like it should but the backend looks just like the screenshot posted in the first message in this thread.

    Please help me sort out this problem!

    /Thomas

  • Thomas Kahn 602 posts 506 karma points
    Jan 11, 2013 @ 17:19
    Thomas Kahn
    0

    I solved the problem but I'm not 100% sure what was wrong.

    My solution was to download a fresh copy of Umbraco and get an untouched copy of the web.config file. Then I copied everything in the <appSettings> tag from the old web.config to the fresh copy. Then I uploaded the new web.config to the server and after that it worked like a charm. I think what happened was that when using the ISP's settings control panel, it changed some settings in the web.config as well which "broke" Umbraco.

    As soon as I get my code compare tool working properly I will take a look at the old and the new web.config to see what's different and what could be causing this error.

Please Sign in or register to post replies

Write your reply to:

Draft