Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Shannon 148 posts 171 karma points
    Jun 05, 2011 @ 19:43
    Shannon
    0

    No Document exists with Version 'f8617055-bb1a-4ea5-b1dc-695171b5c3c8'

    Cleaning up versions from Umbraco and I get this error message

    At 
    /umbraco/FALMHousekeeping/versions/cleanupVersionsByCount.aspx?action=cleanupversionsbycount
     
    (Referred by:
    http
    ://www.njection.com/umbraco/FALMHousekeeping/versions/cleanupVersionsByCount.aspx?action=cleanupversionsbycount):
     
    System.ArgumentException: No Document exists with Version
    'f8617055-bb1a-4ea5-b1dc-695171b5c3c8'
       at umbraco
    .cms.businesslogic.web.Document.setupNode()
       at umbraco
    .cms.businesslogic.web.Document..ctor(Int32 id)
       at
    FALMHousekeepingTools.versions.cleanupVersionsByCount.btnClearVersions_Click(Object
     sender
    , EventArgs e)
       at
    System.Web.UI.WebControls.Button.RaisePostBackEvent(String
    eventArgument
    )
       at
    System.Web.UI.Page.ProcessRequestMain(Boolean
    includeStagesBeforeAsyncPoint
    , Boolean includeStagesAfterAsyncPoint)
                                                           

     

    I tryed using the following solution but I couldn't find any nodes.

    kkurni.blogspot.com/.../...xists-with-version.html

     

  • Tom Fulton 2030 posts 4984 karma points c-trib
    Jun 06, 2011 @ 16:39
    Tom Fulton
    1

    Hi Shannon,

    I recently ran into a similar error message, the client tried to Rollback a document which produced an error, then you could no longer open the node (it produced the same error as above).  It appears it started creating a new version for the Rollback but never finished due to the error.

    Are you able to open the document?  You could try finding out what document it is by looking in the cmsContentVersion table for that versionId to grab the Node ID, then check the cmsDocument table for the nodeName.

    If you can't open the document in the backend UI and get the same error, the fix I used may work for you.  However I can't guarantee there won't be any side effects or if this is a proper fix, but it worked in my case.  Make sure you make a database backup first!  The fix is to delete the latest version which is "bad", which I got from this workitem.

    DELETE FROM cmsPreviewXml WHERE versionId='your-version-guid-here'
    DELETE FROM cmsContentVersion WHERE ContentID='node-id-here' and versionId='your-version-guid-here'

    Hope this helps,
    Tom

     

  • Ruald Gerber 20 posts 41 karma points
    Jul 13, 2011 @ 14:02
    Ruald Gerber
    0

    @Tom. Your solution worked for me. Thanks!

  • Ismail Mayat 4354 posts 9409 karma points MVP 2x admin c-trib
    Nov 27, 2012 @ 12:02
    Ismail Mayat
    0

    Tom,

    You just saved me a whole world of pain.

    Regards

    Ismail

  • John Perryn 70 posts 181 karma points
    Jan 15, 2013 @ 01:21
    John Perryn
    0

    Thanks Tom.

    Our site (V4.9.0) (backend only) died with a similar error following use of the ROLLBACK option in the content tree. Our non-techincal editor had a meltdown!

    I had to copy the databaase to a local machine to edit as per your advice, then reload it back at the service provider. Worked 100% and only took minutes.

    All the best

    John P

Please Sign in or register to post replies

Write your reply to:

Draft