Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • bradley 13 posts 33 karma points
    Oct 11, 2011 @ 15:06
    bradley
    0

    Content tree in admin section

    Hi

     

    The issue is that the Content tree is missing in the CMS for anyone other than an Admin user.  There are 2 environments that we are concerned with.

     

    1. Staging

    2. Live

     

    During our last major release of new functionality on the site, the entire structure of the web project from the staging environment was used to overwrite the live environment except for config files (web.config, umbraco.config, umbracoSettings.config) and Media directory.  This did include the App_Data folder too.... and I suspect that somewhere in here is where the problem lies.

     

    From that moment on, all other Users (other than the Admin User) is unable to see the contents tree (prior to this update everything was fine).

     

    In many posts in the forums, I have seen a lot of reference to permissions on the file system.  I have tried going as far as setting Full Permissions to the Everyone and still this has not solved the problem.

     

    This is the error message that I get in umbracoLog table.

     

    At /umbraco/webservices/TreeDataService.ashx?rnd=81c3cfeefcca460f84aa8216482d85c0&id=-1&treeType=content&contextMenu=true&isDialog=false&rnd2=21.8 

    (Referred by: http://duplomir.ru/umbraco/umbraco.aspx): System.Data.SqlClient.SqlException (0x80131904): Invalid object name 'UCUserSettings'.     

    at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection)     

    at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning()     

    at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj)     

    at System.Data.SqlClient.SqlDataReader.ConsumeMetaData()     at System.Data.SqlClient.SqlDataReader.get_MetaData()     

    at System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString)     

    at System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async)     

    at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, DbAsyncResult result)     

    at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method)     

    at System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior behavior, String method)     at System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior behavior)     

    at Microsoft.ApplicationBlocks.Data.SqlHelper.ExecuteReader(String connectionString, CommandType commandType, String commandText, SqlParameter[] commandParameters)     

    at umbraco.DataLayer.SqlHelpers.SqlServer.SqlServerHelper.ExecuteReader(String commandText, SqlParameter[] parameters)     

    at umbraco.DataLayer.SqlHelper`1.ExecuteReader(String commandText, IParameter[] parameters)

     

    Any pointers in the right direction would be most appreciated.

     

    Regards

    Bradley

  • DetonatorB 17 posts 40 karma points
    Oct 11, 2011 @ 15:18
    DetonatorB
    0

    Nope, it's a reported database error.

    Apparently, an item (table or stored procedure or such) named UCUserSettings cannot be found.

    After looking at the 4.7.1 db schema, I see no such object.

    Is that some customization?

  • bradley 13 posts 33 karma points
    Oct 11, 2011 @ 15:39
    bradley
    0

    Thanks for the reply.

    Nope, it is not a customisation.  That's the thing, i have no idea where that is coming from.  I am confused as to what would have caused this.  The only database changes were changes that were made to custom tables that we have, nothing to do with Umbraco...

    Confused...

  • DetonatorB 17 posts 40 karma points
    Oct 11, 2011 @ 16:09
    DetonatorB
    2

    Ah. the plot thickens.
    I can't find it in the umb src either.

    It seems that it happens while requesting for tree data (content tree).

    And I suspect it is part of Courier, considering the prefix.

    Is your Courier installation identical? (bin + web.config)

     

  • bradley 13 posts 33 karma points
    Oct 11, 2011 @ 16:45
    bradley
    0

    Aha, thanks for pointing me in the direction of Courier.  I am going to investigate the differences between the environments in this regard.  Will report back.

  • DetonatorB 17 posts 40 karma points
    Oct 11, 2011 @ 16:56
    DetonatorB
    0

    You're welcome buddy.

  • Owen Blacker 10 posts 72 karma points
    Dec 13, 2012 @ 18:29
    Owen Blacker
    2

    Definitely thank you for mentioning Courier.

    I've spend a chunk of this afternoon trying to see if some mysteriously-disappeared content nodes are in old database backups and I just got this error.

    It turned out the backup I was looking at was before Courier was installed. I added Courier back to it and the Content tree is magically not empty again.

    Thank you very much!

  • DetonatorB 17 posts 40 karma points
    Dec 14, 2012 @ 00:08
    DetonatorB
    1

    Thanks for the feedback Owen.

    You may be helping others.

  • Premkumar 5 posts 75 karma points
    Oct 19, 2015 @ 13:08
    Premkumar
    0

    Awesome.. That helped me today..

  • Nadine Fisch 148 posts 394 karma points
    1 week ago
    Nadine Fisch
    0

    Hi, we have the same difficulties here. I've tried to install Courier, but the installation wasn't succesful (I think this is becausing of missin write permissions). I removed the courier package, but now I can't add new nodes because of this error.

    I don't understand how to fix it.

Please Sign in or register to post replies

Write your reply to:

Draft