Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Fengelz 106 posts 221 karma points
    Oct 31, 2011 @ 12:42
    Fengelz
    0

    IIS 6 and 404 problem.

    I usually run into problems integrating 404 pages in umbraco. And once more I can't seem to figure out what I'm doing wrong.

    I have an umbraco 4.7 running on IIS 6.

    I have inserted my 404 nodeId in the umbracoSettings.config like so:

    <errors><error404>6196</error404></errors>

    But still I get the standard server error from IIS: 

    Server Error

    404 - File or directory not found.

    The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

    Can anybody enlighten me on what I need to do? 

    I prefer to use umbracos built-in handling but I'm open to other suggestions though I have tried to implement my own custom handler.

    Hope someone can help.

    Best regards 

    - Sune

  • Rodion Novoselov 694 posts 859 karma points
    Oct 31, 2011 @ 18:10
    Rodion Novoselov
    0

    Hi. Is it really IIS 6? This standard error page looks more like IIS7. And also, do all other pages work ok?

  • Jan Skovgaard 11257 posts 23497 karma points MVP 7x admin c-trib
    Oct 31, 2011 @ 18:40
    Jan Skovgaard
    0

    Hi Fengelz

    Have you recycled the app pool after setting up the id of the intended 404 page?

    /Jan

  • Fengelz 106 posts 221 karma points
    Oct 31, 2011 @ 18:58
    Fengelz
    0

    @Rodion I'm pretty certain it is IIS6 (Thats what it told me under help->about in the IIS Manager)

    @Jan I haven't tried that. I'll see if I get a chance to test it tomorrow.

    Thanks for your replies

    - Sune

  • Fengelz 106 posts 221 karma points
    Nov 02, 2011 @ 10:48
    Fengelz
    0

    Tried to recycle the app pool, unfortunately to no change.

    I found a .NET solution to the current problem so I'm over the hump for now. Would be nice to know how to handle this problem in the future though :/

    - Sune

  • Jan Skovgaard 11257 posts 23497 karma points MVP 7x admin c-trib
    Nov 02, 2011 @ 18:52
    Jan Skovgaard
    0

    Hi Fengelz

    Do you mind sharing your solution? Others might benefit from your approach if they have the same issues as you did :)

    /Jan

  • Fengelz 106 posts 221 karma points
    Nov 03, 2011 @ 09:10
    Fengelz
    1

    Sure. Heres a gist: https://gist.github.com/1336018

    I got the class snippet from a colleague, and it may require a bit of modifying to scale to other solutions. 

    I would still prefer to use umbracos native way, but I seem to always run into trouble when I try to implement it, probably due to settings in either the solution or in IIS.

    - Sune

  • Jan Skovgaard 11257 posts 23497 karma points MVP 7x admin c-trib
    Nov 03, 2011 @ 09:24
    Jan Skovgaard
    0

    Hi Sune

    That's great :)

    I also just came accross this entry on the wiki: http://our.umbraco.org/wiki/how-tos/how-to-implement-your-own-404-handler

    /Jan

  • Fengelz 106 posts 221 karma points
    Nov 03, 2011 @ 09:30
    Fengelz
    0

    Yeah. I tried that as well, but couldn't get it working, which led me to the conclusion that it is some basic server setting that messes with me :).

    But I'm working on another solution with the similar problem. I'll be sure to update this thread if I come across the solution.

     

    - Sune

  • Dirk Seefeld 122 posts 633 karma points
    Aug 04, 2014 @ 16:18
    Dirk Seefeld
    0

    The last response to this is long a go, but for every one how is using IIS 6 here is the server setting that solved the issue for me.

    In web.config add the following line to <system.webServer> section:

        <httpErrors existingResponse="PassThrough" />

    Be sure <httpErrors> is not already defined, otherwise you get an error.

    For IIS 7 or newer this setting is not necessary, but it will not break your solution when you move the application to such a machine, thus it is save to add the line.

    Yours
    Dirk

     

  • Niels Lynggaard 180 posts 517 karma points
    May 06, 2015 @ 09:56
    Niels Lynggaard
    0

    I had a similar problem with a new website on Umbraco 7. The Prod-server was somehow configured to use IIS errors, so I found a solution by setting trySkipIisCustomErrors="true" web.config under web.routing

    <web.routing
        trySkipIisCustomErrors="true"
        internalRedirectPreservesTemplate="false">
      </web.routing>

    Cheers,

    Niels

Please Sign in or register to post replies

Write your reply to:

Draft