Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Thomas Vestergaard 52 posts 138 karma points
    Dec 22, 2011 @ 22:56
    Thomas Vestergaard
    0

    Best way to upload larger media files

    Hey everybody

    What's the best way to upload larger video files to the media library? And by larger files, I meen in the ~50mb area. I tried using the desktop uploader but it wont accept .mp4 files.

    I'm not limited to the media library. A seperate uploader could be made, but it would fit more nicely into the umbraco structure if the video files were in the media library.

    Any experience you would like to share?

  • Jan Skovgaard 11244 posts 23437 karma points MVP 6x admin c-trib
    Dec 22, 2011 @ 23:26
    Jan Skovgaard
    0

    Hi Thomas

    The DMU does in fact allow you to upload .mp4 files. However it seems like 2 things need to be in order before it will accept them.

    1) The video/mp4 mimetype must be set in the web.config
    2) The <httpRuntime maxRequestLength="524288" executionTimeout="3600" /> must of course be set to a number a little higher than the size of the file you're trying to upload.

    This should to the trick for you.

    However you might need to be aware of one more thing since I vaguely recall reading something about you may also need to increase the allowed file-size in another config file somewhere if files are bigger than 60MB before the DMU accepts it. But not 100% sure on that.

    Hope this helps.

    /Jan

  • Thomas Vestergaard 52 posts 138 karma points
    Dec 23, 2011 @ 09:16
    Thomas Vestergaard
    0

    Hi Jan

    Thanks for the rapid reply. I'll dig into this tonight.
    I'll let you know how it turns out.

    Best
    /Thomas

  • Sören Deger 726 posts 2827 karma points c-trib
    Dec 23, 2011 @ 09:28
    Sören Deger
    2

    Hi Jan,

    there are another posibility, too:

    You can upload the files via FTP and install the "Import Media"-package (http://our.umbraco.org/projects/backoffice-extensions/import-media). With this package you can integrate the files easily to the media section.

     

    Sören

  • Jan Skovgaard 11244 posts 23437 karma points MVP 6x admin c-trib
    Dec 23, 2011 @ 09:41
    Jan Skovgaard
    0

    Hi Sören

    Yes this is indeed also an option. However if the DMU can handle the job I think it's the most efficient of the two methods imho :)

    /Jan

  • Thomas Vestergaard 52 posts 138 karma points
    Dec 23, 2011 @ 16:06
    Thomas Vestergaard
    0

    I would have loved to use the DMU, but I cannot make it work.

    The package Sören sugested, did the trick for me :)

    Thanks!

  • Jan Skovgaard 11244 posts 23437 karma points MVP 6x admin c-trib
    Dec 23, 2011 @ 16:10
    Jan Skovgaard
    0

    Hi Thomas

    Ok, well as long as you're able to move forward :)

    /Jan

  • Jacob 41 posts 90 karma points
    Jan 22, 2014 @ 19:43
    Jacob
    0

    I'm unable to upload any videos to the Media section of my Umbraco backoffice whatsoever.

     

    I added the following mimeMaps to the staticContent section of my webconfig to no avail:

          <mimeMap fileExtension=".mp4" mimeType="video/mp4" />

          <mimeMap fileExtension=".m4v" mimeType="video/m4v" />

     

    Does the standard Upload DataType support video file uploads, or is the error related to the database table that should be storing the videos?  Regardless, I have videos I need to upload to my Umbraco solution.  I'd prefer to do this under a "Featured Videos" folder in my Media section.  What is the best course of action to accomplish this task?

  • Jan Skovgaard 11244 posts 23437 karma points MVP 6x admin c-trib
    Jan 22, 2014 @ 19:57
    Jan Skovgaard
    0

    Hi Jacob

    What version of Umbraco are you using?

    And do you get any error messages when trying to upload?

    Perhaps you need to increase the the amount of bytes that can be uploaded in the web.config on the following line

    <httpRuntimemaxRequestLength="10096"executionTimeout="120"/>
  • Jacob 41 posts 90 karma points
    Jan 22, 2014 @ 20:06
    Jacob
    0

    Hi Jan.   Sorry for the lack of details; my brain is a bit fried from going through so much documentation and code today.

    I'm currently using Umbraco 7.  Also, I do receive an error message when attempting to upload a video to the Media section of my Umbraco solution.  Here is what I'm doing:

    1. Under my "Featured Videos" folder (located in the Media section of the backoffice) I'm trying to create a new File media type.  The File media type is using an Upload datatype as a property, which I'm using in attempts to upload an MP4 video (this is similar to how I was able to upload pictures).

    2. After browsing my machine for the desired MP4 video, I select the save button.

    3. Umbraco attempts to upload the video and I receive a vague error.

     

    The error states:

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

    Exception Details: 

    Stack Trace:

     

    Except there is no Stake Trace information listed.  Thanks for the recommendation.  What section of the web config should I include the code you suggested?

     

     

     

     

     

     

  • jake williamson 150 posts 632 karma points
    Sep 22, 2014 @ 18:00
    jake williamson
    0

    hi jan,

    don't suppose you ever got a solution to your issue?! i've hit the same problem today - the same empty error message...

    cheers,

    jake

  • Jacob 41 posts 90 karma points
    Sep 22, 2014 @ 18:14
    Jacob
    0

    The empty error message seems to be the result of a conflict between the web server framework (IIS for example) and the umbraco web-based IDE.  I was never able to get around this through Umbraco.  Instead I opted to use CDN services for the majority of my media and the umbraco CMS as a platform to enable configurability to the client.

  • Sandor 13 posts 36 karma points
    Jan 07, 2015 @ 10:52
    Sandor
    0

    Hi,

    Anyone found a solution for this? Is the cause of this issue known yet? I have increased both attributes in the web.config regarding the max upload size but to no avail. My image of 30 Mb results in the aforementonioned blank error message.

    Weird thing is that I do get a preview of the image in the ImageCropper property. It's only on save that the error occurs.

    btw: Umbraco 7

    Sandor

  • Jan Skovgaard 11244 posts 23437 karma points MVP 6x admin c-trib
    Jan 07, 2015 @ 10:57
    Jan Skovgaard
    0

    Hi Sandor

    Could you show us what your configuration looks like now?

    Maybe you have not increased the amount enough.

    /Jan

  • Sandor 13 posts 36 karma points
    Jan 07, 2015 @ 12:28
    Sandor
    0

    Hi Jan,

    Here you go

    <httpRuntime maxRequestLength="40720" executionTimeout="600" requestValidationMode="2.0" enableVersionHeader="false" targetFramework="4.5" />
    
    <security>
      <requestFiltering>
        <requestLimits maxAllowedContentLength="52428800" />
      </requestFiltering>
    </security>
    

    I believe it is more than enough.

    Sandor

  • Jan Skovgaard 11244 posts 23437 karma points MVP 6x admin c-trib
    Jan 07, 2015 @ 12:39
    Jan Skovgaard
    0

    Hi Sandor

    Ok, you need to set the maxRequestLength to a higher number. And also I think you should set the executionTimeout higher.

    Please try this - It sets the max to around 500MB like youe have in the requestLimits and set the timeout to 30 min.

    <httpRuntime maxRequestLength="52428800" executionTimeout="1800" requestValidationMode="2.0" enableVersionHeader="false" targetFramework="4.5" />
    

    Hope this helps.

    /Jan

  • Syed Rizvi 3 posts 72 karma points
    Sep 08, 2015 @ 01:27
    Syed Rizvi
    0

    Which section of the web config do I need to paste this line?

  • Sandor 13 posts 36 karma points
    Jan 07, 2015 @ 18:07
    Sandor
    1

    Hi Jan,

    I had to add the following as well to make it work:

    1. Add this to the web.config:

    1. Run c:\windows\system32\inetsrv\appcmd set config "My-Website" -section:system.web -requestLimits.maxRequestLength:104857600 -commitpath:apphost in the CMD.exe. Apparently there is another default max size of 30 Mb set in IIS.

    Besides that we noticed a different error when uploading larger files when umbracoUseSSL was set to true.

  • Syed Rizvi 3 posts 72 karma points
    Sep 08, 2015 @ 01:23
    Syed Rizvi
    0

    So which section of the web config I need to paste the following line?

Please Sign in or register to post replies

Write your reply to:

Draft