Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Nico Lubbers 151 posts 172 karma points
    Oct 20, 2009 @ 20:36
    Nico Lubbers
    2

    ouch... forgot admin password. how to reset?

    I have a umbraco 4.0.2.1 installation with some work done already but I supidly forgot the password of the only user... admin :-(

    In the umbracoUser table the password is hashed and clearing it does not help.

    How can I reset the password to "default"

  • Chris Larson 48 posts 62 karma points
    Oct 20, 2009 @ 20:48
    Chris Larson
    5

    If you have access to the SQL Server, the following SQL statement should work.

    UPDATE umbracoUser set userdisabled=0, userLogin='admin', userPassword='d9xnUXsUah9gycu7D0TpRYcx19c=' where id=0
  • Nico Lubbers 151 posts 172 karma points
    Oct 20, 2009 @ 20:50
    Nico Lubbers
    5

    nevermind... I found the solution

    changed the password of another installation to the password: default

    then looked in the umbracoUser table. The hash for that is: bnWxWyFdCueCcKrqniYK9iAS+7E=

    Now updated the umbracoUser table with that hash.... and I can login again :-)

  • Nico Lubbers 151 posts 172 karma points
    Oct 20, 2009 @ 20:52
    Nico Lubbers
    0

    Ah Chris,

    I did not see your reply when I posted this :-)    Another hash value in your script.... thats odd.....

    Thanx

     

  • Nico Lubbers 151 posts 172 karma points
    Oct 20, 2009 @ 20:57
    Nico Lubbers
    0

    Chris, Somehow your script is not for the password default is it?

  • Chris Larson 48 posts 62 karma points
    Oct 26, 2009 @ 15:22
    Chris Larson
    3

    Whoops.... Try this one instead. I pulled the value from a production system rather than my default DB version.

    UPDATE umbracoUser set userdisabled=0, userLogin='admin', userPassword='rboj46J1NSyvbZ5c7UI/5+m+Pcc=' where id=0
  • Francisco Caicedo 1 post 21 karma points
    Jul 10, 2015 @ 23:49
    Francisco Caicedo
    0

    Awesome, It worked.

  • Donald Burgess 9 posts 29 karma points
    Oct 29, 2009 @ 05:09
    Donald Burgess
    0

    Hello Chris

    I tried your solution and is updated the table in SQL Server, but still will not enable me to loginto umbraco as admin. Am I right in assuming the decrypted password is 'default'

     

    Thanks

    Don

  • Donald Burgess 9 posts 29 karma points
    Oct 29, 2009 @ 06:14
    Donald Burgess
    0

    hello Chris

    I have a it working now

    Thanks

    Don

  • nigel 6 posts 26 karma points
    Nov 02, 2009 @ 16:21
    nigel
    0

    Hi

    Just installed 4.0.2.1  (the version using Cassini and VistaDB) and cannot login as admin.

    I have changed the password for admin in the VistaDB database to all the variations suggested above to no effect

    bnWxWyFdCueCcKrqniYK9iAS+7E=

    d9xnUXsUah9gycu7D0TpRYcx19c=

    rboj46J1NSyvbZ5c7UI/5+m+Pcc=

    really a bit stuck ... appreciate any ideas


     

  • nigel 6 posts 26 karma points
    Nov 02, 2009 @ 17:44
    nigel
    0

    To add to my previous post,

    I have uninstalled and re-installed Umbraco, using the embedded VistaDB.

    I changed the admin password when prompted during the install, making absolutely sure I had an accurate note of the password (which was a weak one).

    I still cannot login as admin and see anything of the admin goodies although the runway website itself works.

    When I try to login in

    a) If I enter the correct password both the username and password field are cleared

    b) If I enter an incorrect password, only the password field is cleared

    This makes me think that the login  was successful when a correct password is entered but something is going wrong beyond that.

    Also, is there a more obvious way of logging in as admin than - http://localhost:4522/umbraco/umbraco.aspx?

    SO frustrating, there is clearly something good waiting here beyod the security cordon!

  • Stephan Lonntorp 195 posts 212 karma points
    Nov 02, 2009 @ 18:39
    Stephan Lonntorp
    0

    make sure your permission settings are correct!

  • nigel 6 posts 26 karma points
    Nov 03, 2009 @ 05:00
    nigel
    0

    At the stage during the install when the 'permissions' are checked I got a message indicating that all permsission settings were ok.

    So, not really sure what to look for; can anyone give a pointer on this?

     

     

  • Nico Lubbers 151 posts 172 karma points
    Nov 03, 2009 @ 23:55
    Nico Lubbers
    6

    Richard Soeteman had this tip during the umbraco benelux meetup:

    Change the admin-password to clear-text in sql by using the following sql-script:

     

    UPDATE umbracoUser set userdisabled=0, userLogin='admin', userPassword='default' where id=0

    Now search in the web.config the UsersMembershipProvider and change the

    passwordFormat="Hashed"
    into Clear:
    passwordFormat="Clear"

    Now you should be able to login with admin / default

    If that works, revert the change in the web.config and save the web.config. Now change the admin password by using the umbraco-client (users/administrator/reset password)

    Check the database to see that the password is hashed again...

    Nico

  • Squazz 35 posts 111 karma points
    Sep 29, 2015 @ 11:04
    Squazz
    0

    What could one do when not even this approach works?

  • Carlos Mosqueda 132 posts 209 karma points
    Sep 29, 2015 @ 14:58
    Carlos Mosqueda
    0

    @Squazz,

    We ran into a similar problem.

    What I ended up doing was:

    FIRST, to go to the web.config and changing the value from "Hashed" to "Clear".

    THEN we went into the user table in the DB, we did not do the SQL script, we just went directly to the field in the 'umbracoUser' table and updated the password field directly, changed the value to something other than 'default' or whatever is in there now. I just made it "password123" temporarily. Remember to execute the SQL to save the new value. You might want to see what your userLogin for admin was too. I have forgotten the admin user login too. Usually it is the email address you typed in when you set up the website, but if you changed that along the way use the username that is the admin user name.

    THEN go to your Umbraco website, login with your admin username and the new updated password, you should then be able to log in.

    Stay logged into the Umbraco Backoffice.

    THEN go back to the web.config, change the value BACK to 'Hashed'.

    THEN go to back to your browser and the admin user account in Umbraco Backoffice (you are still logged in right?), and change the password.

    This will rehash the new password and update the temporary one you updated in the DB table to your now new password.

    Make sense? Let us know if this does not even work.

  • Squazz 35 posts 111 karma points
    Sep 30, 2015 @ 08:03
    Squazz
    0

    Trying to do what you are writing here I can't even log in when setting the value to "Clear" and changing the password to something simple as password123.

    When hitting the "login" button I get a error 400, and looking at the headers it doesn't seem as if my request is getting to the database. It is rejected up front as a "bad request"

  • Squazz 35 posts 111 karma points
    Sep 30, 2015 @ 08:12
    Squazz
    0

    Update: This is freakishly random.

    Same setup as yesterday where nothing worked. Before I closed everything and went home, I rebooted the computer, refreshed all caches and temp files, rebooted again, and still: nothing. I couldn't get login to work in any way.

    Then today, I boot up the computer, try to login (with everything as it was yesterday), and now I can login.

    I don't know what the problem is, but I know that the Umbraco team stands firm in the opinion that there's nothing wrong with Umbraco and that it's something local. With all the cases that I have read about, and seeing my own case, I choose to oppose.

  • Markus Johansson 1528 posts 4279 karma points
    Apr 28, 2010 @ 17:10
    Markus Johansson
    0

    Or just clear the "userPassword" field in the database, login with no password and change to the new password.

  • Markus Johansson 1528 posts 4279 karma points
    Apr 28, 2010 @ 17:18
    Markus Johansson
    2

    Just adding some steps if you dont what to change beetween clear and hashed:

    1. Open user-table in SQL Server Management Studio and clear the userPassword-filed.
    2. Login to you umbraco-backend using the "username" and a empyt password textbox.
    3. Click the users-tab and add a user, remember the password.
    4. Go back to Management studio and copy the password from the new user to your old account.

  • Brad 13 posts 34 karma points
    Apr 29, 2010 @ 17:22
    Brad
    0

    I didn't have any luck pasting in the hash values above.  What did work for me was the following:

    Open the Users table and delete the password value.

    Login to Umbraco with a blank password.

    Now.. the tricky part.  With the password blank in the database, the User editor will not display the change password form.

    Go back in the Users table (while still logged in) and put some text in the password field.  I used the number 1.

    Open the admin user and reset the password to something new.... presumably that you will remember this time.  ; )

  • Markus Johansson 1528 posts 4279 karma points
    May 04, 2010 @ 22:24
    Markus Johansson
    0

    @Brad

    My solution was simular, I added a new administrator - logged in as that person and changed the password for the "root"-administrator.

    / M

  • mfeola 117 posts 221 karma points
    Oct 26, 2010 @ 00:44
    mfeola
    0

    i cant seem to get this to work in umbraco 4.  has something changed?  I migrated content over from one server to another and now i can't login with my original username and password and deleting the field has not helped

  • Dincer M. 35 posts 96 karma points
    Feb 21, 2011 @ 04:22
    Dincer M.
    0

    Got the similar problem about passwords, correcting the permissions solved it.. Thanks Stephan Kvart  :)

  • Pinal Bhatt 298 posts 389 karma points
    Sep 22, 2011 @ 15:55
    Pinal Bhatt
    1

    bnWxWyFdCueCcKrqniYK9iAS+7E=    worked for me, this set my password to 'default'

  • Biagio Paruolo 1435 posts 1552 karma points
    May 11, 2017 @ 14:07
    Biagio Paruolo
    0

    This works. UPDATE umbracoUser set userdisabled=0, userPassword='bnWxWyFdCueCcKrqniYK9iAS+7E=' where id=0

  • Roman Petrenko 20 posts 39 karma points
    Apr 04, 2012 @ 20:55
    Roman Petrenko
    0

    Hi

    How can I reset or retrieve admin password for umbraco 5.1 . There is no umbracoUser table or anything like that. any ideas?

     
  • Debbie Lawrenson 55 posts 75 karma points
    Jun 12, 2013 @ 20:53
    Debbie Lawrenson
    0

    I have also tried this to no avail. Can I ask how you fixed it please?

  • David Dimmer 76 posts 134 karma points
    Aug 29, 2013 @ 19:45
    David Dimmer
    0

    Which web browser are you using? With Umbraco 4.7.1.1 we had an issue where IE on SQL Server 2008r2 would not allow us to login. Chrome worked fine.

    -David Fyin.com

  • charles fenoughty 1 post 21 karma points
    Feb 12, 2014 @ 16:53
    charles fenoughty
    0

    Thanks for the help all, the one that worked for me was changing the password in user table to bnWxWyFdCueCcKrqniYK9iAS+7E=

    This hash was the "default"

    Umbraco 6.1.1

  • Heather Floyd 439 posts 521 karma points c-trib
    May 20, 2014 @ 17:47
    Heather Floyd
    0

    Does anyone know if the hashing or something has changed for umbraco v.6.1.6? "bnWxWyFdCueCcKrqniYK9iAS+7E=" isn't working for "default"...

  • Ayo Adesina 357 posts 899 karma points
    Jun 08, 2014 @ 16:37
    Ayo Adesina
    0

    I'm using umbraco 7 and I have tried everythingh here... no joy, I'm almost thinking of starting the whole project from scratch

    this is a really bad bug... killing time for something that should be easy to fix.

  • CH 5 posts 70 karma points
    Jun 11, 2014 @ 17:36
    CH
    0

    i was able to reset the admin pass with the Clear format attribute in web.config under Umbraco 7.1.4

     

  • Carlos Mosqueda 132 posts 209 karma points
    Jul 12, 2014 @ 06:03
    Carlos Mosqueda
    0
  • Laura DiPiazza 13 posts 33 karma points
    Jul 14, 2014 @ 22:41
    Laura DiPiazza
    0

    I am using umbraco 6.1.5 and having the same unsuccessful login issue. I can't seem to login to the backoffice via the admin credentials. I tried resetting the password via the db to no luck.
    After further research this seems to be only occurring now in my development environment. My stage environment is working if you login using ssl.

    I created a copy of the stage database and restored it to my development server. I pointed the webconfig to the new database and also copied over the umbraco.config file locally as well. I am still not successful logging in. My development server does not have SSL. Any tips would be greatly appreciated!

  • rob 75 posts 170 karma points
    Aug 07, 2014 @ 10:53
    rob
    1

    Just had to battle this issue and it turned out that the admin record had userNoConsole set to 1.

    So the fix was to reset this along with the password

    UPDATE umbracoUser set userNoConsole=0, userdisabled=0, userLogin='admin', userPassword='bnWxWyFdCueCcKrqniYK9iAS+7E=' where id=0;
    

    The weird thing is, as far as I can tell only the Admin account has access to the Admin account settings to make that fatal change.

  • c0deguy 2 posts 22 karma points
    Jan 21, 2015 @ 21:41
    c0deguy
    0

    thanks rob...

    that worked for me.

  • Marcus J. Maunula 196 posts 331 karma points
    Jan 28, 2015 @ 18:22
    Marcus J. Maunula
    0

    I have seem to have a problem with using the "Clear" trick on the latest 7.2.1. When setting back to hashed after reset it does not work again.

    Any new updates that changed the password reset tricks?

    Thanks in advance

  • Dennis Aaen 4394 posts 17768 karma points admin hq c-trib
    Jan 28, 2015 @ 19:31
    Dennis Aaen
    2

    Hi Marcus,

    If you have acces to the database then you can try this approach.

    1: Find the user table in database. Change th string in the password column to bnWxWyFdCueCcKrqniYK9iAS+7E=

    This string bnWxWyFdCueCcKrqniYK9iAS+7E= is the hashed value for the password "default".

    When you have done that you should be able to login with your username and in the password field you type default.

    2: After you´re logged into the Umbraco office go the users section and change your password, to the password that you want.

    If you want an SQL script you could execute this script on the database, and it should set the admin password to default

    UPDATE umbracoUser set userdisabled='False', userLogin='admin', userPassword='bnWxWyFdCueCcKrqniYK9iAS+7E='where id=0;

    Remember to change the userLogin if not not are logging with the admin user, the same for the id if you choose to use the SQL script. And be careful you are working with the database

    Hope this helps,

    /Dennis

  • Marcus J. Maunula 196 posts 331 karma points
    Jan 28, 2015 @ 22:00
    Marcus J. Maunula
    0

    Hi Dennis, I have tried that but it does not seem to work with 7.x anymore. Nor does the setting Password to Clear since it stops working as soon as I put it back to Hashed.

  • Dennis Aaen 4394 posts 17768 karma points admin hq c-trib
    Jan 28, 2015 @ 22:17
    Dennis Aaen
    1

    Hi Markus,

    What are the values for the user that you are trying to login with in the userDisabled column and userNoConsole, both should be set to False. See the screenshot below.

    Did you use the script or did you manually change the password value, in the column. If you used the script before perhaps it would been an idea to just change it directly in the column.

    Hope this helps,

    /Dennis

  • Marcus J. Maunula 196 posts 331 karma points
    Jan 28, 2015 @ 22:51
    Marcus J. Maunula
    0

    I used the UPDATE script and both are 0 (or false). Really strange. I also tried installing a fresh one and just copy the default but no go.

     

  • Marcus J. Maunula 196 posts 331 karma points
    Jan 28, 2015 @ 22:58
    Marcus J. Maunula
    0

    Could this affect?

     useLegacyEncoding="true" 

    I also get this (yes the user does exist)

    "Message":"An error has occurred.","ExceptionMessage":"The user 'admin' could not be found in the Umbraco database"

  • Brad Harder 6 posts 26 karma points
    Feb 04, 2015 @ 05:16
    Brad Harder
    0

    Hey. I found that I had the same issue. I managed to get the default password working as described above, but only after stopping and starting the App Pool for the site. When I logged in; changed the password; and then logged out, I found that the issue returned. Restarting the App Pool again seemed to solve the issue.

    Not sure that I like the idea of restarting the app pool everytime a password needs changing. Anyone have any other suggestions?

  • surya 1 post 71 karma points
    May 09, 2016 @ 18:58
    surya
    0

    Hi Brad, Thanks a lot, not sure for some reason my password stopped working, I spent 4 to 5 hours to find solution, I rebooted my server after creating new username and password in database,it did not work,strangely it worked only after Apppool restart :)

  • Rhychelle Walker 7 posts 27 karma points
    Mar 17, 2015 @ 15:13
    Rhychelle Walker
    0

    hi there, how can i find out the user details for our cms' admin account, we only have writer and editor accoutns set up and are constantly told by our IT that those are the admin (or developer as they call it) accesses.  this cannot be the case as i cannot see any advanced options such as user tables etc.

    any helpw ould be greatly appareciated, the site has been hadnballed from person to person and no one has any info at all.

  • Jan Skovgaard 11152 posts 22857 karma points MVP 5x admin c-trib
    Mar 17, 2015 @ 15:27
    Jan Skovgaard
    1

    Hi Rhycelle and welcome to our :)

    The definition of an administrator account can vary depending on the people using Umbraco.

    When an Umbraco installation is setup there is a master administrator account created during installation - When a company or a developer is setting up a solution for another company usually there are created an "Administrator" account, which has limited access - So the admin is able to see "Content", "Media", "Users", "Translation", and "Members". And then usually there can be "Editor" and "Writer" accounts. The developers administrator account has access to all the sections, which includes "Developer" and "Settings".

    In order to be able to fetch the account you're looking for you'll need to have access tot the database and look in the users table.

    But I'm wondering if you could get in touch with the agency that developed the site instead and get the information from them?

    Looking forward to hearing from you.

    /Jan

  • Rhychelle Walker 7 posts 27 karma points
    Mar 18, 2015 @ 14:17
    Rhychelle Walker
    0

    thanks Jan, appreciate the quick response.  i was able to find the orignal developer's admin logins however i cannot seem to find anywhere to get to the database or do any other things i needed (like macro changes). i'm thinking i may need to rebuild the form macro for that page all together. thanks again, will continue researching the forums.

  • Bipin Kataria 25 posts 50 karma points
    Jun 14, 2015 @ 20:44
    Bipin Kataria
    2

    Guys,

    All these settings works just fine. You might be unable to see the changes in system after updating database table. This is because sometime Umbraco cache the users in cache with old information. So, after making all the DB changes, recycle AppPool or just add one space in web.config and save it (this will also do APR). And after that refresh the page and try with the password. I figure out this after spending 1-2 hours. :)

    admin => d9xnUXsUah9gycu7D0TpRYcx19c=

    default => bnWxWyFdCueCcKrqniYK9iAS+7E=

    Thanks, Bipin

  • adarsh 46 posts 66 karma points
    Sep 04, 2015 @ 11:03
    adarsh
    0

    Thanks Bipin, your message helped us.

    cheers! Adarsh

  • Cesar Scur 2 posts 73 karma points
    Jan 14, 2016 @ 14:00
    Cesar Scur
    1

    I've had this problem also, after upgrading for 7.3 and running a security check. My user account got locket and I've used the update umbracoUser method to try solving. Same 400 response.

    However I discovered that there is some sort of cache for the authentication, so after updating the table I had to clean the App_Data folder.

    I'm not sure why or how umbraco works exactly but this procedure solved my issue.

  • Jakub 1 post 71 karma points
    Feb 04, 2016 @ 14:15
    Jakub
    0

    It works... :/

  • Will Chamberlin 2 posts 72 karma points
    Apr 12, 2016 @ 20:16
    Will Chamberlin
    0

    Had the same issue and clearing the app_data temp dir plus removing umbraco.config also allowed me to log in with the updated password.

  • denisedelbando 139 posts 336 karma points
    Apr 28, 2016 @ 17:52
    denisedelbando
    0

    not one works for me.

    Not restarting app_pool or the hashed version of default.

    What i did was I went to another umbraco site that i can still login, copied the hashed password of that one. once i updated the database, i changed it to my preferred password.

    For anyone who wants to know the hashed equivalent of "password" (without the double quotes) it is:

    /7IIcyNxAts3fvQYe2PI3d19cDU=

    then dont forget to change your password once you logged in.

  • Pradip 23 posts 115 karma points
    May 09, 2016 @ 05:20
    Pradip
    0

    Hello All,

    We can reset our Umbraco admin password by following the below steps :

    1 ) We need to generate new password using the below link :

    http://www.99bugs.com/i-lost-my-umbraco-admin-password-now-what/

    In the above function, we have set a new password "pass123".

    2 ) Now, we need to update the admin user password using a new hash password "1p6mM9EvHJU8Bv5fWcvBX9fTSvc=" using the below query :

    UPDATE umbracoUser set userdisabled=0, userLogin='admin', userPassword='1p6mM9EvHJU8Bv5fWcvBX9fTSvc=' where id=0

    That's it. Now we can login using new admin password "pass123".

    Thanks, Pradip

  • Dan Diplo 1393 posts 5211 karma points MVP 2x c-trib
    May 09, 2016 @ 19:10
    Dan Diplo
    1

    The easiest way by far (for Umbraco 7 at least) is to download https://our.umbraco.org/projects/developer-tools/umbraco-admin-reset/

    You just download the DLL, but in /bin/ folder and it resets the password and deletes itself. You can then login and change password.

  • Brad Harder 6 posts 26 karma points
    May 11, 2016 @ 05:04
    Brad Harder
    0

    Yeah. Started using this. far easier than messing with SQL

  • Niels Damkjær 1 post 71 karma points
    Sep 06, 2016 @ 08:47
    Niels Damkjær
    0

    Using UmbracoAdminReset.dll worked for me on Umbraco version 7.5.2

  • mathieuh 1 post 71 karma points
    Jul 13, 2017 @ 18:27
    mathieuh
    0

    Just make sure that allowManuallyChangingPassword="true" or else the username is changed but not the password.

  • Styrmir 7 posts 80 karma points
    May 10, 2016 @ 12:26
    Styrmir
    2

    After trying countless variations of the suggested above I found what worked for me:

    How to reset password:

    1. Generate hash password using a hash key generator such as http://www.99bugs.com/i-lost-my-umbraco-admin-password-now-what/ as suggested above, or use one of those suggested above.
    2. Copy hash key and paste output into umbracoUser.userPassword.
    3. Make sure umbracoUser.userNoConsole = False.
    4. Change one space or letter in site web.config, save, then start site (this change makes the application pool reset).

    The login entry form on the webpage uses the following:

    1. Login is umbracoUser.userLogin.
    2. Password is umbracoUser.userPassword (saved in hash form in db).
  • Josh Yates 6 posts 86 karma points
    Aug 02, 2016 @ 02:16
    Josh Yates
    0

    Very nice. Generated password and executed SQL UPDATE. That rextester UI would be great for Umbraco admin password reset. :-)

  • mcgrph 13 posts 103 karma points
    Mar 27, 2017 @ 19:37
    mcgrph
    0

    this was it! everything else didn't work for me, but umbracoUser.userNoConsole = false was the way to get access :)

  • Don Nehc 69 posts 222 karma points
    Jul 12, 2016 @ 01:29
    Don Nehc
    0

    Hello, is there a UI that allows users not only admins to reset password? Is there a forgotten password link? Something similar to WordPress does?

  • Dan Diplo 1393 posts 5211 karma points MVP 2x c-trib
    Jul 12, 2016 @ 08:36
    Dan Diplo
    0

    When a user is logged in they can click on the user avatar / umbraco icon (top left) to change their password.

  • Don Nehc 69 posts 222 karma points
    Jul 12, 2016 @ 14:34
    Don Nehc
    0

    That is assuming users know their password. In my case, I don't know the password, and I want to either reset or request a new temporary password. How do I accomplish that?

  • Pradip 23 posts 115 karma points
    Jul 13, 2016 @ 05:19
    Pradip
    0

    Umbraco is not providing any reset password functionality from a login page like Wordpress. Means only admin can reset the password using the above mentioned methods.

  • Jan Skovgaard 11152 posts 22857 karma points MVP 5x admin c-trib
    Jul 13, 2016 @ 05:22
    Jan Skovgaard
    0

    Luckily such feature will exists in future releases - Once Umbraco 7.5 is released there will be an option to reset the password - Just mentioning it for future reference.

    /Jan

  • Don Nehc 69 posts 222 karma points
    Jul 13, 2016 @ 12:38
    Don Nehc
    0

    That is great. Thank you.

  • Cristovao 12 posts 33 karma points
    Oct 26, 2017 @ 09:28
    Cristovao
    0

    This topic have some time now, but since no one has placed what I consider the best solution for resetting Umbraco back office password, I leave my opinion. I mean since Umbraco 7.3.xx I guess??

    Umbraco (> 7.3.x) has a recover password process already implemented. The only thing that you need to do is setup email SMTP settings on Umbraco web.config. Here is an example:

      <system.net>
    <mailSettings>
    <smtp from="yourmail@domain.com">
                <network host="smtp.domain.com" 
                 port="587" 
                 userName="yourmail@domain.com" 
                 password="yourpassword" 
                 enableSsl="true"/>
            </smtp>
    </mailSettings>
    

    With this on your web.config, you can use the recover password option on BackOffice login form. Umbraco will send a link to recover password. If you deploy Umbraco for your customer, this is the proper way to do it.

    Other possible option already mentioned here is this plugin to reset: https://our.umbraco.org/projects/developer-tools/umbraco-admin-reset/

  • blackhawk 313 posts 1364 karma points
    Nov 08, 2017 @ 17:45
    blackhawk
    0

    If you have Umbraco 7.6+, and tried all the given solutions on this post, you may be better off with getting the password reset process enabled through Umbraco locally.

    What worked in my case, was installing PAPERCUT.

    Then make sure your web.config within your Umbraco project has the appropriate mail settings to talk to PAPERCUT:

      <system.net>
        <mailSettings>
          <smtp deliveryMethod="Network" from="your-admin-email@some.location">
            <network host="127.0.0.1" port="25" />
          </smtp>
        </mailSettings>
      </system.net>
    

    ...You may have to also set that same admin email address in your umbracoSettings.confg like so:

    <notifications>
      <!-- the email that should be used as from mail when umbraco sends a notification -->
      <email>your-admin-email@some.location</email>
    </notifications>
    

    Finally, go to your log-in screen for BackOffice, and click the forgotten password link? and follow through.

    Hopefully this helps!

  • Colin O'Donoghue 1 post 71 karma points
    Feb 06, 2018 @ 10:36
    Colin O'Donoghue
    0

    I have tried all these options but nothing works.

    I am unsure what version of Umbraco the site uses as i am both new to the site and to Umbraco

    I do know that the web.config file has the machinecode tag in it with a custom decryption and validation key.

    Would this stop all the sql reset options from working as i am sure the hashing function uses this to hash the password doesn't it

    I do have complete access to code and database

    Thanks

  • Oriol 5 posts 77 karma points
    Apr 12, 2018 @ 13:46
    Oriol
    2

    Not sure if useful or not, but instead of using a remote smtp server which maybe you don't have access (I haven't at least) you can set a dump directory to store there the emails and just retrieve the reset password link:

    <mailSettings>
      <smtp deliveryMethod="SpecifiedPickupDirectory">
        <specifiedPickupDirectory pickupDirectoryLocation="C:\Email" />
      </smtp>
    </mailSettings>
    
  • mcgrph 13 posts 103 karma points
    Jul 10, 2018 @ 20:46
    mcgrph
    0

    After several attempts (and also trying the solution which was working for me the last time, see comment above), the solution of Oriol was the one which actually worked! Just had to modify the membership provider in web.config to the following:

    <membership defaultProvider="UmbracoMembershipProvider" userIsOnlineTimeWindow="15">
        <providers>
            <clear />
            <add name="UmbracoMembershipProvider" type="Umbraco.Web.Security.Providers.MembersMembershipProvider, Umbraco" minRequiredNonalphanumericCharacters="0" minRequiredPasswordLength="10" useLegacyEncoding="false" enablePasswordRetrieval="true" enablePasswordReset="true" requiresQuestionAndAnswer="false" defaultMemberTypeAlias="Member" passwordFormat="Clear" allowManuallyChangingPassword="false" />
            <add name="UsersMembershipProvider" type="Umbraco.Web.Security.Providers.UsersMembershipProvider, Umbraco" />
        </providers>
    </membership>
    

    and update the mailSettings as Oriol mentioned. Afterwards the link to reset password was working and created an .eml file (E-Mail) in the specified directory with a link to create a new password. Umbraco version is 7.11.1

Please Sign in or register to post replies

Write your reply to:

Draft