Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • cmm 20 posts 122 karma points
    May 14, 2014 @ 14:41
    cmm
    0

    after upgrade 6.2.0, can't edit Document type/generic properties

    Hello,

    After I upgraded to version 6.2.0, I'm no longer able to edit the the properties inside the "generic properties" tab of any document type, using the left mouse click. Seems like when I use the left mouse click the it automatically unfocus the element, the mouse cursor is not even there.

    The strange thing is, that the right mouse click works and I'm able to focus the textboxes of the properties..  but that's not acceptable for our users, we need to have it like it was before the upgrade, and is the standard in every textbox editing, you select the textbox with the left mouse click and it should focus the textbox. 

    I also noticed there's a new drag and drop feature to move the properties of the "generic properties" tab, could this be related ?

     

     

  • Jan Skovgaard 11258 posts 23500 karma points MVP 7x admin c-trib
    May 14, 2014 @ 15:31
    Jan Skovgaard
    0

    Hi Plim

    What version did you upgrade from? And how did you do the upgrade?

    Do you see any error messages in the browser console log if you run it at the same time you're clicking around?

    Have you checked the trace log at /app_data/logs to see if there are any entries marked with "ERROR" in there?

    Looking forward to hearing from you.

    Cheers, Jan

  • cmm 20 posts 122 karma points
    May 14, 2014 @ 15:47
    cmm
    0

    Hi Jan,

    Thanks for you feedback.

    I upgraded from version: 6.1.6

    I upgraded manually by extracting the following folders from UmbracoCms.6.2.0:

    Bin (overwrite)

    Umbraco (overwrite)

    Umbraco_cliente (overwrite)

    Install

    Config ( Merged the various configs)

    Web.config (Merged)

    Then the application use the install aspx and I installed via web. The app seems to be running without any major issues, this one being the exeption.

    The browser console log doesn't show any javascript errors.

    However I found this Warning in the /app_data/logs, but not sure if it's anything related:

    2014-05-14 14:42:31,844 [12] WARN  Umbraco.Web.UI.Umbraco.Umbraco - [Thread 26] A requested app:  was not found

    Do you know what's the javascript location that controls the focus of the properties textbox under "generic properties" tab ? 

     

    Thanks for your time

  • Jan Skovgaard 11258 posts 23500 karma points MVP 7x admin c-trib
    May 14, 2014 @ 15:56
    Jan Skovgaard
    0

    Hi plim

    Ok - the above steps seem fine.

    Could you try doing the following?

    1: Go to /app_data/TEMP/ClientDependency and delete all the files 2: Go to /config/ClientDependency.config and increment the version number 3: Recycle the app pool

    Does that help?

    I don't know the location of the Javascript but I don't think that it's the way to go if it's not a general bug imho.

    /Jan

  • cmm 20 posts 122 karma points
    May 14, 2014 @ 16:06
    cmm
    0

    Hi Jan,

    thank you for your feedback. The issue still remains, the textbox of the properties are not editable with the left mouse click.

    I even edited the web.config to restart the app, but no luck.

    Cheers!

  • Jan Skovgaard 11258 posts 23500 karma points MVP 7x admin c-trib
    May 14, 2014 @ 20:41
    Jan Skovgaard
    0

    Hi Plim

    Ok, last shot from me - Otherwise I have no clue...

    Try going to the /App_Data/TEMP folder and then delete all files from all the folders in there - perhaps you can even just delete all folders from this directory.

    Then try recycling the app pool once again - does that help?

    What browser and operating system are you using btw?

    /Jan

  • cmm 20 posts 122 karma points
    May 20, 2014 @ 16:36
    cmm
    0

    Hi Jan,

    Sorry for my late anwser, I just got back to try fixing this again.

    Deleting all the files in the folders of  /App_Data/TEMP did not solve the issue. (neither recyling the app pool)

    This is happening on two different systems. Windows 7 and Windows Server 2008 R2 Standard.

    I'm out of ideas.. I'm going to try using a fix from this article: http://weblogs.asp.net/jeffwids/archive/2011/01/31/jquery-textbox-in-sortable-is-not-clickable-selectable.aspx it seems to be related.. but this has nothing to do with umbraco.. more with Jquery.. hope this helps..

    Cheers

  • Rob 5 posts 55 karma points
    Jun 16, 2014 @ 15:18
    Rob
    0

    I have the same problem in Umbraco 6.2.1.
    You can't click on document type properties to edit them. Only with right click.
    I think this has something to do with the new drag & drop funcionality.
    Can this be reported as a bug? Or is there a solution that has not been posted in this topic?

  • Jan Skovgaard 11258 posts 23500 karma points MVP 7x admin c-trib
    Jun 20, 2014 @ 20:21
    Jan Skovgaard
    0

    Hi Rob

    You can always try to file a bug report indeed - but it's no guarantee that it will get fixed ASAP or anything. But if others are having the same issues then there might be a chance or perhaps someone makes a pull request that HQ can easily merge into the core for instance.

    /Jan

  • Jesper Olesen 1 post 24 karma points
    Aug 28, 2014 @ 15:34
    Jesper Olesen
    3

    Had a similar issue with our Umbraco installation.

    Problem turned out to be tied to the Javascript not hooking up on the form element correctly due to asp.net renaming the form ID's.
    I would suggest you take a look at your Web.config. To be more precise:

    <system.web>
    ...
    <pages enableEventValidation="false" clientIDMode="Predictable"

    If it's set to "AutoID" this exact problem occurs (As well as a few other bugs here and there in Umbraco backend)

  • Alan Ballard 1 post 21 karma points
    Jan 20, 2015 @ 20:42
    Alan Ballard
    0

    Thanks Jesper, that worked for me.

  • Stefan Kip 1608 posts 4100 karma points c-trib
    May 09, 2016 @ 10:09
    Stefan Kip
    0

    Thanks Jesper, removing the clientIDMode attribute worked for me too :-)

Please Sign in or register to post replies

Write your reply to:

Draft