Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Chris Mahoney 161 posts 299 karma points
    Apr 14, 2015 @ 00:04
    Chris Mahoney
    0

    Publish At not working

    Hi,

    I'm having problems (again) with Publish At. Here are the steps:

    1. Create a new page, add some content, Save and Publish.
    2. Open the published page in a new window or tab.
    3. Go back to Umbraco, edit the page, and set the Publish At a couple of minutes into the future.
    4. Click Save (not Save and Publish).
    5. Wait until the required time has elapsed.
    6. Switch back to the other tab and reload the page.

    At this point I should be seeing the new content, but it's still the old version. The properties of the page don't show it being published, and the audit trail also has no entry.

    Does anyone know what could be causing this?

    I'm using Umbraco 6.2.5 on a site that's been upgraded across countless versions (starting somewhere around 4.5).

  • Nicholas Westby 1893 posts 6332 karma points c-trib
    Apr 14, 2015 @ 00:40
    Nicholas Westby
    0

    There are two similar issues on the bug tracker:

    Maybe it's a bug or some non-obvious functionality (e.g., maybe it doesn't auto-publish in the future if you click "Save" rather than "Save and publish")?

    Can you reproduce this with a clean install of 6.2.5?

  • Chris Mahoney 161 posts 299 karma points
    Apr 14, 2015 @ 00:42
    Chris Mahoney
    1

    That first one (4809) was actually me :)

    I determined last year, with whatever the current version was at the time, that Save would work but Save and Publish wouldn't. Issue 5494 comes to the same conclusion. The behaviour seems to be different now, because Save isn't doing it either.

    I'll try a clean install and see what happens.

  • Chris Mahoney 161 posts 299 karma points
    Apr 14, 2015 @ 01:01
    Chris Mahoney
    0

    Interesting... it worked on a fresh install. Do you have any suggestions around where to start troubleshooting what could be wrong with the existing install?

  • Nicholas Westby 1893 posts 6332 karma points c-trib
    Apr 14, 2015 @ 01:49
    Nicholas Westby
    0

    You could perform a diff of the file system to see if maybe some files didn't get upgraded or if there are some extra files laying around. I like using WinMerge for this. Be sure to ignore the App_Data\TEMP folder.

    Could also be related to any packages you have installed.

    Could be that some properties on your node aren't passing validation.

    You might check if there are errors in your Umbraco error log (App_Data\Logs). Pay particular attention to any related to scheduled tasks or publishing.

  • Chris Mahoney 161 posts 299 karma points
    Apr 14, 2015 @ 03:13
    Chris Mahoney
    0

    Thanks for bringing the log to my attention. There are some relevant entries in there.

    2015-04-14 13:02:19,572 [29] ERROR Umbraco.Web.Scheduling.ScheduledPublishing - [Thread 25] An error occurred with the scheduled publishing. The base url used in the request was: https://www.mysite.nz:443/umbraco/, see http://our.umbraco.org/documentation/Using-Umbraco/Config-files/umbracoSettings/#ScheduledTasks documentation for details on setting a baseUrl if this is in error
    System.Net.WebException: The remote server returned an error: (404) Not Found.
       at System.Net.WebClient.UploadDataInternal(Uri address, String method, Byte[] data, WebRequest& request)
       at System.Net.WebClient.UploadString(Uri address, String method, String data)
       at Umbraco.Web.Scheduling.ScheduledPublishing.Run()

    That "base url" looks correct at a glance; is it in the correct format? Interestingly if I turn SSL off then I get a slightly different message:

    2015-04-14 13:06:12,548 [22] ERROR Umbraco.Web.Scheduling.ScheduledPublishing - [Thread 17] An error occurred with the scheduled publishing. The base url used in the request was: http://www.mysite.nz:443/umbraco/, see http://our.umbraco.org/documentation/Using-Umbraco/Config-files/umbracoSettings/#ScheduledTasks documentation for details on setting a baseUrl if this is in error
    System.Net.WebException: The operation has timed out
       at System.Net.WebClient.UploadDataInternal(Uri address, String method, Byte[] data, WebRequest& request)
       at System.Net.WebClient.UploadString(Uri address, String method, String data)
       at Umbraco.Web.Scheduling.ScheduledPublishing.Run()

    As you can see, it's still trying to use port 443 even with SSL turned off, which is bizarre (there's nothing explicitly set up in umbracoSettings.config). But regardless, with SSL on, that URL looks correct.

    Any ideas?

  • Chris Mahoney 161 posts 299 karma points
    Apr 14, 2015 @ 04:25
    Chris Mahoney
    0

    After looking at the code, it seems to be looking for https://www.mysite.nz:443/umbraco/RestServices/ScheduledPublish/Index, which does indeed return a 404. However, the same URL returns a 404 on the fresh Umbraco install too! Is that really expected behaviour?

  • Nicholas Westby 1893 posts 6332 karma points c-trib
    Apr 14, 2015 @ 16:16
    Nicholas Westby
    0

    Sounds a bit like this issue: http://issues.umbraco.org/issue/U4-6394

    And sounds similar to an issue I was having (I posted a comment near the bottom): http://issues.umbraco.org/issue/U4-5379

    It apparently only happens some of the time after an app pool restart. Maybe it has to do with the first URL being requested as HTTPS rather than HTTP? Not really sure, but maybe this is a deeper issue that hasn't really been fixed.

    By the way, it might be correct that that RestServices URL might return a 404 for a GET request (i.e., if you are navigating to it in your browser). It might only respond to POST requests. Not sure, but something to keep in mind.

    Note that I don't use "Publish At" so I don't know if what I've experienced is related to what you're experiencing.

  • Chris Mahoney 161 posts 299 karma points
    Apr 14, 2015 @ 22:02
    Chris Mahoney
    1

    So it seems that 404 errors aren't exactly uncommon!

    After seeing "greater than 6.1" in the other linked issue I had a look at the source to the last version of 6.0 and found that it doesn't use RestServices at all for scheduled publishing. I've modified my 6.2.5 to work in a similar way and it's working on my test server, so I might just bite the bullet and use that tweak on live too. There are no further 6.2 updates to break it! :)

  • Biagio Paruolo 1472 posts 1611 karma points c-trib
    Feb 08, 2016 @ 09:44
    Biagio Paruolo
    0

    I had problem with 6.2.4 with new IIS8.5 features enabled like alwaystartup, no recycling ( only one time a day ) and preload on.

    See: https://our.umbraco.org/forum/umbraco-7/using-umbraco-7/65355-Scheduled-Publishing-Error-404

Please Sign in or register to post replies

Write your reply to:

Draft