Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Trent Bielejeski 4 posts 22 karma points
    Jan 23, 2010 @ 03:48
    Trent Bielejeski
    0

    Date format in developer UI

    Is there a way to change the date formats on the properties page?

     

    Like

    Created
    30/04/2009 22:21:44  to  04/30/2009 22:21:44
    In the US the date format is mm/dd/ccyy
    Trent
  • Thomas Höhler 1237 posts 1709 karma points MVP
    Jan 23, 2010 @ 09:41
    Thomas Höhler
    0

    try adding the culture en-US into the web.config:

    <globalization requestEncoding="utf-8" responseEncoding="utf-8" culture="en-US" uiCulture="en-US" />

    hth

  • Immo Wache 69 posts 224 karma points
    Jan 23, 2010 @ 13:43
    Immo Wache
    0

    Hi Trent,

    go to /umbraco/config/lang and copy en.xml to us.xml. Open us.xml with an editor of your trust and change:

    <language alias="en" intName="English (uk)" localName="English" lcid="" culture="en-GB">
    
    

    into

    <language alias="us" intName="English (us)" localName="English" lcid="" culture="en-US">
    
    

    and save. Now you can go to User section open your user and select Language English (us). You will get US date format in Umbraco back office.

    HTH

  • Trent Bielejeski 4 posts 22 karma points
    Feb 09, 2010 @ 03:56
    Trent Bielejeski
    0

    that did work. Thank you.

    But it did kinda break the tinymce editor

     

    TinyMCE: Error loading language 'us'. Please download language pack from tinymce.moxiecode.com

     

    any ideas

    Trent

     

  • Sean Mooney 131 posts 158 karma points c-trib
    Feb 09, 2010 @ 14:28
    Sean Mooney
    2

    @Trent, I followed Immo's instructions but instead of creating a new file I just changed the existing (en.xml) one from

    <language alias="en" intName="English (uk)" localName="English" lcid="" culture="en-GB">

    to

    <language alias="en" intName="English (us)" localName="English" lcid="" culture="en-US">

    It fixed the date issue, and haven't noticed any problems.

    -Sean

  • Immo Wache 69 posts 224 karma points
    Feb 09, 2010 @ 16:42
    Immo Wache
    1

    Hi Trent,

    I think the way from Sean is much better and avoid the problems with TinyMCE3.

    For the case you need both en-US and en-GB languages you need to extend TinyMCE3 with the "us" Language. For this you need to copy and modify from en*.js to us*.js:

    /umbraco_client/tinymce3/langs/us.js
    /umbraco_client/tinymce3/themes/umbraco/langs/us.js
    /umbraco_client/tinymce3/themes/umbraco/langs/us_dlg.js
    /umbraco_client/tinymce3/plugins/table/langs/us_dlg.js
    /umbraco_client/tinymce3/plugins/paste/langs/us_dlg.js
    /umbraco_client/tinymce3/plugins/media/langs/us_dlg.js
    /umbraco_client/tinymce3/plugins/advhr/langs/us_dlg.js
    /umbraco_client/tinymce3/plugins/advimage/langs/us_dlg.js
    /umbraco_client/tinymce3/plugins/advlink/langs/us_dlg.js

    In each file you have to update language reference at the begin from en to us e.g. in tinymce3/langs/us.js.
    from:


    tinyMCE.addI18n({en:{

    to:


    tinyMCE.addI18n({us:{

    This is also the case for extending of Umbraco back office UI for an additional language.

    HTH, Immo

  • Funka! 398 posts 660 karma points
    Jan 10, 2012 @ 02:02
    Funka!
    0

    Hmmm, I know this topic was last touched last year, but I can't seem to get this to work -- we have a Date Picker field that is displaying Feb 3rd as 2012-02-03.  We would like this to say 02/03/2012 for our U.S. users.

    I copied the /umbraco/config/lang/en.xml file to us.xml and made the change as suggested. I did indeed find this new "language" in my user record, which I updated, but the date format has not changed in our Date Picker field. (I did notice that the "Created" publish-status dates in the "Properties" tab did change, so this is at least half a victory for us!)

    Thanks!

  • Funka! 398 posts 660 karma points
    Jan 10, 2012 @ 02:06
    Funka!
    0

    OK quick followup on somethin weird - After changing my admin user's language from English (UK) to English (US), it seems that my styles selector in the TinyMCE editor has an extraneous, bogus entry in it.  We usually keep just H3 and H4 styles defined in a special "CMS" stylesheet. However with the language changed, I now see a new option in this selection as follows:

    {#umbraco.style_select}

    If I change my user's language back to UK english, this weird CSS item goes away. I put it back to US english and it reappeared.

    I would love to see more consistency in how these dates are rendered across the back-office UI in a future release! (perhaps with a single setting somewhere, out of the box.)

    Thanks!

  • Frost 70 posts 99 karma points
    Feb 23, 2012 @ 10:05
    Frost
    0

    Any progress on this? We're stuck with a seriously buggy TinyMCE, as I noted here: http://our.umbraco.org/forum/using/ui-questions/29038-Change-Date-Format-in-Properties-Tab-(TinyMCE-bug)

  • Connie DeCinko 931 posts 1159 karma points
    Mar 23, 2012 @ 19:41
    Connie DeCinko
    0

    Did the change to en.xml and most looks good.  However, date pickers show their results as yyyy-mm-dd.  Anyway to change that format?

     

  • Phillip H. Blanton 1 post 21 karma points
    Dec 17, 2012 @ 04:51
    Phillip H. Blanton
    0

    Thanks! This solved my problem too.

  • Connie DeCinko 931 posts 1159 karma points
    Dec 21, 2012 @ 18:13
    Connie DeCinko
    0

    Hello?  Anyone figure out how to fix the date display in a date picker?

     

  • Oscar Jurado 5 posts 25 karma points
    Nov 28, 2013 @ 20:42
Please Sign in or register to post replies

Write your reply to:

Draft