Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Connie DeCinko 931 posts 1159 karma points
    Nov 13, 2015 @ 15:24
    Connie DeCinko
    0

    Publishing extremely slow

    Recent upgrade to Umbraco v.4.11.10. Site seems to perform just fine. However, publishing is a nightmare. It was working fine prior to the upgrade. Now, it takes several minutes for a simple page to publish. I've cleaned up old versions of content, checked for orphan content nodes and reindexed the Examine search collections.

    If I republish a folder with say 7 documents, I see Umbraco step through all 7 fairly quickly, however when it gets to the last document, the publish dialog stays open for 3 to 5 minutes, every time.

    What could be causing this?

  • Per Olsson 47 posts 306 karma points
    Nov 13, 2015 @ 15:45
    Per Olsson
    1

    Try to delete the umbraco.config file and republish the site in case there is some problem with the XML cache.

    I never trust the Examine reindex tool so try to delete \App_Data\TEMP\ClientDependency manually instead and republish.

    Nicholas also have a nice guide here to disable Examine to rule out the issue: https://our.umbraco.org/forum/umbraco-7/using-umbraco-7/72898-faster-way-to-publish-a-large-number-of-nodes#comment-233951

    As always, keep backups before you do something.

  • Connie DeCinko 931 posts 1159 karma points
    Nov 13, 2015 @ 21:58
    Connie DeCinko
    0

    Figured out the cause. web.config had the wrong SMTP address, the one from dev instead of prod. Corrected it and now all is good. Apparently Umbraco was having fits trying to send the email confirmations and choked on an incorrect SMTP server setting.

Please Sign in or register to post replies

Write your reply to:

Draft