Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Disham Parikh 5 posts 75 karma points
    Feb 04, 2016 @ 07:44
    Disham Parikh
    0

    Examine not able to search the word "IT"

    Hi,

    I came across some weird issue, I am using Examine to search my content. My contents are having three "dropdownList Multiple" property countrylist, industrylist and technologylist. among which industrylist dropdown have value "IT", Examine search working great for all the word search except the word "IT", i tried to use wildcard search as well e.g.(industrylist:i*), but examine showing me "No result found".

    Please note that, i have two contents which industrylist's prevalue is "IT" and still is showing me "No result found".

    Possible solution could be, i can search by prevalue's ID, but i don't know how can i search by prevalue ID using examine.

    Please let me know possible solution.

    Regards,

    Disham

  • Ismail Mayat 4286 posts 9245 karma points MVP 2x admin c-trib
    Feb 04, 2016 @ 07:55
    Ismail Mayat
    1

    Disham,

    I suspect you are using external index which uses standard analyser which will strip stopwords namely common words which are just noise e.g it, and the etc.

    If you do a search on the forums I recall Barry Fogarty worked around it as he had very similar issue to you unfortunately on a train at the moment.

    Regards

    Ismail

  • Disham Parikh 5 posts 75 karma points
    Feb 04, 2016 @ 08:41
    Disham Parikh
    0

    Thanks Ismail, your hint worked for me.

    following post of Barry Fogarty helped me to solve my issue.

    https://our.umbraco.org/forum/developers/extending-umbraco/25600-Examine-case-insensitive-keyword-search

    Creating custom analyzer solved my issue.

    Many thanks.

Please Sign in or register to post replies

Write your reply to:

Draft