Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Chris Mahoney 165 posts 303 karma points
    Feb 18, 2016 @ 01:26
    Chris Mahoney

    Always show "triangles" when creating links

    Apologies if this has already been posted; I don't know the proper name for the triangles that I'm asking about :)

    In Umbraco 7.3 and 7.4, when creating a link from the RTE you get a panel on the right-hand side of the screen. At the bottom of the options is an item called "Home". This is actually an expandable sitemap but that's not obvious unless you move the pointer over it, which causes a triangle to appear to the left (showing that it can expand).

    Is there any way to make the triangle always show up, or some other way of making this feature more "discoverable"? I've had multiple editors ask how to link to other pages; a label simply saying "Home" isn't very user-friendly so I'd love to improve this if I can. Is there a setting somewhere?

  • Jan Skovgaard 11245 posts 23441 karma points MVP 6x admin c-trib
    Feb 18, 2016 @ 05:10
    Jan Skovgaard

    Hi Craig

    Perhaps it's a good idea to raise this issue on the issue tracker with a UX label or feature request label to make people aware that it can be an issue and something that might need some TLC in the core.

    You should be able to overwrite Umbraco's styling by including your own stylesheet like Matt writes about here in the section "Custom CSS"

    I would use the browser's DOM inspector and figure out the class and html structure and then create a CSS rule to ensure that the triangle icon is always visible.

    Hope this makes sense :)


  • Chris Mahoney 165 posts 303 karma points
    Feb 18, 2016 @ 19:31
    Chris Mahoney

    Thanks; I had no idea that you could override the CSS in the backoffice.

    For anyone else that wants to accomplish the same thing, this is all you need:

    .umb-tree ins { visibility: visible; }
Please Sign in or register to post replies

Write your reply to: