Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Christophe 23 posts 43 karma points
    Mar 01, 2010 @ 16:12
    Christophe
    0

    Extending Session Timeout

    Hello,

    I would like to know where there is a setting for extending the session timeout while editing the content and development.  The annoying thing is that it does not give you a warning and will log you out losing your work if you didn't save.  I understand it is for security but right now it is just me and I get frustrated I have to log back in after I go get a drink.

    I am a novice so it might frustrating for you if I don't understand (I'm even more a novice in ASP.NET and I have a hunch the answer way lay there.

    Thank you in advance.  Merci d'avance.

    Christophe

  • Richard Soeteman 3597 posts 10924 karma points MVP
    Mar 01, 2010 @ 17:01
    Richard Soeteman
    0

    Hi,

    You might want to checkout the attribute executionTimeout of the HTTPRuntime element in your web.config file. This is the configuration file for asp.net applications so also for Umbraco. Find more info at http://msdn.microsoft.com/en-us/library/e1f13641.aspx

    Cheers,

    Richard

  • Martin Kyukov 26 posts 176 karma points
    Jan 23, 2017 @ 12:11
    Martin Kyukov
    0

    The link is dead.

  • Tim Watts 90 posts 392 karma points
    Jan 23, 2017 @ 15:15
    Tim Watts
    1

    Martin,

    This link should give you the information you need: https://msdn.microsoft.com/en-us/library/e1f13641(v=vs.100).aspx

    Microsoft have marked this one as archived, but the recommended link is the broken one which was originally posted!

    Just in case the link disappears again, it says that the default value for ExecutionTimeout is 110 seconds. The value is ignored if <system.web><compilation debug="true">

    Tim

  • Martin Kyukov 26 posts 176 karma points
    Jan 23, 2017 @ 15:19
    Martin Kyukov
    0

    Your reply is much appreciated!

  • Simon Dingley 1388 posts 3239 karma points c-trib
    Mar 01, 2010 @ 17:19
    Simon Dingley
    7

    There is an appsetting in your web.config that you may also want to try changing:

    <add key="umbracoTimeOutInMinutes" value="20" />
  • Christophe 23 posts 43 karma points
    Mar 01, 2010 @ 17:34
    Christophe
    0

    Thank you so much for your response.

    Pardon my ignorance, but I assume the change needs to be made on ASP.NAT on the server, correct. Because I do not host or manage the server.  A pro set up the site for me to manage just the content but I turned developer and am having fun.  All I have access to is Umbraco.

    If that's the case (it is on the server) should I ask the guys to change that?

    Thank you so much again.

  • Simon Dingley 1388 posts 3239 karma points c-trib
    Mar 01, 2010 @ 18:26
    Simon Dingley
    1

    Both of the suggested settings can made in the web.config file located in the root of your website. You can make the can make the changes using any plain-text editor such as notepad.

  • Christophe 23 posts 43 karma points
    Mar 01, 2010 @ 18:31
    Christophe
    0

    I got it.  Thanks for your help.  I appreciate it!

  • Simon Dingley 1388 posts 3239 karma points c-trib
    Mar 02, 2010 @ 13:03
    Simon Dingley
    0

    Christophe, please mark the thread as solved by clicking the tick against the response that you used or if you used more than one of the solutions give them a thumbs up ;)

  • Murray Roke 452 posts 839 karma points c-trib
    Jul 07, 2010 @ 02:01
    Murray Roke
    0

    I thought the  'keepalive' iFrame would prevent you getting logged out?

    We also have observed users getting logged out after for example 25 min of inactivity.

    Looking at the code, i see that if the keepalive iFrame fails once it will stay broken.

    I've added this as an issue to codeplex here http://umbraco.codeplex.com/workitem/27994

Please Sign in or register to post replies

Write your reply to:

Draft