Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Sander van de Pas 62 posts 122 karma points
    Apr 15, 2010 @ 16:00
    Sander van de Pas
    0

    ZIP Upload problem

    Hi,

    I have a site with Umbraco 4.0.2.1 installed on it and I’ve installed the ZIP Upload package.

    When I want to upload a zip, with only pdf files (no folders), it gets the following error:

    Server Error in ‘/’ Application.

    Wrong Local header signature: 0×21726152

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: ICSharpCode.SharpZipLib.Zip.ZipException: Wrong Local header signature: 0×21726152

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [ZipException: Wrong Local header signature: 0×21726152]
    ICSharpCode.SharpZipLib.Zip.ZipInputStream.GetNextEntry() 1166
    Nibble.Umb.ZipUpload.zipupload.Button1_Click(Object sender, EventArgs e) 7011
    System.Web.UI.WebControls.Button.OnClick(EventArgs e) 111
    System.Web.UI.WebControls.Button.RaisePostBackEvent(String eventArgument) 110
    System.Web.UI.WebControls.Button.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument) 10
    System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) 13
    System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData) 36
    System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) 1565

    Do you have any idea why it happens?

    Thanx,
    Sander

  • Jeroen Breuer 4860 posts 12121 karma points MVP 3x admin c-trib
    Apr 22, 2010 @ 13:44
    Jeroen Breuer
    0

    It's about the ZIP upload created by Tim Geyssens: http://www.nibble.be/?p=55. Doesn't anybody know how to solve this problem?

  • Stefan Kip 1578 posts 4013 karma points c-trib
    Apr 22, 2010 @ 13:46
    Stefan Kip
    0

    I guess the zip file is invalid.

    Can you test with a clean (self created) zip file (with one text file or similar)?

  • Sander van de Pas 62 posts 122 karma points
    Apr 22, 2010 @ 14:16
    Sander van de Pas
    0

    I think the ZIP file wasn't correct. Tried it with a new created zip and then it worked!

    Thanx.

Please Sign in or register to post replies

Write your reply to:

Draft